Jump to content
PVA - Jim

macOS Mojave (10.14) Compatibility

Recommended Posts

Honestly,

I only use Dark Mode in Linux with KDE Desktop.

Even in Elementary OS and other Gnome Desktop Linux I still prefer bright mode.

The least dark mode I like is macOS with its ugly border lines, tried it a few times

but never used it again.

Windows dark options are ok too but I use bright anyway.

 

The biggest problem with dark mode is Standard Content in Browser, HTML Mail

or just other Apps like VW that don't support it anyway.

Then the contrast is just too much, opposed to white content in standard bright gray

UIs. And it is not much of a problem to use darker UI Apps like Cinema or Modo in

their full screen on a bright mode OS UI.

Share this post


Link to post

Same with the dynamic Dune in macOS.

I deactivated it soon simply because it irritates me when I notice the changing

Brightness when it is changing frames. But my main problem is that it doesn't

fit your bright or dark mode for half of your working time.

 

But what I do is using multiple Screen Spaces for different App types and it seems

that I adapted their background brightnesses to the corresponding Apps.

like darker Background for my 3D Apps like Modo, Blende  and Cinema, brighter

Backgrounds for CAD Apps like VW or Bricscad and such.

Share this post


Link to post

Still having issues with Mojave. Was using 2019SP2, and would have vwx hang when editing callouts. Switched back to 2018 SP5, and having similar issues with truss labeling tool. I thought VWX was supposed to work with Mojave now?

 

Share this post


Link to post
1 hour ago, MSLD said:

using 2019SP2, and would have vwx hang when editing callouts.

 

Hi MSLD, 

  • Does this occur every time you edit a callout, or sporadically? 
  • Can you incur this issue using a File > New... > 'New blank document'… 
    • …while your aforementioned file is open?
    • …after restarting Vectorworks and when your aforementioned file is closed?  

Share this post


Link to post

@hh_berlin I have found other bugs as i was starting to use it everyday. So it's still not fit for our office roll out IMO. 
Inserting stairs beachballs and bombs sometimes. There are a few other slow downs/hang ups while it processes data. Will note them next time. Don't get me wrong, is usable, but you may encounter issues. Due to that, we are still sticking to OSX High Sierra and 2018.

 

EDIT: Inserting symbols into a drawing gets very slow on occasions, also the quick click icons (auto join walls) etc do not stay enabled after each restart. Will record any others I find. 
EDIT1: Complete application quit when changing the bearing height of a roof. Not every-time though.

Edited by ptoner

Share this post


Link to post

I keep getting the pester to update to Mojave & have not updated. As this thread is 11 pages long I'm still really wary of doing so. Is the advice to avoid Mojave until VW2020?

Share this post


Link to post

For me and my current 3D work with Symbols,

VW 2019 and Mojave work pretty well.

Yes, there were certain Hickups with OpenGL and Selections

in between, but even had no need to restart VW so far ....

Share this post


Link to post

OK, there was an Undo Crash.

 

But beside that, I "Purged" the whole day without any crash !

Share this post


Link to post

framing member now hangs with latest mojave update when trying to use custom symbols (on blank and existing drawings)

(after trying to select it - looks like the object info panel dialogue is causing the problem) had a similar problem with drawing labels.

 

what a disaster 2019 is.....

  • Like 1

Share this post


Link to post
On 12/15/2018 at 3:14 PM, fabrica said:

what a disaster 2019 is.....

Its the reason why none of the 40+ users in my office have been upgraded to Mojave yet. VW 2019 is still buggy. I cant upgrade them or get them to use 2018 either, as support for that is further behind and I do not want to bug test that as well, doubling up on my already beefed up workloads. 

Share this post


Link to post

I am only two users here. However the 40+ hours lost from making the switch hurts badly. Our mistake was to update to Mojave without checking.  However, whereas I received several emails reminding me to update the VW annual subsription, none told me not to update OSX.  To say ‘check our website’  makes sense if the supplier never contacts users directly. VW  did contact me but about the Service Select subscription only. 

  • Like 1

Share this post


Link to post

I have not upgraded to Mojave (and would like to), 2019 won't render properly for me at all, went back to 2018. 

Share this post


Link to post
10 minutes ago, SVA Architects said:

Deleting a 90deg filled arc today sent VW into a 10 minute spinning ball freeze

What I am finding is that these bugs do not happen every single time, just randomly.

People who use the app for drawing, daily, are the ones who identify these bugs. 

Today i had a couple for example.

1. Object info pane randomly adding 3 x 0's to all dimensions that i would input.

2. Opening a saved view crashed the app straight out. (first time that has happened)

Edited by ptoner

Share this post


Link to post
2 hours ago, ptoner said:

What I am finding is that these bugs do not happen every single time, just randomly.

People who use the app for drawing, daily, are the ones who identify these bugs. 

Today i had a couple for example.

1. Object info pane randomly adding 3 x 0's to all dimensions that i would input.

2. Opening a saved view crashed the app straight out. (first time that has happened)

 

Share this post


Link to post

Yeah that spinning is constant with differing sources/causes. 
Yesterday I had multiple crashes/spinning for 10mins, when selecting a text box on the drawing. 
It maddening how poor support is from Apple, yet i find it an easy excuse to throw everything at their door too. Either VW left these bugs so late, that Apple have not gotten round to fix them yet or Apple do not want to know, cause they should have the man power. 
I am aware that other CAD packages have similar issues with Apple and Mojave support, though maybe not as extreme.

Edited by ptoner

Share this post


Link to post

I had many lockups (outside of VW) with Mojave on my 2013 MBP until I did a reformat and restore from time machine. The machine would simply stop responding (but the mouse would continue to move). After 30-60s (sometimes longer) it would process all the keyboard and click buffers and go back to normal. This got progressively worse and worse until I couldn't use the machine for much at all, and I did the reformat. This only happened on my laptop. The MacPro tower has been fine. I have experienced a few crashes with VW, but nothing consistent or identifiable as to source.

YMMV.

Edited by JohnAthayde

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...