Jump to content
  • 1
Tom Klaber

BUG -Auto-Pan No Longer Working

PVA - Jim

Filed as VB-153889

Message added by PVA - Jim

Question

Selecting objects and then moving the objects and mouse to the edge of the screen used to result in auto panning the drawing in that direction - allowing you to drag objects to other parts of the drawing.  This does not seem to be working in 2019

  • Like 1

Share this post


Link to post

14 answers to this question

Recommended Posts

  • 0

Same here.

 

Been trying to think of a good way to describe it. Auto-pan seems to do the trick!

Share this post


Link to post
  • 0

Oh my god !

It's true.

 

I was never happier about any Bug before. Please don't fix it (*)

Finally the upgrade is worth.

I found that previous behavior SO distracting.

 

(*) if ever fixing, please as an OPTION setting.

(Or maybe that already is and off by default ?)

  • Laugh 1

Share this post


Link to post
  • 0

My dreams ended quickly.

1st because that moved into the Known Issue Area and

2nd because it does not work reliably in that new fashion.

 

Tested with Rectangle Tool fine first but Screen will jump when

in Line creation anyway(*). Just not controllable.

 

(*) So even an SP>0 embargo from my side would not really help ....

Edited by zoomer

Share this post


Link to post
  • 0
3 minutes ago, Tom Klaber said:

@zoomer haha.  BOOOOO - Zooomer booo.  I drag stuff around all the time.... I am detailing now and it is driving me CRAZY.  


It's making me bonkers. It apparently popped up right in the release build, as I would have stumbled over this heavily creating videos. 

I'm all for an option to disable the scrolling, but I needs my scrolling edges back.

  • Like 2

Share this post


Link to post
  • 0

If I drag hard to the left then the Auto-Pan will work, hard to the right, then it won't.  However, if I hover about 3-4mm away from the edge, (where my OIP is located) then it works fine(-ish)

 

Could this be an issue with the OIP. When I replace the OIP with the navigation Palette it all works as expected.

  • Like 1

Share this post


Link to post
  • 0

It is apparently related to a fix that allowed the dragging of objects between mutliview panes. I am able to alter it as well by changing which palettes are docked where. Engineering already acknowledged this one and is working on a fix currently.

Share this post


Link to post
  • 0

I noticed this the other day. At the time I wasn't sure if it was a bug or because I was drafting with my laptop trackpad for the first time in a while. Glad to hear it will be fixed.

 

Kevin

  • Like 1

Share this post


Link to post
  • 0

I've just tried it here and it all works as it used to. You do need to "hover" ever so slightly on the area where the rulers are, but that seems like its intended and makes sense to me...

  • Like 1

Share this post


Link to post
  • 0

Correct, this SHOULD already be fixed as of 2019 SP2. But as mentioned above the mouse has to stop near the edge it can't just go over a palette, this is to prevent accidental scrolling, prevent scrolling when you mouse out of the drawing area to enter an OIP value, to another monitor, or if you have multiview enabled.

However, we have indeed decided that the auto scroll area is a bit too small and we will be changing the behavior again in the next SP to make it more comfortable like it used to be without still allowing for errors.

Share this post


Link to post
  • 0

Hmmm, I see what you mean - it *kinda* works, but definitely not the same way that it used to. If you hover in that few-pixels-wide border zone near the edge of the screen, after a delay, it auto-pans. But that's very different from the previous behavior, which was activated as soon as the cursor reached the edge of the screen.

At the very minimum it would really be great if there was a toggle for something like this....trying to hover in that area with a trackpad or with a bunch of things snapping near the edge is rather tricky...

Share this post


Link to post
  • 0
On 1/4/2019 at 9:16 AM, Dan Hoffman said:

Hmmm, I see what you mean - it *kinda* works, but definitely not the same way that it used to. If you hover in that few-pixels-wide border zone near the edge of the screen, after a delay, it auto-pans. But that's very different from the previous behavior, which was activated as soon as the cursor reached the edge of the screen.

At the very minimum it would really be great if there was a toggle for something like this....trying to hover in that area with a trackpad or with a bunch of things snapping near the edge is rather tricky...

 

Perhaps not only toggle but to allow adjustment in preferences of the time delay that initiates the auto scroll. This should help account for differences in mouse/trackball, etc. sensitivity settings.

 

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×