Jump to content
Andy M

Green Border appears around Viewports

Recommended Posts

HI All,

I am using VW2011 and am stumped by the appearnace of green borders around my viewports.

Could someone please tell me why a green border appears around my viewports. I can select this border , but is only called a rectangle ion the OIP, so its hard for me to figure what it is and why they appear, and furthermore how do I turn them off so they don't appear.

thanks for your time

regards

Andy

Share this post


Link to post

Andy

I've never been able to make it happen myself, but I've watched it happen to someone else. I thought it was just him!

Do you normally use Edit Design layer from a SLVP and jump around a lot while in that editing mode?

mk

Share this post


Link to post

Right click on a VP and click Edit

You should see a tick box with

Add Reference Crop Object

If ticked it will place a green Reference Crop Object on your DL

Share this post


Link to post

HI Mk,

yes.

I edit the viewports in the sheet layer. Selecting Design layer and then Ok I am now at the design layer which has the green border around the page, then when I select Return to Viewport... back to the sheet layer, I now have a green border around the viewport on the Sheet layer, which wasn't there before.

The more times I do this same procedure the more green borders will appear stacked onto of the earlier green borders.

The only way to get rid of these is to select them on the design layer and delete them..

Is slightly annoying..

Any help appreciated.

thanks

Andy

Share this post


Link to post

On your viewport, when you choose to Edit Design Layer, make sure you uncheck Add Reference Crop Object. It is this that is drawing the green rectangles, as Ozzie said above.

It can be really useful, but if you don't want them,they are a pain!

Share this post


Link to post

Add Reference Crop can be really useful as Tamsin says

The trick is if you use it - go back to Edit and untick it

I think when used it should have a pop up - Use Once Only as a user choice

Share this post


Link to post

A clarification, please? I've seen that option "edit design layer" while working on a sheet layer. The way I though one needed to make changes to a viewport on a sheet layer was to return to the VPs design layer, make my changes, return to the sheet layer and update my viewport. Is the edit design layer option only a quick way to do the same thing?

Marshall

Share this post


Link to post

The problem I have always had with this, is unchecking the box does not delete the green line . You have to manually delete it.

I do not use them much but they can be handy.

Share this post


Link to post

Yes, it is a shortcut between the VP and the DL. If the Return to Viewport option is not enabled in the dialog, then you have to manually navigate back to the VP.

And, yes, the unwanted green boxes have to be manually deleted from the design layer. There will be stack of green boxes, on for each time the DL was accessed via the Edit VP dialog.

-B

Share this post


Link to post

Hi...

Also; By using the VP to get to the DL, you have the option of showing the VP attributes in the DL, as opposed to the documents current attributes (visibilities of layers, classes, render modes, orientation, view, etc)... so, it's more than JUST a shortcut!

Remember though... have Return to VP checked, or you may have stuff turned on/off, which you don't want/want to see. This is sometimes a pain to get back to your preferred visibilities of layers/classes in DL mode.

Share this post


Link to post

I am having the same issue, and I have tried unchecking the Add reference box and have gone in manually to delete them. I have also deleted and recreated the viewports and they just keep showing up without me having navigated to the DL through the VP. Is there a preference I can change or something I can do to stop them from appearing altogether? Its driving me insane!!!

Share this post


Link to post

ehandelm - An idea: Make sure you deleted all the unwanted green boxes. It is possible that class and view settings make some of the green boxes invisible in some views, but visible in other views. As Farookey points out it is possible to navigate from Viewport to Design Layer and end up changing the layer view settings to the viewport settings - the green boxes may be present but invisible. Accessing the same DL by other means with different view settings could reveal the green boxes.

Hope you get this solved!

-B

Share this post


Link to post

Thank you so much! I could not figure out how to get rid of that green box until now!

Share this post


Link to post

I know that this is a very old thread, but I have the same issue of a green border around my viewport in a screen layer. This appeared when I ticked the 'Add reference crop object option' but when I untick this the green border is still there. I have tried to delete this in the design layer, as mentioned above, but it is not there.

 

How can I get rid of this annoying thing?

Screenshot 2019-09-26 at 11.01.06.png

Share this post


Link to post
15 hours ago, jeremyb said:

I have tried to delete this in the design layer, as mentioned above, but it is not there.

 

It will be on one of the design layers that are visible in that viewport. If, from your viewport you go edit design layers it should be on one of the visible design layers. If you still can't find it try turning on all your classes and going through your visible design layers one at a time.

Share this post


Link to post

Hi, that’s because the green line went on a class that is turned off.

click the visibility tool / visible mode and hold the v keyboard button down and all classes will be turned on temporarily,

Mouse over the green line to se what class it’s on.

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...