Jump to content
Andrew Davies

3DConnexion Mouse

Recommended Posts

...one more observation: it doesn't look like VW will recognize input from more than one SN axis at a time, e.g. in Walkthrough, I can't move to the side and rotate my direction of view simultaneously – this makes for a very jerky experience, and might be part of the reason why zoomer gets woozy while using this mode (me too, a little). I checked Sketchup, and it's able to respond to multi-axial input smoothly and predictably, and I think that's in part why if feels so much more natural and easy.

This ^^^^ 100%. VW doesn't appear to be engineered to handle full-range multi-axis input, resulting in a clunky user experience that negates half the benefit of having a 3D pointing device in the first place.

Look forward to seeing what the future brings, hopefully in VW2017 or at least VW2018, 3D nav will "just work" the way it does in Sketchup & other 3D apps.

Edited by Gilbert Osmond

Share this post


Link to post

currently the 3D bubble works (3 axis in Flayover, 6 axis in walkthrough)

You can switch between these and some other modes by the menu button.

You can use all left side Shift/Alt/Tab/... buttons.

You can assign shortcuts to all 12 "display" buttons.

You can use "Macros" to see a proper text name for your commands on display.

(But Macros are globally, so they will add 12 times for each App you assign.

I use prefixes in the name)

The right hand side View Buttons and Icons don't work currently.

It will unwanted awake your Mac from time to time and prevents falling a sleep

again. It sometimes instantly awakes your Mac when you switch to sleep and you

will need 2-3 attempts.

I have set VW and Modo custom settings.

Still not sure what I should assign for C4D with its double key shortcuts.

I also recommend the CADMouse kit.

Movements and middle mouse button are great.

For VW I have X (Selection) on the forward button, Fit View on the backward button.

Share this post


Link to post

Icons are already a planned feature, it just a question of whether it will be ready in time for 2017 or not. The plan is to allow them for both Mac and Windows as soon as possible, I think for Mac we may have to wait until the feature is implemented by 3dconnexion.

We're of the same opinion that the majority of users of any design software would prefer a visual indicator for a tool rather than just text.

Share this post


Link to post

Engineering would like me to encourage all SpaceNavigator users (or prospective users) that have a Mac to push 3DConnexion for icons to be added, or for any other non-equal functionality compared to Windows functions:

http://www.3dconnexion.com/forum/viewforum.php?f=23&sid=4944c239bb817805e3576c46fb0ec96d

A friendly nudge, if you will.

  • Like 1

Share this post


Link to post
Thanks zoomer,

Your description of how it currently works is kind of what I thought. except for "Macros are globally, so they will add 12 times for each App you assign" I am not really sure what you mean by that.

I meant that you will "macro" your 12 Display Buttons for an App to get a usable

text on your display.

Normally you will add an App to the settings, if not already there, and do your

custom settings to that App. If you define another App you will have a complete

separate list of settings.

Other for the Macros Tab where you add your Macros/Functions.

Thesewill all appear in all Apps.

So if you created 12 Macros for VW and want to do the same for C4D, you will

create another 12 Macros in the list. If you finally assign your buttons in the

App settings and chose "Run Macro" with the available Macro option list, you will

see and have to sort Macros for VW and C4D

When they show the demos on their site it appears the 12 icons change depending on which tool is chosen in the program they are using. So for example, if the wall tool is chosen, I would like to see the upper tool bar icons appear (the 4 line control modes, wall preferences, etc), If I then switch to the polyline tool then the icons would switch to all the vertex modes, etc.

I thought that too at first.

But if you look closely you will notice that it is just 2 screenshots of both

currently supported Apps.

So I think just 12 Display Buttons per App. (At least for now)

If the button never changes you can get by on text because eventually you memorize the command based on its position (not the text) but if these buttons are constantly changing and all the text on the buttons need to be read each time, I'd rather just use a keyboard shortcut.

Yes of course you can.

Former Space Pilots haven't even had a display and you could use them too.

It is just for the learning period to have a readable Text instead of showing all

12 Buttons Symbols just "Keystroke SHIF...."

Share this post


Link to post

But if you look even closer and play the movie below the 2 screen shots it shows the tools switching within the same program which means when fully supported by the program you have much more then the static 12 buttons. I am hoping Vectorworks will act like the program in the video at some point in time.

Wow, you have to look very closely - or the right video.

Indeed, more Tools depending on geometry selection.

And I think the only way it Enterprise and its display makes really sense.

BTW,

in this way, VW supporting Enterprise means to order Tools, in a way which

isn't currently available in VW itself.

But no problem so far on OS X - there are only 12 buttons :)

Share this post


Link to post
On 9/14/2016 at 1:49 PM, Altivec said:

... Its been almost a couple of weeks past my second email and I have yet to receive a reply.  In fact, the moderator on their board hasn't replied to any post Since Aug 25th.  As much as I want one of these things, I am really turned off by their neglect.  If you can't even answer a simple question to make a sale, I can't even imagine what it would be like to deal with these guys if I actually have a problem with the thing. ...

After buying a used SpacePilot Pro (part #3DX-600037) about 4 or 6 months ago I had reason to call 3Dconnexion's live tech support for assistance w/ Vectorworks/Mac compatibility. My impression is that tech support consists of just 1 fellow who may have other job resposibilities and/or be an engineer (?). There was a notable air of condescension in his tone, really did not seem very interested in helping.  Hard to assess based on one data point, perhaps the company is doing so well in other markets that it doesn't need VW users.  Admittedly I *did* buy the unit second-hand but still, this is not some consumer widget for which tech-support is just a money-losing afterthought.  Anyone who invests in 3dConnexion pointing device is likely to be the kind of person who passes along opinions of the product & the company to other potential buyers. I'm sure the market for high-performance multi-axis input devices in the CAD space is far from being saturated. 3DConnexion ought perhaps be more concerned not only with their product but with their company image & reputation for follow-up support.

I did not find the SpacePilot Pro usable in VW2016. I haven't yet upgraded to the latest 3Dconnexion driver, nor VW2017. After I do both (when VW2017 SP1 is released) I will report back on this thread w/ my experiences and remarks.

Edited by Gilbert Osmond

Share this post


Link to post
1 hour ago, Gilbert Osmond said:

My impression is that tech support consists of just 1 fellow who may have other job resposibilities and/or be an engineer (?).

I think there are at least 2 of them :)
And they sound like engineers which i think is quite good.

I also understand it it is not very easy to keep those devices running on all platforms and Apps
and I fear especially OS X will be even worse. (If I regard my MadCatz Mouse support on OS X)
So Support afford to Business ratio may not be ideal for them anyway.

I am more a kind of early adopter.
But if you care about that, I think it is better to wait until something works already.

Share this post


Link to post

Just heard word related to this topic internally: The engineering team working on this is waiting on a config file release from 3Dconnexion to push the enhancements built into 2017, management is working with their people now to get this rolled out as soon as possible. Currently the main issue is that Windows has more features available than the Mac side because of the aforementioned restrictions on that OS, we are trying to find a way around this limitation.

  • Like 2

Share this post


Link to post

My base model was delivered today.  Simple set up.....kept loosing my model but the VW menu buttons soon got this back to where it was.....I think once I have mastered the sensitivity of the item it will be fantastic....take a while to get use to using the mouse and the space navigator as I am left handed using it in the right hand is a bit cumbersome at the moment but that will improve with time

 

one thing the zoom in and zoom out worked ok with 2017 but doesn't work with 2016 

i notice there is an option to download a plug in 

do I need to download this to use with VW as well as the drivers I downloaded when I first set the SN up

 

any advice would be appreciated especially the settings for the left and right buttons.  

 

Thanks 

Share this post


Link to post

Just got word from the 3Dconnexion folk:

There will be a driver update released within a few days for the Mac, driver version 10.4.2 which will include some stability improvements, but not yet the full configuration profile work done by Vectorworks. The Vectorworks-specific compatibility updates will come in the next version of the driver, 10.4.3 which is not too far off.

  • Like 1

Share this post


Link to post

In case this is useful for anyone else -

 

I'm on a mac and on VW2017, and currently using the latest (10.4.2) driver from 3Dconnexion.

 

Up until now I've been using the "SpacePilot", one of these:

Screen Shot 2016-11-07 at 13.08.17.jpg

I could get hold of one S/H relatively cheap so got it to try it out even though it's not officially supported for mac, and is not one of the current models. The joystick works but not the screen and none of the buttons except for "1" which toggles between modes (walkthrough/flyover etc). Used it for a while in 2016, with the VW recommended settings. For me definitely a worthwhile investment, now use it quite heavily during 3D work.

 

With an upgrade to VW2017 certain things changed and motion became a bit jerky in certain situations; I've detailed this issue on this thread -

 

As of today I've upgraded to a current model, the "SpacePilot Pro" - this one:

 

Screen Shot 2016-11-07 at 13.14.01.jpg

 

This was partly driven by a hope that maybe the jerky motion might disappear with a more up to date model (quick answer: it's worse) but also so I could start to make use of the buttons.

 

Have now spent a little time messing around with it. It took me a while to work out how to toggle between modes - it turns out that it's by the "menu" key (it was via a previous post in this thread that I discovered this). Assigning shortcuts and functions to the various buttons works generally as expected even if this process is not hugely user-friendly. Assigned functions do show up on the screen, although, where they are assigned as keyboard shortcuts they rather un-usefully appear as "shift-K" etc rather than a descriptor of the actual tool function. This is as per discussion further up the thread and I agree with the comments already made.

 

I feel that having the buttons is useful. If only because at this stage they potentially offer a workaround for the problem I describe in my thread linked above - when zoomed-in I can easily use a shortcut button on the Spacepilot to flip into "Translate" mode and then use the mouse to pan around smoothly when looking at small details.

 

However, it seems that the general quality of motion is worse than on the older model. On the older SpacePilot, ignoring the problem of jerkiness when zoomed-in, generally the motion is fairly smooth. On the new one, it i snot smooth but jittery, as if the image is being refreshed at a lower framerate. Why this should be I have no idea. But maybe is part of the reason why someone further up the thread said they felt it was unusable at present. I can potentially post a short screen recording if anyone wants to see what the difference looks like.

 

So, for now, unless I find a way of fixing this jittery motion I think I am going to have to revert to the older model.

 

By the way as a general comment - when you first start using these things it's quite confusing to work out what's going on and how it interacts with the flyover/walkthrough modes selectable as tools in the visualisation pallette. When you use the SpacePilot to move around, the cursor turns to the flyover symbol, but in reality the mode you are operating in has nothing to do with what's selected in the visualisation pallette - the mode in which the spacepilot operates is determined by toggling through its own modes (in VW2017 called "helicopter", "camera target mode" and others) which are different from the walkthrough/flyover/translate modes that apply when using a conventional mouse. As someone further up said, the spacepilot should do its own thing, with the cursor remaining in whatever mode is currently active - for example the pointer tool. It's the currently active cursor symbol that reappears when you take your hand off the joystick - the misleading "flyover" symbol only appears whilst you're moving the joystick. Confusing.

 

Also for the benefit of anyone else trying for the first time - at the moment there is no config for VW built in anywhere. You have to add VW as an application in the 3Dconnexion control panel, then define all the axes manually as per the advice in the knowledgebase article. Then these settings will apply whenever you're in VW. It seems that it doesn't make any difference whether you add VW2016 or VW2017 - if you add it as VW2016 then VW 2017 still uses those settings and vice versa. The actual behaviour in each version of VW is however a bit different.

 

 

Anyway, I am praying for the release of the hopefully improved driver very soon!

 

 

 

 

 

 

 

 

 

 

 

Edited by lineweight (née col37400)

Share this post


Link to post
On 8/1/2016 at 6:20 AM, Andrew Davies said:

 

But I am struggling to get it to work well with Vectorworks. I set it up as per these settings

http://kbase.vectorworks.net/questions/1173/3Dconnexion+SpaceNavigator+-+Recommended+Configuration+-+(Mac+OS+X)

 

 

Does anyone have a configuration that is working well on Mac with VectorWorks 2017?

Can you export your config file ?

 

I'm trying all permutations again - and getting frustrated (again!)

 

thank you

Ethan

Share this post


Link to post

Anyone else having problems or strange behavior with 10.4.2 driver ?

 

My CAD Mouse got more and more missing LMB clicks + unwanted double clicks.

May be a hardware problem.

But also Enterprise started to mix macros or button assignments. Also 3D Navigation

got nuts and felt like 2000% accelerated.

So I un/reinstalled and restarted back and forth many times, including deleting all hidden

settings and prefs. So my tedious settings for 3 Apps are gone now and I have 12 new

C4D Macros of commands I never need.

Enterprise seems to work but the CADMouse is still unusable.

 

Put both back in the cabinet again. Will try with 10.4.3 again.

Share this post


Link to post

i can't seem to make this work for me also....i have persevered with the mouse but have gone back to manaul navigation with my mac mouse

 

Share this post


Link to post

You also had problems with the CADMouse ?

I only heard one on their forums that mentioned problems with LMB clicks.

 

Yesterday was enough, I couldn't imagine how terrible missed clicks or unwanted

double clicks can be. Today I am still afraid clicking, although all other mice work reliable.

Share this post


Link to post

I find that everything works fine when using 3Dconnexion's own "trainer" software. All perfectly smooth and as it should be so it seems unlikely there's a hardware problem. (Does the same apply to the CADmouse?)

 

The problem seems to come in its interaction with VW, somehow.

Edited by line-weight

Share this post


Link to post

Something is absolutely broken. Using 2017 SP1 on OS X 10.11.6 with the 3DxWare 10.4.2 I am unable to make the SpaceNavigator behave at all. Not only do the inputs seem wrong, it does not appearing to be redrawing properly during the erroneous movements. Filing a new bug now. VB-137869

 

I do not see the same problem in 2016.

Share this post


Link to post

Honestly I deleted all these Apps as 10.4.2 brought that ugly annoying welcome screen after a reboot,

that does ignore the "show every start" deactivation checkbox.

I tried the Enterprise Trainer. Smooth but it was set to very conservative speed.

 

The Enterprise 3D Bubble works as smoothly as the old 3D Navigator in Modo.

For C4D I don't find comfortable speed settings. It is similar than in VW, usable but not so natural.

Edited by zoomer

Share this post


Link to post
14 minutes ago, JimW said:

Something is absolutely broken. Using 2017 SP1 on OS X 10.11.6 with the 3DxWare 10.4.2 I am unable to make the SpaceNavigator behave at all. Not only do the inputs seem wrong, it does not appearing to be redrawing properly during the erroneous movements. Filing a new bug now.

Do you have a Spacepilot Pro you can try out at your end?

Share this post


Link to post

Jim, do you know how the your VW support will look like ?

 

Don't know if it is different for Windows.

But after deleting my own tedious made Macro settings, I now got a new C4D Setup by clean install.

C4D + some other (uninteresting) Apps.

 

I see that every App provided exactly 12 Command Macros only for these 12 buttons.

While "Macros" are needed to allow a Keystroke + an additional useful Description on Display.

(Assigned per Keystroke only, it will show the key combination on display only)

 

And all these Macros for all Apps are mixed into one single list.

You have to use name prefixes to group them for alphabetical sorting.

(They did like e.g. "Cinema Hyperbevel" "Autocad Draw Line")

So this way It would not make much sense if a Software would deliver 150 Macros to choose

yourself because you wouldn't find these again.

But if I watch the C4D Presets, there is no single command I would have chosen by myself.

 

Will VW also have to provide 12 Macros only ?

So will VW sit in a meeting and need to decide which are the 12 must have commands that

the majority of VW users, that use an Enterprise too, will need to survive ?

:)

 

Edited by zoomer

Share this post


Link to post

I have a SpaceNavigator and an Enterprise version, they exhibit the exact same problems for me here on my machine. They're mapped almost identically as far as the joystick portion is concerned so I would expect similar problems on the entire range.

  • Like 1

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...