Jump to content
Kevin McAllister

Bugs upon Bugs upon Bugs

Recommended Posts

I'm not having a good few days with VW. There seems to be bugs around every corner. I've honestly never felt this frustrated with VW and I'm starting to understand some of the frustrations I keep seeing on the Tech Board. Do others come up against bugs so regularly in their workflow?

Just now, I sat down to resubmit a bug I submitted two years ago. In the process of creating an example file another bug I submitted more than a year and a half ago reared it head again. I feel like I'm chasing my tail or caught in some sort of late night comedy loop.... :-(

Kevin

  • Like 2

Share this post


Link to post

I agree, have been using VW since about 2005, and then spent the last 2 years working on archicad, have started back on VW now for about 3 months. In the 2 years of archicad, apart from the occasional crash I only had to make literally a handful of queries about the operations/glitches. I have made more than that amount of queries for VW in the last week. Some of my queries turn out to be training related, but a large number are just bugs. Some of the more obvious ones I don't even report. Im still a fan of VW over archicad however the intuitive factor seems to be missing. With most software you can roughly learn one operation and expect other operations to behave in a similar way. I also had a look at some of my posts from 2010 and some are still issues now. I have to wonder how some of the example images in the advertising material actually work.

  • Like 1

Share this post


Link to post

Kevin,

I feel your pain. It's so sad. The bugs put a halt to my productivity far too often. I need to work, not trouble shoot. Dear Vectorworks, it's not ok to keep spending resources adding features when the bugs are so prolific. I know there's no such thing as bug free, but this is bad.

Share this post


Link to post

Here's a partial list of bugs I have submitted and still nothing:

Mirrored 2D objects geometry is messed up when height is changed in the OIP.

Mirrored 3D objects edges don't render consistently in Hidden Line render.

My Mac won't automatically sleep when Vectorworks is open.

Docked palettes don't retain their set heights form a previous session when Vectorworks is opened.

Fraction numerator overlaps the /.

Can't auto save a backup copy to the Cloud without creating a mess of extra files.

  • Like 1

Share this post


Link to post

I sympathize Bruce. Most of mine are rendering related at the moment - lost edges, improperly scaled NURBS in symbols etc.. I had forgotten about the fraction issue. I miss real fractions. The list grows daily unfortunately. Maybe we should start a forum thread of bugs and see how big it grows. Our own public bug list as it were....

Kevin

Share this post


Link to post

These are some examples of my last queries. As you will see these aren't issues for creating complex drawings, these are just the basics. I find it hard to imagine creating complex multistory structures if these are the issues that arise just from creating simple buildings.

Design Layer Viewports and Class Visibilities

https://techboard.vectorworks.net/ubbthreads.php?ubb=showflat&Number=229718#Post229718

Roof Turns Invisible After Creation Despite Class Settings

https://techboard.vectorworks.net/ubbthreads.php?ubb=showflat&Number=230146#Post230146

Opening up New instance of VW2016 causes crash

https://techboard.vectorworks.net/ubbthreads.php?ubb=showflat&Number=230011#Post230011

Surface Hatch to Render Texture Glitch

https://techboard.vectorworks.net/ubbthreads.php?ubb=showflat&Number=229494#Post229494

Keynote Legend - Text Alignment

https://techboard.vectorworks.net/ubbthreads.php?ubb=showflat&Number=229740#Post229740

Having to perform additional actions to make changes take affect

https://techboard.vectorworks.net/ubbthreads.php?ubb=showflat&Number=229802#Post229802

Share this post


Link to post

In the last few years I have lost countless hours of productive time troubleshooting Vectorworks. As I have mentioned on the forum before, I have an ongoing list of well over thirty items. Most I think are bugs but many are built-in illogical functionality. My guess is that my "little" list is the tip of the iceberg and represents as serious systemic problem with the current state of Vectorworks. In my opinion fixing this systemic issue should be the top priority for Vectorworks!

Share this post


Link to post

I personally think it's a resource issue and/or limitations due to the age of the code base.

VW has the potential to be very good. They have to start listening/acting or sell it to someone who will.

Share this post


Link to post

I'm really shocked by the fraction bug and how long it's been around. I can't make a presentation document using Vectorworks because fractions look like BLEEP. Then if I don't use the numerator over denominator setting in Units, I get something that has to be interpreted like 1 1/16. Is the one and one sixteenth, or eleven sixteens? A - (1-1/16) would solve that, yet this goes on for years. Yes, I'm mad.

  • Like 1

Share this post


Link to post

I concur with everything here. I have something like 75 items on my ongoing list. The time consumed by encountering, identifying, and developing work-arounds for problems leaves little time for submitting them as issues or bugs (though I try...). What should be matching methodologies from one tool to the next are not, and too often results are not as one would expect. Vectorworks is / would be SO GREAT if all of the little things that interfere with its productive use would only just get resolved! New features, like the highly capable cameras with DOF, are great, but, they'd be even greater if we could more effectively model things to take pictures of...

  • Like 2

Share this post


Link to post

The current state of bugs has really gotten out of hand. I am angry, tired and frustrated like the others on this thread.

My current bug was that I am unable to select door hardware, choose a steel section on the framing tool, among other things. Seemingly unrelated tools, but I think they all share the same pop-up selection box UI.

I contacted VSS Tech Support, but they were unable to replicate the bug so they wanted to screen share my computer to see what was going on.

The bug would go away once I switched user accounts, so last week I formatted my hard drive, installed a clean copy of Mac OS X El Capitan, created brand new user accounts, and reinstalled Vectorworks 2016. For an entire three days, I did not have the bug so I thought I had fixed it. Silly me...

This afternoon I had a nasty, immediate Vw crash (which I believe was caused by dragging a wall onto a locked wall) and now that same bug is back. It's just the same as before, so it's clear that a migrated user account was not the problem. Somehow Vectorworks managed to break itself when it crashed.

So once again - I have completely wasted two days trying to fix Vectorworks. :mad:

I know that adding that features like depth-of-field and caustics are sexy and probably relatively easy since they are part of the C4D engine, but I honestly could care less about them. Neither of those features will help me put out a set of construction drawings.

Vectorworks should focus on fixing the current tools before adding any new features. Period.

Ok, I'm done ranting ...

  • Like 1

Share this post


Link to post

There's so many great new tools, the only problem is that the basic ones aren't even working correctly. I'm not about to start researching and learning the marionette tool, subdivision surfaces, 3D pdf exports etc when I can't even get the surface hatch to work on a floor, a site model that I can dash in section or a detail marker to show correctly without having to enter and exit the tool with no change for it to take effect. It would be great to use all these other tools but not until I can create a basic black and white set of construction drawings without having to draw lines and fills etc over 3D objects that aren't working properly.

  • Like 1

Share this post


Link to post

"I'm not about to start researching and learning the marionette tool, subdivision surfaces, 3D pdf exports etc when I can't even get the surface hatch to work on a floor . . "

Will VW ever address the ongoing issues from the base?

The very first time I used VW I could not believe how clever it was, a CAD & Illustrative package in one, on a Mac, a jackpot! Several years and much investment later, not really feeling it.

best wishes . .

  • Like 1

Share this post


Link to post
when I can't even get the surface hatch to work on a floor

Is the attached what you are trying to do? Hatch on a Slab and Floor?

Sorry cant add VW file as 2Mb max here

Share this post


Link to post

Surface hatches are currently not always rendering properly on Floor objects, this probably cropped up unnoticed since we don't really use Floor objects anymore here in demos or testing, instead favoring the Slab object since it has a component structure. The Floor issue is indeed still filed as a bug, bug many things are prioritized over it.

Share this post


Link to post
Surface hatches are currently not always rendering properly on Floor objects, this probably cropped up unnoticed since we don't really use Floor objects anymore here in demos or testing, instead favoring the Slab object since it has a component structure. The Floor issue is indeed still filed as a bug, bug many things are prioritized over it.

Jim, thanks for shedding some light on one of the bugs in this thread. A few thoughts from this revelation -

- there should be a Obsolete or End of Life or Deprecation list available to users. It sounds like floors have become obsolete and the only reason to fix this bug is to maintain the legacy aspect.

- more resources need to be put into rendering bugs. The majority of my current bugs are rendering related even if the cause isn't a rendering issue. Some of my rendering related bugs were filed over two years ago.

- there is a desperate need for an active bug list that shows priorities. How would a person using Floor objects ever know they could be waiting FOREVER for a fix.

Kevin

Share this post


Link to post
Surface hatches are currently not always rendering properly on Floor objects, this probably cropped up unnoticed since we don't really use Floor objects anymore here in demos or testing, instead favoring the Slab object since it has a component structure. The Floor issue is indeed still filed as a bug, bug many things are prioritized over it.

Jim

There is still a problem with hatches embedded in renderworks textures rendering on slabs objects. Problem exists both in slabs rendered by object and by component.

I'll attach an example.

Switch the rendering from OpenGL to Hidden Line. The direction of the hatch changes on different sides in hidden line.

mk

Share this post


Link to post

I don't suppose it will help if you use a line texture and render either by Object or by Component?

Edited by Alan Woodwell

Share this post


Link to post

It works fine in OpenGL. Hidden line is a problem. I often use OpenGL when working, but the SLVP is in hidden line.

mk

Share this post


Link to post
we don't really use Floor objects anymore here in demos or testing, instead favoring the Slab object since it has a component structure

Please don't abandon the Floor object; I use it extensively! Complex objects (i.e. the Slab) have their place, but, simple ones do, too.

Is it just me, or has this thread been completely derailed?...

Share this post


Link to post

:) Yes, it's derailed. And I agree about floor objects. They are very useful from many things. Except maybe floors.

mk

Share this post


Link to post

Its not that derailed. We learned some information about the priority of a particular bug.

The "floor" object is actually very useful in an entertainment context. I've even used it for floors. I would argue its one of the misnamed tools since its capable of many other uses - its an auto hybrid extrude. It should be rebranded and included in all versions of VW rather than being deprecated. In my work, while I use architectural tools, I'm drawing architecture as a container for other design rather than as the end result. Because of this its often simplified for clarity. Tools like the slab tool are overkill for this.

Kevin

Share this post


Link to post

I work in both architecture and entertainment design. The floor object is a great countertop and a great stage. Any 3D object like the floor, slab, and roof face objects that are 3D parametric objects that also respond to add and clip surface are super useful.

mk

Share this post


Link to post
I'm not having a good few days with VW. There seems to be bugs around every corner. I've honestly never felt this frustrated with VW and I'm starting to understand some of the frustrations I keep seeing on the Tech Board. Do others come up against bugs so regularly in their workflow?

Yes, it's the Vectorworks way of life. I've been asked to do some quick site area calculations (impervious area as a percentage of the whole site). I've never found a way to report on simple polygons for doing this, so I've always used the Space object. But it's been a while, and now, over 50 minutes into what should have been a 10 minute exercise, I'm fighting with the Space object... and ALL I'm trying to do is get some simple areas!

To get the Space object to display using the class attributes of the class it's in, I first had to put it into another class, and then back into its intended class before it recognized the class attributes.

The Label won't pick up the attributes of the different class that it's assigned to; actually, I don't think it's even in its assigned class because when I turn that class off it's still present.

Best is that in order to select the Space object and have it show in the OIP, I first have to drag the label to a new location. ?!?

Seriously, it shouldn't be this painful (and so extraordinarily non-productive).

  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×