Jump to content
  • 0
Ryan Russell

Export to TwinMotion (VWSP3)

Question

Can someone please explain the process to export to TwinMotion on a Mac?

 

Also, why is the development of a good rendering option, outside of RenderWorks, not readily available within this software? It is 2021, and, in my opinion, Vectorworks really needs to begin to focus on improving the Macintosh side of the house. There has to be a large segment of their user base that is presently being under represented here. One could always export the data out, then switch to a VM or PC based system. But that is a cumbersome and somewhat lengthy process to achieve a much needed result.

 

Furthermore, if I recall, the development roadmap had promised TwinMotion direct integration by the release of SP3. Is there anyone out there who can shed light as to what road blocks were encountered that made this not happen?

 

Lastly, the video produced on the DataSmith export is apparently only a Windows option. Why is this? And zero information is made available to the viewer that is to be the case. How about giving the Mac users the same ability on export functions?

 

Sincerely,

Confused VW 2021(SP3) User

Share this post


Link to post

13 answers to this question

Recommended Posts

  • 0

@Ryan Russell 

built any features you want to have unique textures in twinmotion to have unique colors or textures in Vectorworks

vectorworks -> export in C4D format

Twinmotion -> import C4D

start adding trees and materials in Twinmotion

done 🙂

Share this post


Link to post
  • 0
11 hours ago, Ryan Russell said:

Lastly, the video produced on the DataSmith export is apparently only a Windows option. Why is this? And zero information is made available to the viewer that is to be the case. How about giving the Mac users the same ability on export functions?


Not sure what you’re referring to - the new Datasmith export in SP3 is definitely both Mac and Windows. It’s entirely possible that it didn’t get automatically added to whatever workspace you’re using. You could try switching workspaces (under Tools menu) or use the Workspace Editor to add the ‘Export Unreal Datasmith’ command to the export menu.

 

That being said, I agree that an in-program real-time render engine is sorely needed, but I don’t think that was ever promised for SP3. Just a direct pipeline to Unreal/TM which is what the Datasmith workflow is. I’ve found it much more reliable than using the C4D or fbx formats, though my own testing so far is fairly limited. I also love that it smartly merges file updates with changes you’ve made in TM/Unreal. 
 

Let us know if you’re able to find the new command. 

  • Like 1

Share this post


Link to post
  • 0

What would be useful to know, is whether any future is projected for Renderworks - or will it be gradually abandoned, with the expectation that users move to using external, additional-cost things like Twinmotion instead? This knowledge would affect two things:

(a) my level of disgruntlement with VW

(b) the amount of time I invest in learning how to use Twinmotion at this stage

Share this post


Link to post
  • 0

Hello line-weight:

We remain committed to including Maxon Cineware with every Vectorworks.  Renderworks is not being gradually abandoned.  With the technology Maxon has acquired through Redshift, and with tighter integration between Cineware and Vectorworks you can expect major improvements in the right direction.  Meanwhile you have options with Lumion, Enscape, and Twinmotion, which can serve you very well.  Lumion, Enscape, and Twinmotion do not require much time investment, that is one of their best attributes.

 

  • Like 3

Share this post


Link to post
  • 0
30 minutes ago, Dave Donley said:

Hello line-weight:

We remain committed to including Maxon Cineware with every Vectorworks.  Renderworks is not being gradually abandoned.  With the technology Maxon has acquired through Redshift, and with tighter integration between Cineware and Vectorworks you can expect major improvements in the right direction.  Meanwhile you have options with Lumion, Enscape, and Twinmotion, which can serve you very well.  Lumion, Enscape, and Twinmotion do not require much time investment, that is one of their best attributes.

 

That is good to hear. Although I've not explored Twinmotion very much, my impression is that Renderworks is still capable of producing the better quality renderings, given enough effort. Twinmotion has a bit of the computer-game look to it.

 

The biggest thing missing from renderworks is the ability to use it to easily make walkthrough animations. The walkthrough animation tool in VW is slightly better than it used to be, but frankly still pretty hopeless. It would be great to see that improved.

Share this post


Link to post
  • 0

So upon further hunting, you do in fact have to to change the WORKSPACE. If you are in VW2021 > Architect, the EXPORT > Unreal DataSmith is not available. However, if you change to VW2021 > Architect-BIM workspace, the Unreal DataSmith option will now be listed in the EXPORT listing. Can someone from Vectorworks please explain why this difference exists between these two workspaces?

Share this post


Link to post
  • 0

UPDATE: Please see this thread "Export Unreal Datasmith". I do believe that this thread does answer most questions posed above.

 

  • Although, can anyone please add any relevant information as to why there are two different workspaces for Architect? One basic and one for BIM?

Share this post


Link to post
  • 0

Just used the data smith export today and models are definitely importing better into Twinmotion - so thanks!

 

One big issue im finding -

Missing elements in my model - they are there, but material in Twinmotion is set to transparent and opacity of Zero..

It appears to be ALL materials in vectorworks which have Transparency set to 'plain', (even with opacity set to 100%) - but for some reason they're importing into twin motion at 0% opacity - Its only happening with items ive imported from eg 3dwarehouse which generally have these settings im finding.

 

Share this post


Link to post
  • 0

Curious to hear how this datasmith process treats Vectorworks Plant Objects (and really the replacement of any VWX object with any of TM's entourage).

 

What happens if you replace VWX Plant Objects with Twinmotion plants today, make changes to the vwx plant placement tomorrow then launch Twinmotion?

Share this post


Link to post
  • 0
3 hours ago, neal-2002 said:

Just used the data smith export today and models are definitely importing better into Twinmotion - so thanks!

 

One big issue im finding -

Missing elements in my model - they are there, but material in Twinmotion is set to transparent and opacity of Zero..

It appears to be ALL materials in vectorworks which have Transparency set to 'plain', (even with opacity set to 100%) - but for some reason they're importing into twin motion at 0% opacity - Its only happening with items ive imported from eg 3dwarehouse which generally have these settings im finding.

 

 

Hello @neal-2002

I tried a hemisphere with a plain transparency at 50% and it is working OK for me.  Can you attach a test file here that shows the problem please?

 

Make sure you are using the very latest Twinmotion build available, bugs are being fixed in every release.  Also use Keep scene hierarchy when importing, there is a known bug where shading will be wrong with Collapse by material, we expect a bug fix for that in the next Twinmotion release.

 

  • Like 1

Share this post


Link to post
  • 0

table example.vwx

example of an item imported from 3d warehouse ( - so its just default model material setting from import - legs material import to TM is transparent, table top is ok)

using 2020.2 on mac 10.15.6

used hierarchy as usual..

  • Like 1

Share this post


Link to post
  • 0
36 minutes ago, neal-2002 said:

table example.vwx

example of an item imported from 3d warehouse ( - so its just default model material setting from import - legs material import to TM is transparent, table top is ok)

using 2020.2 on mac 10.15.6

used hierarchy as usual..

 

@neal-2002 I see this, and it does seem to be related to Opacity of plain transparency set to 100%.  Such a configuration is nonsensical - why use transparency and set it to completely solid?  Anyway we will look into a code fix for it.  If I change the Opacity to anything other than 100% it shows in TM, like you said.

 

  • Like 2

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...