Jump to content
Steve Nield

Texture not showing in Open GL

Recommended Posts

I have an object that the texture can only be seen if rendering in Fast Renderworks or Final Quality and not in OpenGL.  I have  checked the OpenGL settings and use textures is checked.   I have tried copying this object to a new empty file and it renders in OpenGL just fine.  Has anyone else encountered this ?

Steve

Share this post


Link to post

I've had this happen as well. Not that found a solution. Thought that it might have been something to do with my graphics card.

Share this post


Link to post

Hi guys

 

I think I have the same or a similar problem here. See description of the problem and instructions inside the attached file. Very strange behaviour: some textures show up, some not, depending on their absolute position. This file is also allready in the service select support-pipeline of Computerworks Switzerland (I think Mr. Moises) with no result yet. Thanks for any help.

Open GL Texture problem.vwx

Share this post


Link to post

@SwissMarc

A signature showing your system and vwx specs would be useful.

Couple things I found.

 

• OGL will render those invisible ImageProps if the Auto Rotate option is disabled.

• Moving the invisible Image Props closer to drawing origin allows them to render OGL. So, position does matter, as you note.  They are positioned prox -400,-500,-71 meters from origin.  That seems like it should not be far enough to cause the old "great distance from Origin" problems, but maybe medium distance from origin combined with insufficient graphics card this problem manifests?  I hope others with more robust system will test.

 

Good luck!

 

-B

 

 

  • Like 1

Share this post


Link to post

@SwissMarc

Benson appears to hit the nail on the head. If I bring these props to around the 0,0 mark they all show up. Move them a long way away and nothing.

HTH

Share this post


Link to post
13 hours ago, Benson Shaw said:

@SwissMarc

A signature showing your system and vwx specs would be useful.

Couple things I found.

 

• OGL will render those invisible ImageProps if the Auto Rotate option is disabled.

• Moving the invisible Image Props closer to drawing origin allows them to render OGL. So, position does matter, as you note.  They are positioned prox -400,-500,-71 meters from origin.  That seems like it should not be far enough to cause the old "great distance from Origin" problems, but maybe medium distance from origin combined with insufficient graphics card this problem manifests?  I hope others with more robust system will test.

 

Good luck!

 

-B

 

Thanks Benson and Allen

 

Sorry, system/vwx specs were inside the vwx file in the instruction text, now I added a signature, see below - thanks for this suggestion. Thus I don't think it is my graphic card which isn't that bad.

 

Yes, turning auto rotate off makes textures visible again. But I need rotating textures, anywhere, independent of their position in the coordinate system. A fiew hundred meters is not much, I find.

 

anyway - JimW confirmed this issue as a bug VB-138160 in this thread: https://forum.vectorworks.net/index.php?/topic/47487-3d-plants-image-props-not-showing-up/

So hopefully this problem can be solved soon.

Edited by MarcU

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...