Jump to content
  • 0

SP5 update


Have tried updating to the latest SP but it fails at the last minute.... Anyone else having a problem or is my ageing MacBook not up to the latest version....?

Screen Shot 2019-08-29 at 22.17.38.png

"Removing Screenshot with serial#" Juan P.


Share this post

Link to post

9 answers to this question

Recommended Posts

  • 0

Just upgraded from SP5 to SP5.1

(While SP5.1 should only be necessary for older Macs !?)


Both 5 and 5.1 updates worked for me on Windows 10 and macOS 10.14

Share this post

Link to post
  • 0

@LeeElston did you just announce to the world your VW serial number?


This is actually a severe serial security issue that I have raised with my VW vendor before. 


VW updater can be launched without Admin rights (on a Mac), and the serial is displayed just like that. 


The updater should require Admin rights to launch, so our Serial Number is much harder to access.


(sorry to veer off topic)

Edited by Amorphous - Julian
  • Like 1

Share this post

Link to post
  • 0

SP5 is not showing up at all, it says that SP4 is up to date. Guess I will be contacting the local distributor tomorrow when it will be available.


Did you try to run the update from VW with the check for updates or did you run a separate update installer? If the latter there might be some incompatibility with your installed VW (e.g. if you are using a locally distributed US version and using the updater from the US website it could still be that some parts of the install are in folders that have a different name and cause the updater to fail. Just something to consider if it applies.

Share this post

Link to post
  • 0

Either SP5.1 on Windows is strange or my Update went wrong.

It takes minutes to start.

Which looks like it is ignoring the click on the start icon.

Just a few seconds beach balling.

At some points it will open though.


Tried to start the VW Updater only,

which, for the first time, wasn't able to find the serial number !?

Gave it and try a repair.


Maybe it is also because of the latest buggy Windows Update

a few days ago ...

Edited by zoomer

Share this post

Link to post
  • 0

I haven't run that Windows update, fortunately, as I take as look at the Ask Woody website first to see if there are major issues. After that big April update that totally crashed Windows on both computers I'm more cautious, though it had to do with some of the security software. Microsoft has a way of screwing up its updates way too often lately.


It wouldn't surprise me if the Windows update of a few days ago has to do with your issue. Did you try to uninstall those updates? (You can do this for approx. 1 week after they were installed). Otherwise you may want to take a look at programs such as e.g. Rollback Rx which can undo such updates too (and do it better than Windows itself in some cases), but that only works if it is installed and running before those updates get installed.

Share this post

Link to post
  • 0

Yes, in the worst case I will throw it away.

I read it 2 days after installation.


Latest 3DConnexion 10.6.2 is also terrible. They took it from their site

and show 10.6.0 again. Tried to revert. Needed a full uninstall but

10.6.0 did no more work after.

Got back to 10.6.2 and have at least my custom settings back.

Won't work reliably either. Have to wait for a new version.

Not sure about 10.6.3 for Mac as I have an old Space Navigator only.

Or if it is really Blender's fault. Overall it is at least working longer than

half an hour on Windows.


Even VW SP 5.0  was strange on all systems from the beginning.

It crashed after creating a new file from my template after a system sleep

on Mac. But had that on Window too. And I deactivated anything sleep

in Windows as it crashes Windows in itself ...


Latest Mac update feels strange too.


What a mess.

I don't have such issues on my Open Suse Tumblewed or Manjaro at all.

And I mainly use "dangerous" Rolling Releases with latest Kernels.

Edited by zoomer

Share this post

Link to post
  • 0

Repairing VW SP5.1 fixed 1 File.

Disk Check and Restart helped.

VW starts normally again.

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114


© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

  • Create New...