Jump to content
  • 0
JimDenaultASC

3DConnexion SpaceMouse Makes Big Jumps

Question

I am having an issue where the model makes big unexplained jumps while using my Space Mouse. It was happening with my older Space Navigator and I thought it was a hardware problem, but the same problem is happening with a brand new one as well.

 

For example, I can be gently and smoothly orbiting the model at 38% when suddenly there is a big jump and I end up underneath the model and zoomed to 3,058,850%. Anyone have a clue? I cannot figure it out. All my SpaceMouse settings are the ones recommended in this thread.

 

Reset to Defaults doesn't help.

 

Here's a little movie.

 

Share this post


Link to post

12 answers to this question

Recommended Posts

  • 0

I have just uninstalled and then reinstalled the new 3D connexion driver for Big Sur and all the issues I had are now solved. Worth a try?

Share this post


Link to post
  • 0

Good grief. I thought I had waited long enough to install Big Sur. Guess not. That is exactly when the problems started. I should have put 2 and 2 together.

Share this post


Link to post
  • 0
10 hours ago, markdd said:

I have just uninstalled and then reinstalled the new 3D connexion driver for Big Sur and all the issues I had are now solved. Worth a try?

Hi Mark,

Thank you for last days! Hope everything fine with you 🙂

 

I saw they've update the beta driver. Do you think it's important to uninstall the driver first?

 

Bernat

 

 

Share this post


Link to post
  • 0

Hi Bernat. 
 

YES!

 

I just took my MacBook in for repair which meant that I had to have a completely clean install of MacOS. After I installed VectorWorks and the 3D connexion driver everything worked perfectly. 
 

Back to my trash can Mac Pro, - I uninstalled the 3D Connexion driver and then reinstalled the brand new BETA driver and everything works fine.

 

Updating the 3D connexion driver (without uninstalling)  for some reason does not work at all.

 

hope you’re well!

Share this post


Link to post
  • 0

Mark,

Did you have any trouble with the 3dconnexion Uninstaller. It totally crashed my computer when I ran it. I had to go into Safe Mode to make it run.

Share this post


Link to post
  • 0
Just now, JimDenaultASC said:

Mark,

Did you have any trouble with the 3dconnexion Uninstaller. It totally crashed my computer when I ran it. I had to go into Safe Mode to make it run.

No. Not at all. Sorry you're having difficulties.

Share this post


Link to post
  • 0
12 hours ago, markdd said:

Updating the 3D connexion driver (without uninstalling)  for some reason does not work at all.

 

 

OK,

I think I tried that before at some point already.

 

But currently i have an uninstalled driver, some reboots, installed driver again,

only attached original Space Navigator situation (because of other issues)

 

But will try 3DNavigator in VW again ...

 

 

Edit :

 

Indeed, seems to work.

No more geometry jumping out of 3D View.

That is fine !

Edited by zoomer
  • Like 1

Share this post


Link to post
  • 0

Hi,

I used the uninstall app without troubles.

But 3d space mouse continues to jump. Not so often but is not over yet.

 

/Bernat

Share this post


Link to post
  • 0

I'm having similar problems.

This is VW2021, Big Sur, on a new M1 Mac mini.

I use a Space Mouse Pro.

 

Problem 1: Motion in general is jerky. If I just try to rotate smoothly at a constant speed (or move in any direction at a constant speed) then I get intermittent jerks and stutters in the motion. Demonstrated here (I am trying to rotate at a constant speed - the jerks are not resulting from input from me):

 

NB that I noticed something very similar when I tried installing VW2021 on my old Mac (a classic Mac Pro running Mojave). It's not something that's been a problem on VW2018 or 2019 installed on that same Mac. That leads me to think it's something to do with vw2021

 

 

Problem 2 (I don't know if it's separate or related) is the same as others have reported - sudden jumps to a different position. Eg:

I feel that this may be liable to happen in particular just after I've opened the file. Not sure about that though. Sometimes I end up somewhere in the sky, sometimes underground.

 

 

I've installed latest update to Big Sur.

I've installed the 'Big Sur' beta driver from 3dconnexion.

 

I've tried un-installing the 3dconnexion driver, and re-installing and restarting the machine, but it doesn't seem to make any difference.

 

Tomorrow I'm going to try running VW2020 on Big Sur and see if the same problems exist.

 

 

 

Edited by line-weight

Share this post


Link to post
  • 0

An observation: if I start up VW2021 without the spacemouse plugged in, then once it's started, plug in the spacemouse, I don't get any response from it at all. I have to quit vectorworks, and reopen vectorworks with the spacemouse already plugged in.

 

This is different to what I am used to on VW2018. It doesn't matter if I start VW without the spacemouse plugged in. I can plug it in after VW has started, and it gets recognised.

Share this post


Link to post
  • 0

Unfortunately I'm able to replicate this on VW2020 as well as VW2021. Both running on Big Sur.

 

Aside from the "big jumps" problem, in both versions, I find the motion is not as smooth as I've been used to on VW2018, especially on large/complex models.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...