Jump to content
  • 0
Andy Broomell

Resource Manager Search Issue

Question

I've noticed lately that after working in Vectorworks for a while, the search function in the Resource Manager only shows results from open files and favorites, even though "Everywhere" is selected in the Search dropdown. Why does it stop accessing library files? If I restart Vectorworks it searches properly, but after a while it's back to only searching open files and favorites. It's been across multiple unrelated files, and has come up a few times over the last few weeks...

 

Has anyone else experienced this?

Share this post


Link to post

8 answers to this question

Recommended Posts

  • 0

It's not working for me either. It was one of the best features they added too. It used to work. I don't when it stopped working correctly. But you are right, I restarted VectorWorks and it worked again. Wonder how long it will last before I need to restart it again.

Share this post


Link to post
  • 0

Here too - thanks for bringing it up. I didn't get around to investigating & posting, but the search becomes limited after awhile.

I suspect it's widespread.

Edited by bcd

Share this post


Link to post
  • 0

I have been experiencing the same issues. Has there been a solution? I have found that some times by selecting "refresh libraries" some times it repopulates. But that does not work all of the time. 

Share this post


Link to post
  • 0

I'm finding that after system upgrade to Sierra (MacOS 10.12.xx) several search functions went bad - Mail, general finder searches, etc.  Might also affect the Resource Mgr? Not sure if vwx searches are linked to system search functions.

 

I think the answer, at least for system search, is to rebuild/reindex the app library, or the whole SSD or HD.  Not exactly sure how to do that, but web search did yield a Terminal/sudo command to force a system reindex.  I didn't try because it showed expected reindex of many hours.

 

Rebuilding my mailboxes helped some for Apple Mail search. Select a mailbox then Main Menu>Mailbox>Rebuild (bottom of the list in this dropdown).

 

HTH

 

-B

Edited by Benson Shaw
clarify

Share this post


Link to post
  • 0

Confirming same behaviour here. Has this been flagged as a known issue @JimW?

 

(VW_Architect_SP2_ANZ)

Share this post


Link to post
  • 0
On 2/3/2017 at 7:58 PM, Benson Shaw said:

'm finding that after system upgrade to Sierra (MacOS 10.12.xx) several search functions went bad - Mail, general finder searches, etc.  Might also affect the Resource Mgr? Not sure if vwx searches are linked to system search functions.

Still on El Captain here and the RM search is broken

Share this post


Link to post
  • 0

There are 5 bugs with identical symptoms to this thread but completely different causes slated to be fixed in the Resource Manager. I'm unable to replicate all of them personally but others here have.

Share this post


Link to post
  • 0

I have the same issue. It used to right itself after a vwx restart, then only after a Mac restart.....now no function at all. Even if I search for "tree" or "chair" it finds nothing. This is now very frustrating....anyone have any solutions? Cheers.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×