Jump to content
  • 1
Sign in to follow this  
Donald Wardlaw

Accept Incoming Connections repeatedly pops up

Question

I get an alert when launching VW;

"Do you want the application "Vectorworks2016.app" to accept incoming network connections?"

I routinely deny. Why would it be necessary to accept? What is the disadvantage to selecting deny?

Thanks,

Donald

10.11.4

Share this post


Link to post

15 answers to this question

Recommended Posts

  • 0

That is the Vectorworks activation and Check For Updates system. Hitting deny can sometimes stop activation from working properly which will lock you out of Vectorworks, but more commonly it would just stop you from getting service pack alerts.

Share this post


Link to post
  • 0

Any way to default our choice so we don't get the pop up on launch every time? I just started getting this with SP3 every time I launch.

Share this post


Link to post
  • 0

It's only supposed to happen once. If you have Mac Firewall enabled, you may be able to shut it up with Apple > System Preferences > Security & Privacy > Firewall > FireWall Options, and instead of "Block all incoming connections" make sure you add Vectorworks to the approved list manually. OS X's firewall is a bit overzealous sometimes by default.

ubbthreads.php?ubb=download&Number=14818&filename=Screen%20Shot%202016-04-01%20at%208.42.18%20AM.png

Optionally you can also disable Firewall entirely, but that is only really a viable option if you have other dedicated network security.

However, if it keeps happening after doing that please let me know. It isn't supposed to constantly harass you.

Share this post


Link to post
  • 0

That is interesting.

On later OS X,

that Message appeared always for VW2015 at every start,

It came only one time at the first start for VW 2016.

It came never at all for C4D.

It still comes every time I open my other App.

Although all are white listed in OS X Firewall settings.

And that Message each start came back for VW 2016,

with the latest OS X 10.11.4 Update.

Share this post


Link to post
  • 0

Let me test it on 10.11, my main Mac is still on 10.10.5. I think the 11.11 machine I usually test on might have its firewall off entirely.

EAlexander, are you on 10.9 still? or another version of OS X?

Share this post


Link to post
  • 0

Hi Jim,

Yes, I'm on 10.9.5 on my main workstation. I have Firewall on and I added VW2016 to "Allow incoming connections" with a green light. I still get the prompt every time.

Like Zoomer - this also happened with VW2015, but I just complied :)

My second workstation is El Capitain, but I can't test that right now. I'll follow up.

Edited by EAlexander

Share this post


Link to post
  • 0

I have the same behaviour with 2016 on my computer even though it's checked in the Firewall settings.

Share this post


Link to post
  • 0

For anyone here that can perform this test, if you completely turn off the firewall, then reboot, does the same error still pop up? You can certainly revert back to having it on after the test, this is simply useful info for my report.

(For these types of issues I sometimes have problems replicating, since I'm inside the same network that the activation server is in.)

Share this post


Link to post
  • 0

Firewall turned off I don't get any notification. When I changed the firewall settings with VW already open I get the same message within a few seconds.

Share this post


Link to post
  • 0

Thank you, that info helps. Filing a full report now.

Share this post


Link to post
  • 0

With the proviso that it is Monday morning and I've yet to have my first cup of coffee...

With firewall on and Vectorworks enabled to accept incoming connections I get the message upon VW startup.

With firewall off I get no such message upon VW startup.

Share this post


Link to post
  • 0

I am now able to replicate this across the board on the Mac side in SP3. Looks like it cropped up between the two service packs, adding this to the report.

Share this post


Link to post
  • 0

Just following up on this: I just upgraded from 10.9 (Mavericks) to 10.11.5 (El Capitan)...and the problem persists.

I did everything Jim suggests above - verified Firewall green light permissions. Turned fire wall off, then back on, then rebooted. Relaunch VW and accepted the first time. Close VW...reopen...prompt appears.

Boo!

:)

e.

Share this post


Link to post
  • 0

This seems to be recurring for users and in testing here as well, reopening the case and moving this thread to Known.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×