Jump to content
ryanww

Device - Custom fields

Recommended Posts

Hello,

 

I'm trying to get this new version setup and its quite a bit different from what I was shown on the pre Vectorworks version. How does one go about adding a custom field for devices i.e. an IP address field?

 

Additionally - it would be great to really have a much more in-depth manual on this plugin. There is absolutely zero information and what info is available is dismal at best. All of the old stuff has now disappeared. 

  • Like 1

Share this post


Link to post

Hi Ryan

 

Apologies for that. Getting integrated into a larger organisation has its issues. I was told that this info is in the Vectorworks University now. I'll try and track down a link for you. Meanwhile here are the how-to articles I wrote.

 

Conrad

CustomFields1.pdf CustomFields2.pdf

  • Like 1
  • Love 1

Share this post


Link to post

Thanks Conrad - very helpful.

 

Couple more things:

1) how can I change the text color of connector labels on a device? Currently magenta.

2) can we add additional signal types (like Cresnet is missing for example) and connector types? I'd love to customize this list to not be so long. I'm never in my life going to use SCART or half of the others on here

  • Like 1

Share this post


Link to post

Hello @ryanww,

 

17 hours ago, ryanww said:

1) how can I change the text color of connector labels on a device? Currently magenta.

 

You could do that by editing the symbol that is used by the device for its labels. You could see which is the symbol from the Device's OIP.

 

17 hours ago, ryanww said:

2) can we add additional signal types (like Cresnet is missing for example) and connector types? I'd love to customize this list to not be so long. I'm never in my life going to use SCART or half of the others on here

- For signal and connector types there are similar files as the CustomParams.txt located in the same folder - SignalTypes and ConnectorTypes. You could edit these files or add modified versions of them in your user folder. However, if you want to remove an entry from there you will have to edit the app folder file, which is usually not recommended.

 

Best Regards,

Nikolay Zhelyazkov

  • Love 1

Share this post


Link to post

Also don't forget that most of these elements inside system symbols are in the 'Sys-xxxx' classes. So have a go changing the class attributes for a faster way.

 

Conrad

Share this post


Link to post

Good day.

I am trying to get a Custom Fields in to Cable or Device Report.

But right now there is no pop up window appear, there i can chose which Custom Fields i want to have in Report.

Please advice how to do this.

 

Thanks in advance 

 

Dmitry

Share this post


Link to post

Hi Dmitry

 

Here's an example: I've enabled a custom Device field, given the Devices on my schematic some values for the custom param, and created a Device Report. Then I inserted a column of my own into the Report, enabled View > Database Headers and added the formula '= (Device.user1) and recalculated. Then the values appear.

 

930840312_Screenshot2020-01-17at23_03_06.thumb.png.05d5c63430b1c9a3727c0188ca0f98eb.png

 

Best

 

Conrad

  • Like 2

Share this post


Link to post

Good evening again )

Short  question. Is ti possible to add more Custom Fields, more when 8?

I am  trying to add more, but looks like i miss something. 

In Custom Params i added 2 more fields: 9 and 10, when i added same fields in dev_rec, but unfortunately can not reach fields 9 and 10 in Object Info.

 

Please advise.

 

Thanks in advance

 

Dmitry

1.JPG

2.JPG

3.JPG

Share this post


Link to post

Hi Dima

 

At the moment the limit is 8 custom parameters. We'll be looking at making these unlimited in a future version. You can play with which ones are text fields and which are choice lists. If a choice list is present then the parameter will be formatted as a dropdown, if it is not present then it is a edit text.

 

Conrad

Share this post


Link to post
On 1/17/2020 at 4:16 PM, Conrad P said:

Just to add to this, Circuits don't currently support custom parameters.

 

Any chance this feature will be added? I'd like to use this feature to generate wire-pull documents based on how I categorize each circuits (field, rack, device, etc)

 

I currently do it with another record, but native would save a step. 

  • Like 2

Share this post


Link to post

Conrad et al,

 

Will adding a custom device field as described above also place it on the Device Builder tool interface? One could do this in 2019 (and earlier) but I can't get it to work in 2020. It's really nice to put an IP address or whatever while building the device, have it show up on the schematics and in reports.

 

I typically have two IP addresses on many devices (1 LAN, 1 Dante). Some devices create their own subnets too…

 

Given the ubiquity of an IP address, I wonder why this field isn't already built in.

 

Ean

Share this post


Link to post

Hi Ean,

 

You're right on both counts I think. IP is close to a standard requirement these days and yes, I think user fields should be added to the Device Builder dialog. I reckon with IP address the best way would be to ship with this enabled as a way to introduce custom fields. Interested to hear opinions.

 

Conrad

 

NB strike the idea of adding custom fields to the Device Builder. We don't need that - you can see them in the OIP as soon as the device is created.

Share this post


Link to post

Meanwhile, if I add the field as described above, will it a appear in the Device Builder interface? I'm going to try it out today, but am trying to avoid floundering overmuch. Thanks.

Share this post


Link to post

No need to flounder 🙂 for sure it is in the Object Info Pallete available immediately you create the device.

  • Like 1

Share this post


Link to post

Actually Ean, it doesn't seem sensible to clutter up the Device Builder when it really is this simple. Check out the Did you know thread for a guide on visualizing user fields.

 

Best

 

Conrad

 

Screenshot 2020-04-30 at 17.44.55.png

Share this post


Link to post

Haven't got that far yet. Still trying to figure out where to edit custom params if not in the app folder. There used to be a ConnectCAD folder in Application Support -> [year] -> Plugins -> etc.

Share this post


Link to post

If you edit the Custom Params in the app folder please back up the file somewhere safe because it will be overwritten on upgrade. The user folder essentially mirrors the app folder paths. Plug-ins/connectCAD_Data is the place where you can put files to add custom signal and connector types, and your own version of CustomParams.txt etc.

 

It's different because we improved it. Much easier moving forward to carry these extra fields with you.

 

Conrad

Share this post


Link to post

Agreed. Easier to upgrade. Best practice to backup the files anyway. Agreed, it is better and getting more betterer.

 

Okay, I just copied the entire connectCAD_Date directory from /Applications/Vectorworks 2020/Plug-ins/ to ~/Library/Application Support/Vectorworks/2020/Plug-ins.

 

Sorry to be a nudge, it's just really helpful to specify complete file paths.

Share this post


Link to post

Naw have custom fields in OIP and reports, but couldn't show them on devices in the schematic--until I undid one thing. I hope what follows can help someone else, especially since the old documentation is now hard to find and current documentation is scant.

 

I edited the CustomParams.text as shown in a document I found about migrating from 2019 to 2020. I'm not trying to migrate anything yet, just setting up from scratch. You have to delete the leading semicolon to uncomment the line and delete the text from the ChoiceList field if you want a text field. I left the tabs in place in the text to designate the choice list in case a missing field would screw anything up.

 

1447462674_VWCCCustomParamsedited.thumb.png.39c340737b54dafd288643fbd58e332f.png

 

Then, I updated the field names in the dev_rec. DON'T DO THIS! BAD!

 

768182851_VWCCcustomparamindev_rec.thumb.png.ee24562e54ebbc347fa8c1ebdad31ec9.png

 

Then I added fields to the device report. I don't get why the fields are in sum mode, but I just copied and edited so they point to the correct fields. Then I copied dev_label_generic to make a new label adding new fields to a new label. If there is a way to make my custom dev_label the default I'd love to know it. I'll ultimately end up editing the default if I have to.

 

1736844994_VWCCcustomdevlabelwithtextlinkedtorecord.thumb.png.b9d31be74217ff49a567db820074edfb.png

 

At this point everything looks fine, but custom fields are not showing up on the device.

 

497757797_VWCCuserfieldsinOIPandreportbutnotdevice.thumb.png.519e0c842e818db3c09be8093015312f.png

 

I remembered that when editing the report fields the custom params name still showed up as user1, user2, etc. So I undid what I had renamed in the dev_rec record format then re-pointed the text labels at the correct fields and voila!

 

1584316580_ScreenShot2020-04-30at5_42_23PM.thumb.png.a8b6858ac795ff5701504d71a78df329.png

 

The only way I could figure out how to label the fields as above is to actually type it into the custom parameter box in the OIP. This is a _terrible_ idea because it will then end up in the field of the reports! Better to make a legend device somewhere on the drawing.

 

Now I've got to figure out how to customize the device in the 2020 version so that sockets don't interfere with all this data I've decided to add! Back to the forum!

 

Ean

 

 

Share this post


Link to post

Thank you Ean,

 

Listen everyone! Near the top of this thread I have posted a step-by-step guide to how custom parameters are handled in 2020. It explains exactly how to add parameters and how to visualise them. It does not tell you how to add a static text label - if you're confident enough to start customising anything I think it's safe to assume you know how to add a simple text object! A bit further down this thread you'll find how to add custom fields in reports. Again it shows a clear example of what to do.

 

I would be the first to agree that it is hard to find information in this forum. This is obvious from the fact that I have to answer the same questions over and over. Fixing that has made it to the top of my to-do list.

 

Meanwhile please check the thread "Did you know" for how-to's it can save you a frustrating wait for a reply here.

 

Thanks!!!

 

Conrad

Share this post


Link to post

@Conrad Preen 

Just diving into CC 2020 and I love how its working better that 2018. Much faster to use!

 

1. Are you working on an easier way to add custom fields by default in the reports? Maybe a flag in CustomParams.txt? As adding 5 columns every time I build a report is getting annoying. (it could be something we can turn on in settings)

 

2. It does not look like if i set a default a default value in dev_rec for the user values it auto populates when I create a new device. 

NewDeviceDoesNotuseDefaultFields.png

3. +Vote to add the ability to show custom fields the device builder as well it makes life easier as its all on one screen. More important is #2

 

4. +Vote for Naming Custom fields, I am migrating the custom fields now to user1,user2,user3. But it has taken a ton of time to do. As we heavily use custom fields.

Edited by Kevin Krautle

Share this post


Link to post

Hi Kevin,

 

Thanks for your comments. Regarding custom fields:

 

9 hours ago, Kevin Krautle said:

1. Are you working on an easier way to add custom fields by default in the reports? Maybe a flag in CustomParams.txt? As adding 5 columns every time I build a report is getting annoying. (it could be something we can turn on in settings)

If you save the document as a template the worksheet customizations are saved too. The menu command Current Layer Device Report simply opens the worksheet with that name and updates it. It first looks for the worksheet named Current Layer Device Report in the template and if it doesn't find it then it will import the worksheet from default content. So you only have to add the columns once.

 

10 hours ago, Kevin Krautle said:

It does not look like if i set a default a default value in dev_rec for the user values it auto populates when I create a new device.

No. 'dev_rec' has one purpose in life - to take values from Device fields and make them visible in the device title symbol as linked text.

Are you looking for a way to set the default value of user device fields.

 

10 hours ago, Kevin Krautle said:

3. +Vote to add the ability to show custom fields the device builder as well it makes life easier as its all on one screen. More important is #2

We have considered this. Device Builder is already a huge dialog and I do wonder where we would fit all this.

 

10 hours ago, Kevin Krautle said:

 

4. +Vote for Naming Custom fields, I am migrating the custom fields now to user1,user2,user3. But it has taken a ton of time to do. As we heavily use custom fields.

It's better than it was - previously you had to re-create your custom fields with every upgrade. Now you just have to copy the CustomParams.txt file to your new installation and your done. You can change the display name of custom fields to suit your wishes. Only the universal names are user1, user2 etc.

 

Hope that helps.

 

Conrad

Share this post


Link to post
3 hours ago, Conrad Preen said:

If you save the document as a template the worksheet customizations are saved too. The menu command Current Layer Device Report simply opens the worksheet with that name and updates it. It first looks for the worksheet named Current Layer Device Report in the template and if it doesn't find it then it will import the worksheet from default content. So you only have to add the columns once.

OK thanks i will check it out.

 

3 hours ago, Conrad Preen said:
13 hours ago, Kevin Krautle said:

It does not look like if i set a default a default value in dev_rec for the user values it auto populates when I create a new device.

No. 'dev_rec' has one purpose in life - to take values from Device fields and make them visible in the device title symbol as linked text.

Are you looking for a way to set the default value of user device fields.

YES! for a newly created device from device builder or using new device. 

 

 

3 hours ago, Conrad Preen said:
13 hours ago, Kevin Krautle said:

3. +Vote to add the ability to show custom fields the device builder as well it makes life easier as its all on one screen. More important is #2

We have considered this. Device Builder is already a huge dialog and I do wonder where we would fit all this.

To the right where it was before.

 

3 hours ago, Conrad Preen said:
13 hours ago, Kevin Krautle said:

 

4. +Vote for Naming Custom fields, I am migrating the custom fields now to user1,user2,user3. But it has taken a ton of time to do. As we heavily use custom fields.

It's better than it was - previously you had to re-create your custom fields with every upgrade. Now you just have to copy the CustomParams.txt file to your new installation and your done. You can change the display name of custom fields to suit your wishes. Only the universal names are user1, user2 etc.

OK, as long as it does not change again. I do understand why you did it, as we can no longer edit the plugin. But this major change should not happen again soon please!

 

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...