Jump to content
  • 0
JRoth

Issue with Import Images

Question

Suddenly, about a week ago, VW stopped being able to import images (I'm on most current version of 2018, Mac). It goes through the dialogue, asking about JPG or PNG, and I can even see a preview if I click Edit Attributes, but after I hit OK< nothing happens. I've tried on Sheet Layers, Design Layers, various Class settings—nothing. I need to be able to include map images for permit drawings, so this is pretty urgent. I've done it literally thousands of times over the years, never an issue before.

 

Anyone else?

Share this post


Link to post

6 answers to this question

Recommended Posts

  • 0

Update! It will let me import as a Bitmap, which will do for now. But neither PNG nor JPG work as Image Resources.

Share this post


Link to post
  • 0

This same issue happens after a full machine restart?

Share this post


Link to post
  • 0

Same issue here. I'm on Vwx 2019, and it still won't import images after a full restart. 

Share this post


Link to post
  • 0

What is the file size of the map images? Up to 150-200 MB will often work ok, larger images will take a bit longer but when you get into the GB range (e.g. satellite/aerial images of large areas or high resolutions) it may either fail to import, or import but fail to show or take a very long (sometimes 2+ hours) time to import. Splitting such images into multiple parts often helps, esp. when saving to JPEGs having a size of approx. 50 MB max.

 

Do keep in mind that most JPEGs have a compression factor of approx. 10 and Vectorworks will internally use the non-compressed size as far as I can tell so a 50MB JPEG is probably around 400-500 MB non-compressed so at some point even a JPEG will fail to import.

Share this post


Link to post
  • 0

Smallest image file tried was a 209 KB (!) JPEG and still no dice. Like @JRoth mentioned above, it will work if same image is imported as bitmap but not as JPEG. Same for larger images in the MB range. For now I'll have to make to with the bitmap option.

Share this post


Link to post
  • 0
7 hours ago, melon said:

Smallest image file tried was a 209 KB (!) JPEG and still no dice. Like @JRoth mentioned above, it will work if same image is imported as bitmap but not as JPEG. Same for larger images in the MB range. For now I'll have to make to with the bitmap option.

That sounds something is wrong with either your VW install or the JPEG is in a flavour that is not (properly) supported by VW. Especially with georeferenced/GIS files it may cause issues if the georeference/GIS formatting is not supported. Did you try importing the georeferenced file without geocoding sidecar file?

If you are allowed to share one of those problem JPEGs I'm willing to have a look at it and see if it has issues on my end as well.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×