Jump to content
Bruce Kieffer

Spacebar to pan

Recommended Posts

I'm having random failures using the spacebar to temporarily pan, and the same with spacebar+command, and spacebar+command+option to zoom in and out. I just had to reset my computer to get it to work again. Anyone else noticing this problem?

Share this post


Link to post

If you tab out and back in to the application does it sometimes restore functionality and sometimes not?

Does restarting the machine always fix it?

Are other modifier keys not working either? Like holding down shift to click more objects, adding them to the selection, or alt/ctrl to duplicate while clicking and dragging?

What other applications are you running? If Vectorworks is just running by itself does the same problem happen?

Share this post


Link to post

Jim,

Tabbing out and back to Vectorworks does not help. I tried that. Restarting always helps. Other modifiers work fine. I usually have Mail, 1Password, SnapScan Manager, Safari, and occasionally an Adobe CS5 app running. I never tried just running Vectorworks alone.

Share this post


Link to post

Applications on OS X can effectively call dibs on a particular hotkey or set of hotkeys. They are supposed to relinquish it (or ask for it back) when the user switches between active applications, but sometimes this gets stuck.

On a few occasions it has been a problem on our end that we were able to patch and on others it has been an issue with the developer of the other software. I'll have this one checked just in case.

Share this post


Link to post

Is this something you've heard of happening in Windows XP/7/8 as well?

I occasionally (once every few weeks, maybe) have my clipboard stop working with text correctly within VectorWorks, and I have sometimes had trouble kicking it loose short of logging off or rebooting. I've wondered if it was system-related, VW-related, and/or related to other programs we use commonly in the office (Firefox & OpenOffice, chiefly).

Share this post


Link to post

Thats a different and normally windows-exclusive issue. I saw it frequently in XP but really haven't encountered it at all since sometime around the Vista era.

Share this post


Link to post

Chiming in here.. I have the same issue: the using the space-bar to boomerang to the pan tool randomly stops working.

FYI I just updated to SP4 and the issue still exists.

Restarting always works to restore the function, quitting Safari always works (so far).

Share this post


Link to post

Looking through records here I am seeing more and more reports of Safari conflicts for hotkeys. I will see if anything can be done (Not always possible when its an Apple app on Mac), adding this thread to those cases now.

Share this post


Link to post

rookie user comment…I just use my middle mouse button to pan. I'm guessing there is good reason to invoke pan from space bar…?

Share this post


Link to post

If you only have a trackpad or a mouse without a middle button/scroll wheel (or if it is an annoying one) then the spacebar is your friend.

Share this post


Link to post

I find that with the left hand doing many hot-key combos, that spacebar (with the left thumb) + mousing more ergonomic in that it just requires less effort in the mousing hand.. might be a subtle difference, but it's more comfortable to me..

also, I have my middle mouse button mapped to spaces and mission control..

Share this post


Link to post

Spacebar, Command, Option no longer zooming in or out and really slowing down my work flow.

I rely on this hugely to work fast and efficiently. Any ideas.  Its not safari as i dont have it open...and dont seem to have any other conflict.

I used:

Spacebar - Pan

Spacebar , Command to zoom in

Spacebar, Command, Option to zoom out.

This was what i was always using but found it only worked on some workstations....

I have upgraded  to Mojav an also my wacom tablet to the latest intuos and wondered if this would be the problem, however i am desperate to find a solution so i am able to use these hotkeys again.

Please help...its frustrating not being able to use something  when you have spent years and years using it that way..feel a little lost.

 

Please help

Thanks

Ari

 

 

Share this post


Link to post

This is a problem for me again after so many years. I will try quitting Safari next time, but it looks like @Ari Phillips is having this problem now too. Computer restart is needed. OK, but doing so takes about 5 minutes, and two of those are to boot Vectorworks. Sad.

Edited by Bruce Kieffer
  • Like 1

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...