Jump to content
  • 0

Window Tags Randomly Disassociate



This is a BIG problem, that we've been having for more than a year on our shared projects. We're currently on 2021 Architect with the current service pack. Since 2019 our windows and door tags randomly disassociate. Interestingly wall tags don't.


We use window tags in annotation on viewports. It seems to be a project sharing issue. Any shared project will randomly disassociate it's window and door tags often. It generally happens after publishing to pdf. It's incredibly frustrating to see your work on plans and elevations disappear when you are trying to issue a set. It's especially disruptive on large projects where it can take an hour or more to re-associate tags. On one project it happened so often that we just typed tag numbers on top of tags with a text box, negating the advantages of BIM.


Others have been having this issue since 2019 and have posted on the troubleshooting forum. Here's one:

I don't see any answers other than it's a known issue and VW is working on it. In the life of a project we spend an average of 2 hours re-associating window and door tags per project (that we've recorded!). On average we have 21 projects per year. That's 42 hours per year that we have to eat because of a bug. I hope Vectorworks is starting to understand the magnitude of this issue. For the amount of re-work and frustration involved in this issue I would have thought VW would have fixed it by now. I hope you will move this to to top of your bug list.

  • Like 1
Link to comment

20 answers to this question

Recommended Posts

  • 0

Thanks Christiaan,

I'm sorry you're having this issue too, but I'm glad to know that I'm not the only one reporting it. VW responded to my bug report. I uploaded the file that we've most recently had the issue with, although I'm not sure if they will be able to recreate the issue. I also referenced your bug report. Maybe we can compare notes:

- The problem seems to happen only on shared projects.

- We work on dropbox. The project file is in a separate folder from working files.

- This issue seems to happen when we're publishing to pdf

- Most recently I published a set to pdf, saw that some of the interior door tags had disassociated (noticed on the pdf), another team member opened the file, reassociated the blank tags, published, then we noticed that some other tags (this time window and door) had disassociated. She reassociated the next round of blank tags, published, and this time they stayed associated.


It's hard to take a break to upload a bug report every time this happens, but I think we'll just need to do that or this might not be resolved.


If anyone else reading this has had this issue, we'd love to hear about it. If we all submit reports as soon as it happens maybe VW can isolate the issue soon.




Link to comment
  • 0


I was able to record a video of the tags disassociating while publishing to pdf. I sent the video and the file to VW and they were able to reproduce the unlinked tags. Except that it happened for them when they saved and committed, not when they published. This hasn't been my experience, so I'm guessing several things can trigger it. Has anyone else experienced this issue while saving and committing?

  • Like 2
Link to comment
  • 0

@Christiaan Thanks, I'm on the new update now. I guess we'll see if the update has any effect. Support sent me a new script that identifies unlinked tags in a file. The script requires sp3. I'm going to run the script once in a while to see what's triggering tags to unlink. They did discover one important thing though. Even though a tag displays the correct number, it doesn't mean it's linked. Apparently there's a bug that allows an unlinked tag to look linked. Apparently when we publish the previously unlinked tags lose their numbers. So although it appears that tags unlink during publishing, they are actually already unlinked but showing as if they are linked. Yikes, it'll be hard to isolate this without extra effort.

Link to comment
  • 0

I've also had this issue when publishing, does any think it could be due to the IFC references updating out of date information before publishing or the Pset_wall_common information from a referenced file taking priority. I have hundreds of data tags on wall types that need associating to walls every time i publish wall types plans or update other consultants IFC model references. I would be very keen to know if anyone finds a solution to this problem.

Link to comment
  • 0

Hi All,

I'm hoping for help from anyone who is experiencing this issue. Aksenia at tech support gave me this script that detects unlinked data tags. The idea is to test your file before publishing to see if the tags were already broken before publishing. I haven't had a chance to do any testing, but I did confirm that the script works for me. If we confirm that the tags are unlinked (but showing linked) before publishing, the next step is to run the script after performing various tasks to see what task is unlinking the tags. I've attached the script, and a video of Aksenia installing it, she didn't include sound, but you can see the steps. Here's her text explanation of running the script:


The script searches for the unlinked data tags on all layers.  For example, if you have two unlinked data tags in your document and you run the script you will see :

Layer Name: A1.01 – This is the layer where the data tag is placed.

X:-26’4.778”Y:-10’1.613” – These are coordinates of the data tag object on layer A1.01

To see the second data tag that is broken you should run the script again but before that you should fix the first data tag (to attach it again). If you run the scrip after all unlinked data tags are attached again you will see the “confirm nothing is broken” message.

To be able to find when the data tag is detached you should run the scrip after each your step. For example, insert a window in wall then run the script, add data tag to the annotation of the viewport then run the script, save and commit your changes then run the script, etc.



If we all test this individually we should have answers faster.




Link to comment
  • 0

Same issue on my side since 2 years. And it is also on all of our shared project. Something I have noticed is that it only happens on the tags we do in the annotation layers. 


Have any of you tried to uncheck this guy in the Publish-PDF settings? I am going to try it now on going forward and will keep you guys noted if it still happens.image.thumb.png.1e520823dedb5279b0c649d04e678ac5.png

Link to comment
  • 0

Another work around solution, if this happens only during your plot is to save your working file as a vectorworks drawings .vwx (instead of a .vwxw) (save as a copy in the file menu and make sure to change as a vwx drawings in the scroll menu) and plot it from there. It will give you a good archive of you set at the same time.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...