• Announcements

    • JimW

      How to use the Wishlist   09/21/2016

      Create a new post here, stating both what you would like to see added to Vectorworks or it's supporting systems and web pages and why you would like that change made. If you see an idea you like, press the ^ arrow to the left of the post's title to promote that idea or feel free to comment on that idea with any additional considerations or concerns you may have. 
  • 11
Kaare Baekgaard

Do not snap to self!

Question

When I work with subdivisions, nurbs or meshes, I have to turn off snapping temporarily in order to move vertices by a tiny amount.

 

If I don't, the vertex will snap to its own original position and prevent the move. Yes, I can move it a lot, but I cannot move it a little.

 

I wish, there was an option – under the 'Snap to Object' tool preferences – to prevent points, vertices, subdivision controls etc. from snapping to themselves.

 

Does that make sense?

Share this post


Link to post
Share on other sites

5 answers to this question

  • 0

Oh yes please, I run into this quite often when making small position changes.

Share this post


Link to post
Share on other sites
  • 0

Love it, I even flat out recommended disabling snapping entirely when working with Edit Subdivision in the videos because of this.

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, JimW said:

Love it, I even flat out recommended disabling snapping entirely when working with Edit Subdivision in the videos because of this.

Snapping with Subdivisions is way worse than with any other type of editing. Its especially disconcerting when using the dragger tool because it tries to snap to the cursor, not the origin of the dragger.

Kevin

Share this post


Link to post
Share on other sites
  • 0

Yes please! This would be useful across the board.

 

Even making a simple rectangle slightly wider is difficult because it snaps to its own edge. (Why would you ever want to modify something to be the exact size it already was?)

 

Of course you can always hold the tilde key (~) to temporarily disable snaps, but not everyone knows this and it can sometimes be clunky. Having the option to always prevent self-snapping would be an awesome improvement.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now