Jump to content
Bas Vellekoop

symbol > look at working plane

Recommended Posts

I was working on a symbol and wanted to use the 'set working plane' tool.

 

I am able to set the working plane inside the symbol, but not able to use the 'look at working plane' button.

This only happens when I'm on a sheet layer and open the symbol from the resource browser.

 

Is there a specific reason this is not possible?

 

Edited by Bas Vellekoop

Share this post


Link to post

It functions fine within a symbol here. Maybe a quick restart will solve it?

Share this post


Link to post
1 hour ago, Bas Vellekoop said:

I am able to set the working plane inside the symbol, but not able to use the 'look at working plane' button.

This only happens when I'm on a sheet layer and open the symbol from the resource browser.

 

Its because you're editing a hybrid or 3d symbol from a sheet layer which is 2d. I have no idea why it works this way but the solution is to switch to the design layers and try again. Lots of commands are disabled when you enter a symbol from the sheet layers including the view dropdown for standard views. I think I've wish listed or bug submitted this before. Editing a symbol should behave the same everywhere.

 

Kevin

 

Share this post


Link to post

@markdd

 

Does it function when you are on a sheetlayer, then go to your resource manager and then go 'edit 3D component'?

Here the 'look at working plane' icon is grayed out

 

If so then it is probably a bug.

 

 

 

 

Share this post


Link to post

I wasn't opening it from a sheet layer. However, if you do use the Select Working Plane function (on a sheet layer) it works fine and although the Look at Working Plane button in the toolbar is greyed out, my number keypad which I use to select views seems to allow me to rotate to a top view of the selected working plane, which in a round about way is what you asked for!! It seems to me that shouldn't happen on a sheet layer and that is the bug!

 

I agree with Kevin, hybrid or 3d symbols should at least have the option to open in a design layer environment when you decide to edit symbol from the resource browser when in a sheet layer. Sounds complicated, and is certainly tricky to explain!!

Share this post


Link to post

I found this issue when coming from a different direction a little while ago, initially it came back as WAD but I'm debating that with some folks currently.

Share this post


Link to post
2 hours ago, JimW said:

I found this issue when coming from a different direction a little while ago, initially it came back as WAD but I'm debating that with some folks currently.

This problem has existed for as long as I can remember (likely from when sheet layers were introduced). Having the symbol edit mode behave differently depending upon whether you enter it from a design layer or a sheet layer is bad interface design. I vote for BAD (broken as designed) rather than WAD :). It is also very confusing for new users who think the interface is suddenly broken. Its going to get even more confusing with multi view...... 

Kevin

Share this post


Link to post

This has annoyed me for a while now.  It becomes a matter of remembering to exit sheet layers to a design layer and then edit the symbol.  Gotta agree.  Editing a symbol should be the same no matter where you are in the file.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×