Jump to content
  • 0
zoomer

Space Mouse Enterprise on Windows

Enterprise with VW 2019/2020 and latest Drivers  

2 members have voted

  1. 1. Does your Enterprise work and show all available VW Commands ?

    • VW 2019 with Driver 10.6.3 - works fine :)
      0
    • VW 2019 with Driver 10.6.3 - does not work
      1
    • VW 2019 with Driver 10.6.0 - works fine :)
      0
    • VW 2019 with Driver 10.6.0 - does not work
      1
    • VW 2020 with Driver 10.6.3 - works fine :)
      0
    • VW 2020 with Driver 10.6.3 - does not work
      1
    • VW 2020 with Driver 10.6.0 - works fine :)
      0
    • VW 2020 with Driver 10.6.0 - does not work
      2


Question

I don't get my 3DConnexion Enterprise working on Windows.

 

I think it was ok at the beginning, but corrupted with the release of

the buggy 10.6.2 Driver. It was taken back soon from Downloads

and replaced with the former 10.6.0 Driver for some time.

Now 10.6.3 Driver was released and I hoped that it will work again.

But it doesn't.

 

I remember similar Problems when VW 2019 was released.

I was able to repair these problems

(only about 12 Commands without Names and Icons available

under Vectorworks App Driver Settings Folder)

At that time I was able to repair it by duplicating the VW 2018 XML

in 3DConnection Folder in App/Roaming/ and replacing everything

2018 with 2019.

But that doesn't work anymore for me, neither for VW 2019 nor 2020.

 

As long as I use my old corrupt 2019 XML, when accessing Driver Settings,

they will switch from VW APP to a "3DxSmartUI.exe"

(which I think is the Driver Settings App itself)

Deleting all VW XML entries will keep VW App active in Settings while editing

but no Vectorworks App Commands Folder available, to assign buttons from.

Or if it is there, it has these 12 number entries without Icons only.

 

If it works for you,

could someone please attach his Vectorworks.xml from

C:\Users\user\AppData\Roaming\3Dconnexion\3DxWare\Cfg

that I can take a look at it.

Edited by zoomer

Share this post


Link to post

7 answers to this question

Recommended Posts

  • 0

Hello @zoomer,

 

Please put the configuration file I attached here into your configuration folder in the installation directory. On my machine, it's located here: 

C:\Program Files\3Dconnexion\3DxWare\3DxWinCore64\Cfg

 

Remember to restart your machine to make sure the config file is loaded correctly.

In my understanding, they changed the configuration file format and thus the files written in the old format don't work anymore.

 

Please let me know if this works on your machine. We will look for a more permanent solution to their new configuration format.

 

Thanks!!

Chih-Pin

Vectorworks2020.xml

Share this post


Link to post
  • 0

Thanks a lot Chih-Pin !!!

 

I did a lot of CFG deleting, restarts and un-/installs.

All existing XMLs in C:\Users\user\AppData\Roaming\3Dconnexion\3DxWare\Cfg

did not work. I got rid of all.

 

I also found the 3DCon Folder

C:\Program Files\3Dconnexion\3DxWare\3DxWinCore64\Cfg

and the few VW configs included, VW 2018 latest.

(a driver un-/install will recreate these, so they should be compatible ?)

 

VW 2020-sized a copy of VW 2018 XML, this will create a working

VW 2020 XML for me in my User Settings, after I opened VW 2020.

It works and I got the (about 55 or so) VW commands now, as included in XML.

Worked ok so far,

just no Icons.

 

 

I see your 2020 XML looks a bit more advanced than my 2018 duplicate.

Will try as soon as I am back on Windows.

Share this post


Link to post
  • 0

Hello Chih-Pin,

 

I realized that is exactly the same XML as I had modified for me from that VW 2018 template.

It will create a new XML in User/Roaming/..  as long as there is no other existing.

It will work and bring back all the commands provided by VW.

Just the Icons are missing.

 

I see in my Bricscad.xml a lot of links to where to find the Icon images,

(I think a mix of a few images copied to 3DCon Setting Folders, the rest

somehow taken from Bricscad App)

but I think VW never had such image links.

No clue where VW stores these, to offer for Enterprise's Display.

 

Share this post


Link to post
  • 0

@zoomer Thanks for this valuable information!!

We will discuss internally and see what's the best solution moving forward regarding to their XML format changes.

  • Like 1

Share this post


Link to post
  • 0

Everything was fine - at least for VW 2019 - with 10.6.0 driver.

It broke down with 10.6.2.

They took it down and said there would be problems WHEN you use

it with more than 1 Device. (Enterprise + CADMouse here)

 

Unfortunately completely uninstalling 10.6.2 and reverting to 10.6.0 did not

help for me, I did not have access to any App settings anymore.

So I went back to 10.6.2.

Everything else worked fine again, just VW lost Icons. (Commands, can't remeber ?)

Beside that opening Blender crashed 3DCon Driver.

 

I thought, here and on the German Forum, there are a handful users

of CADMice and Enterprises. Maybe not at the same time ?

At least no one beside me complained so far.

 

Now came 10.6.3 and I hoped it would fix everything.

VW still had no Icons on Display and switched to default 1-12 commands,

which did strange things.

(At least the driver does no more crash with Blender)

 

But with adding the modified VW 2020 XML it works for now though.

(VW 2019 too)

 

Share this post


Link to post
  • 0

Any chance to get all VW offered Commands for 3DConnexion

back for VW 2021 by a standard installation of VW and Driver

on Windows 10 ?

 

For 3DConnexion Space Mouse Enterprise,

including VW Icons on Enterprise display ?

Share this post


Link to post
  • 0

Renaming the line for executable VW2020 in the original file above into Vectorworks 2021 solved the issue for me.

Attached is the file I updated. Maybe you already did this yourself. No icons though, just text.

Vectorworks2021.xml

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...