Jump to content
Phileas

Weird behaviour of a pad site modifier

Recommended Posts

Hey guys I have a problem with my site model again...

 

I placed a "pad with vertical retaining edge" site modifier object to create the excavation for a basement ventilation window.

While the second one I created with the exact same method works perfectly well, this one has a weird thing going on inside it:

950906924_Capturedecran2019-06-05a11_07_31.thumb.png.e13941bc4a7d310beb0a0639e9db1905.png

 

I don't know why this "triangle" shows up inside the pad, despite the retaining edge defining where the vertical walls of the pad should end:

 

1306670757_Capturedecran2019-06-05a11_17_34.thumb.png.28c5d8b0d64154d6a82cde93bf958af5.png

 

As I said, I built the exact same thing on another spot of the project, and it works just fine:

1786916945_Capturedecran2019-06-05a11_18_33.thumb.png.9c97e80f7665842cd5d6aa3d788b0826.png

 

Duplicating the working and replacing the weird one doesn't work.

 

This type of error occurs in several places on my site model, despite the fact that no pads pads are intersecting each other.

1418166757_Capturedecran2019-06-05a11_20_14.thumb.png.12836978c0b7b6aa65504dcf58cd5a82.png

1885301250_Capturedecran2019-06-05a11_19_53.thumb.png.2fae52801e2bafd02337c043034ec4e7.png

 

Does anyone have similar issues and a solution to offer?

 

Share this post


Link to post

Might be worth trying with plain Pad - no retaining edges. Site model should create surfaces up/down  to adjacent edges.  Also some  problems arise if edges are coincident in plan even though different z - a little space between can make a difference Eg .0001mm

 

just a thought

 

- B

Share this post


Link to post

@Benson Shaw Good idea, I replaced every pad I could with a plain one a few days ago, and it solved some of the problems.

 

All pads are already spaced 0.001mm in plan, you're right it doesn't work otherwise.

 

however, I still need the retaining edge on most pads, as I need to control the walls of the pads and their height.

 

I still have a few imperfections like that left I can't get rid of, but I solved most of them simply by dragging the edga of a pad 100cm to the right, and then 100cm back to the left... I have no idea why or how that worked but I'm somewhat short on time and don't have the opportunity to figure that out.

Share this post


Link to post

I feel like either I'm using this tool wrong, or it's just not finished properly and full of bugs...

 

here's another example: no pads intersecting, no errors, nothing, and I get this result on pads that aren't remotely related to the one I'm modifying...

Share this post


Link to post
Posted (edited)

Kinda talking to myself here

 

I'm starting to think that my site model somehow ended up being corrupted or idk...

 

When I try to rebuild it from the source data by double-clicking the site model, there is no data inside it... And when I exit the model, it disappears completely, deleted forever... luckily CMD+Z exists lol.

 

I've got a separate file with a clean copy of the original site model. This one is still fine, but it says there are errors in the source data (3D polys), saying 3D polys are intersecting. It then marks every point where 3D polys converge as a problematic intersection in the source data. Maybe that could be the problem? I'll try and replace the 3D polys with 3D points at the correct height at every intersecton, and update you guys with the result.

 

btw, inserting the site model from my backup file into my current problem file, replacing the corrupt model and updating the new site model to show the site modifiers in place still ends up with the same problem, so no solution there.

Edited by Phileas

Share this post


Link to post

OK update:

 

The site model created with only 3D points still shows the same problems, so I guess my site modifiers are causing the issue.

 

However, there are no site modifiers intersecting, the site model is reporting no problems.

 

I'm running out of ideas...

Share this post


Link to post
On 6/13/2019 at 12:34 AM, Phileas said:

there is no data inside it.

I saw similar on your orig post. The pad w retaining edge that disappeared.  I did select one and noted that OIP reported  infinite xy coordinates. It vanished when deselected.  Sorry no solutions, but it indicates something wrong with the pad or nearby mods.

 

Sometimes surrounding the whole system of mods with a grad limits object solves some problems with aberrant spikes and holes and folds. Might be worth a try. 

 

-B

  • Like 1

Share this post


Link to post

Hi I had problems with pad with retaining edges so I just used pads, got same results and no issues.

Share this post


Link to post

@Benson Shaw yeah something appears to be wrong, I simply can't figure out what...

 

I already have everything surrounded with a grade limit, and yes it solved some issues, but some appear to be just generated by bugs... I moved one vertex of a problematic pad 5cm on the x axis, then moved it back to it exact starting position, updated the model, and the problem was gone lol.

 

@Alan Woodwell I already replaced every pad I could with normal ones, but I need a retaining edge for at least a few, so no real solution there.

 

Right now I'm simply hoping all the bugs will somehow disappear.

 

 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×