Jump to content

Vectorworks 2018 Hogs Application Memory

Recommended Posts

I'm running interchangeably between two systems:


Mac Pro (Mid 2010) w/ 16 GB RAM running macOS Sierra &

MacBook Pro (Retina, 15-inch, Mid 2014) w/ 16 GB RAM running macOS High Sierra


I have this same issue running Vectorworks 2018 SP2 on both machines.


When rendering (doing anything really, but rendering is the main culprit) I eventually reach a point where the application pauses and I get a message stating that "Your system has run out of application memory". This refers to virtual memory, not RAM. The only remedy is to quit and restart VW. I've been monitoring application memory usage in Activity Monitor while rendering, and sure enough, VW is consuming memory and never letting go. It climbs with each render until it gets around 35 GB and then it pauses and I get the message. My understanding is that an application uses this virtual memory while it is running a process and is supposed to release it when done. VW apparently is never releasing, which I think is referred to as a virtual memory leak. I upgraded the laptop from Sierra to High Sierra this morning to see if that would solve the issue, but it persists. Anyone else experiencing this problem? While I'v learned to monitor the situation and work around it, it's very frustrating and needs a solve ASAP.



Link to comment

I work for Mattel, who will not allow us to send files to others, though I may be able to send the system profiles. I'll ask, but usually the answer is a knee-jerk no. I know that makes troubleshooting hard, and I've run into this roadblock before with my organization, but unfortunately that's the way it is. Hopefully this post will help others with the same problem, and I'll try to provide as much info as I can.


I do have an update though. The rendering issue is still as described above for my Mac Pro running macOS Sierra, however the MacBook Pro now running High Sierra is behaving differently since updating the OS yesterday morning. Before yesterday it had been running regular Sierra, and exhibiting the same symptoms as the Mac Pro. Yesterday I decided to tax it as much as I could, and the result was interesting. The gauges I'm monitoring are in the Memory tab of the Activity Monitor; the numbers in the row associated with Vectorworks 2018 and the Memory Pressure graph at the bottom of the window. With the described problem, as rendering proceeds, the numerical amount of memory accumulates and the Memory Pressure graph fills up, going from green, to yellow, then to red which is when it pauses and gives up. At first the MacBook seemed to be on it's way to maxing out like the Mac Pro, but when the pressure started to hit red it suddenly released and dropped back to green where it continued to render as it should. The numerical memory value rose to about 40 GB and hovered around that spot for the remainder of rendering. The Mac Pro w/ Sierra never plateaus, only climbs. I've never paid any attention to this before, so I don't know if this is typical, but so far so good. I'm doing another test now and will update if this changes, but I've just recreated the situation I described above except that this time it has plateaued around 23 GB and the gauge is steadily green, so even better.


So, it appears (and I'm cautiously optimistic) that this is a macOS Sierra working with VW 2018 problem, and updating to macOS High Sierra fixed it. I'm the only one in the office still running regular Sierra, so I have no way to cross check, except with myself before I updated the laptop. I cannot update my 2010 Mac Pro to High Sierra, so I may finally have the legitimate excuse I need to force IT to upgrade my machine as they usually only respond to mission critical needs for hardware upgrades. I'm curious to hear if anyone else is having problems with VW 2018/macOS Sierra.



  • Like 1
Link to comment
  • 4 months later...
On 5/24/2018 at 5:21 PM, Jeremy Best said:

Hi @Seth Thomas


I know this seems really unlikely nowadays, but because virtual memory is written the the HD, is there any chance your startup drive is short or storage space?  


No, my HDD was plenty big enough. I've actually resolved the issue since then. Turns out it was the OS. I don't have all the details, but it seems that Apple changed the way it manages VM in High Sierra as compared to Sierra, and VW 2018 is using this new process, which caused my memory problem. Upgrading to High Sierra solved my problems. In my case I actually had to upgrade my entire computer because our IT department would not install High Sierra on my old Mac Pro Tower, so I ended up with a relatively new cylindrical Mac Pro. Anyway, problem solved.

  • Like 1
Link to comment
  • 2 weeks later...
  • 4 months later...

Hi Guys, I'm having a similar problem. I am running Vectorworks 2019 sp1. after working for around 2 hours (not rendering at a all) I get the attached error message. this doesn't happen with any other software so I think it must be somehow connected to Vectorworks.

my specs are as follows:

macOS High Sierra version 10.13.6

iMac (Retina 5k, 27-inch, late 2015)

Processor 3,3 GHz intel Core i5

Memory 8GB 1867 MHz DDR3

Graphics AMD Radeon R9 M395 2048 MB

I was advised not to upgrade from high Sierra as the new Mojave is unstable for VW2019. is this true?

judging by the above posts, do you think upgrading is the solution to my problem?


Link to comment
  • Vectorworks, Inc Employee

We can confirm this with Activity Monitor, it should be in your Application folder under Utilities.

Reboot your machine now that you've had that error, then start up Activity monitor first, then your normal apps and Vectorworks. In Activity monitor, click the Memort tab, then click the Memory column header to sort by which app is using the most memory. Work for awhile, then see what the usage gets to and reply back with a screenshot of the monitor if you get that out of memory error again.

8GB of RAM is a bit low for heavy file usage, but should still be usable as long as no other major apps are using a lot of it as well.

Link to comment
  • Vectorworks, Inc Employee
8 minutes ago, David Homer said:

This is the report from the activity monitor. any thoughts? I have ordered some additional RAM and should get it next week but everything I read suggests this isn't a RAM issue?

This is absolutely not an issue with you having enough RAM, Vectorworks reporting that much RAM usage would indicate a memory leak of some kind. Please get the file you were working with along with your system profil to tech@vectorworks.net and have them take a closer look. 

Link to comment
  • 1 month later...

This topic has been discussed several times before.

I am designing a glass structure to display and protect some carved Pictish stones. I am working with meshes derived from scans of the stones to make metal mounts to fit them accurately, so the file is quite big. Using VW2016 on my Mac Pro with a reasonable if not up to date graphics card, the file starts by using 1-2 GB of memory, then gradually increases until the computer displays the dialog shown by David Homer above, at which stage Activity Monitor is showing memory usage at 64-65GB, and the computer locks up and cannot be restarted or shut down.

I got to the stage where I simply could not get any work done. I bit the bullet and bought a new Macbook Pro with Radeon Pro 560X 4GB. Guess what? Different hardware, different operating system, problem is the same, although the more powerful machine copes with it and does not freeze up, so I can close the file and reopen it... regularly.

This is a known problem, so what would be helpful would be suggestions for pragmatic solutions.

Link to comment

Hi @RWSD, these symptoms sound particular to the file you're working on and seemingly not due to the quantity of geometry in it. You could try to search for this yourself or submit it to Tech Support for review/diagnosis and hopefully a fix. My experience suggests it could be one or more corrupt objects. 


To get this looked at ASAP please submit this issue through Tech Support channels: 

If you're in the USA: https://www.vectorworks.net/support/help

If you're elsewhere: Contact your local distributor or if you're on Vectorworks Service Select submit there for priority attention. 


If you'd like to try troubleshooting this yourself, here's what I would try: 



Cleanse The File In-Transition


Method 1: 

  1. Export the file to a prior version
  2. Reopen it in the current version. If the problem persists; 
    1. Open it in that prior version

Method 2: 

  1. Create a 'New blank document'
  2. Go: Tools > Organisation > Design Layers > New… > check 'Import Design Layers' and 'Choose…' your file
  3. Select all Design Layers > check the 'Import Layer Objects' radio button > click 'OK' 
  4. See if the issue occurs in this document. 

This method (2) should only be used if method 1 doesn't work because it cannot import your Sheet Layer contents meaning you'll have to recreate most work produced in Sheet Layers. 



Check for what I call 'far-out-objects'


Far-out-objects refers to the condition where either the main drawing or one-or-more stray objects are massive distances away from the Internal Origin. (Distinct from the User Origin). I'm discovering an every-widening range of symptoms brought on by this condition - which I've found to be one of the most common causes of Tech Support requests I receive. 


To rectify this condition without guidance requires either a decent aptitude with the Vectorworks interface or a fair bit of tenacity (relative to the severity of the condition). It's a hard process to write a one-size-fits-all set of instructions for but I'm currently trying to do this. I'll attach what I've done so-far for you to try if you wish. If you use it please let me know of any issues or suggestions you have. 


Tech Support Tutorial; Rectifying 'far out objects' - Written Guide.pdf

Edited by Jeremy Best
Replacing Tech Support Tutorial with an updated version
  • Like 1
Link to comment

Thanks for your time on this Jeremy.


I am aware of the problem of objects distant from the internal origin, I've had to deal with this in the past, usually when importing other people's Autocad drawings. I'm very careful about this when starting new models or new layers. While I agree that from a support point of view this is one of the first things to get people to look for, I checked this file very carefully for that sort of error, and it isn't the problem.


I tried your idea of exporting as a 2015 file, then re opening in 2016; interestingly 3 out of the 4 stone scans went missing! I didn't open it with 2015, I don't have older versions of the software installed on the same machine.


I also opened a new file and imported the layers from the original file; the layers all imported with the correct names, but they had no geometry in them...



I'm sorry, I don't know what you mean by "Cleanse the file in transition"



Link to comment
On 12/1/2018 at 6:57 AM, RWSD said:

I tried your idea of exporting as a 2015 file, then re opening in 2016; interestingly 3 out of the 4 stone scans went missing!

That sounds telling. Perhaps one or more corrupt objects. 




On 12/1/2018 at 6:57 AM, RWSD said:

I also opened a new file and imported the layers from the original file; the layers all imported with the correct names, but they had no geometry in them...

I think you missed this part of Method 2, Step 3: …check the 'Import Layer Objects' radio button

Link to comment
1 hour ago, Jeremy Best said:

That sounds telling. Perhaps one or more corrupt objects. 




I think you missed this part of Method 2, Step 3: …check the 'Import Layer Objects' radio button

What does "corrupt objects" actually mean, Jeremy?


You are quite correct, I mustn't have checked "Import Layer Objects", I have now imported them into another new file. I'll play with it and see if the problem has stayed with the imported layers.

Link to comment
21 hours ago, RWSD said:

What does "corrupt objects" actually mean, Jeremy?

Any computer file or parts of the data it is made of - say one or more objects in a Vectorworks document - can become corrupt. In this situation corrupt means the computer code that defines an object has an error in it. One could liken it to the way a typo in a word makes it technically incorrect and dysfunctional. 


They're not usually caused by user actions, they're seemingly just random and probably caused by hardware hiccups or programming conflicts. 


Sometimes certain actions on a corrupt object cause it to be 'recreated' and/or 're-written.' In Vectorworks this can be just editing a [corrupt] symbol, or adjusting a [corrupt] wall's parameters, but often importing it into another document is a more likely solution, - if it can be fixed at all that is. This is partly why:


Vectorworks recommends autosave is set to: 

Keep the 5 most recent backups - at minimum. - The more frequently your autosaves occur the higher this figure should be, so you have healthy versions of your objects you can retrieve if they subsequently become corrupt. 

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...