John Vancouver

Fit wall to object - 2

12 posts in this topic

Posted (edited)

Does any body know why one wall will fits to a roof object and the other gable end wall fits the shape but 6' to high. Same wall style. Same settings. 

 

jt

temp-1.jpeg

Edited by John Vancouver
0

Share this post


Link to post
Share on other sites

Try selecting the offending wall, click on the Components button in the Object Info palette and check to see if the tops of its components have an offset. If so, set them to zero. If that's not the issue, can you attach a small file showing the problem?

0

Share this post


Link to post
Share on other sites

Posted (edited)

It often helps for fit Roof to make sure that the Wall is really under the Roof

(at least temporary)

before you fit it to the Roof.

Edited by zoomer
0

Share this post


Link to post
Share on other sites

It is under the roof and there is no office. I create the walls at the same time so it pretty strange. Happened in another file. 

0

Share this post


Link to post
Share on other sites

Some of the other wall do the same thing. I just used the standard wall and the standard set up. 

0

Share this post


Link to post
Share on other sites

It is you Wall Style.

You fixed all you Walls Components Tops,

although what you want is the to have all Tops to have no distance to Wall height.

 

So if you set Components from Wall height, manual distances from it or not, it will do the fit fine.

 

You have set 2 of the 4 Components to react to Wall Peaks, which the Fit Object will create,

but somehow even that does not work (in VW 2018 ?)

 

 

And about overlapping, your Wall heights from Story Level binding does make the Walls Tops

overlap with the Roof. Seems to be no problem.

But there would be problems when you Walls Bottoms cross the Roof. In such a case you should

temporarily lower the Wall bottom under the Roof, do the Fit Wall and reset Walls Bottom to its

correct height afterwards again.

0

Share this post


Link to post
Share on other sites
9 hours ago, John Vancouver said:

 

I opened the file in VW 2018 and tried the following:

  1. Selected both gable end walls
  2. Ran the Delete Wall Peaks command
  3. Ran the Fit walls to Objects command

For me this fit the walls correctly.

 

I also tried this:

  1. Opened you file
  2. selected the offending wall
  3. edited its components via the Object Info palette.
  4. Set all component tops to be "relative to wall"

This corrected the issue.

 

Do either of these approaches help on your setup?

0

Share this post


Link to post
Share on other sites

I also ran the Delete Wall Peeks,

but realized that I can't do any changes to Wall top by adjusting any (overall) Wall height values.

(By the way the Components Tops were alle fixed to heights separate from overall Wall in Style)

That is why I tried Matt's second attempt first, also successfully.

 

But I do not get why Fit Objects will not simply create the correct (overall) Wall Peeks and Components

just reacted to those peeks as promised by the Styles Components Settings. Or better have that height

Offset.

So I assume there currently is something wrong in VW anyway.

0

Share this post


Link to post
Share on other sites

I think I got it. Thanks guys. Seems overtly complicated. It would be great if the commands that don't work because a toggle has been set somewhere else would be faded out and a highlight would pop up saying that this command or setting does not function be cause the wall setting such such is picked. 

 

My 2 cents. :-)

 

 

Edited by John Vancouver
0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now