Jump to content

3d component of symbols disappearing


Recommended Posts

I've had this problem on and off since VW2008.

I create a hybrid symbol for use in plans, sections & elevations. I place them in top/plan view and adjust their height in a side view. Then I cut a section or create an elevation VP and render hidden line.

The first time around, everything looks fine. BUT when I come back to update the VP later, the symbol doesn't appear. The rest of the drawing is there (walls, windows, doors, etc.) but my symbol is gone.

In the past, I thought the problem was related to importing the drawing from an earlier version of VW but now I'm starting to think it's something else. It only happens to symbols that I make myself. Symbols that came with VW don't exhibit this behavior - even when brought up from a previous version of VW.

I noticed that many of the symbols that come with VW are all drawn in the None class with "hard-coded" attributes (NOT By Class.) I generally draw everything in the appropriate class with attributes set to By Class so that I can override attributes in VPs.

Has anyone else had this problem.

Am I missing something?

Help!

Link to comment
  • Replies 79
  • Created
  • Last Reply

Top Posters In This Topic

Bill

I've had occasional trouble w/ symbols disappearing. I haven't been able to recreate it. Usually it happens on 3D only symbols that have nurbs curves.

The fix that has worked for me is to go into the 3D edit space of the symbol, from the resource browser. I don't have to actually edit anything, just go into it and back out. Then the 3D symbols become visible again, and it doesn't happen again during the life of that drawing.

hth

michaelk

Link to comment

Bill

I just had it happen again.

3D only symbols, made of an extrude along path in one class and a bunch of nurbs curves in another class. Symbols themselves are in the none class.

Making the both classes visible does not make the symbols visible in the design layers or SLVPs.

However, as soon as I enter and exit the 3D part of the edit screen for one of the symbols, that symbol pops back into view on both design layers and SLVPs.

There are 9 of these similar, affected symbols. I have to enter and exit the 3D edit part of each to make the visible again.

I'd post the file, but it's too big.

michaelk

Link to comment

This might be a clue (to somebody smarter than me):

I did a "Save Copy as..." so I could strip it down enough to post the file. Then closed the original file that still had the visibility problem and opened the new, about-to-be-stripped-down file.

But the visibility was fine in the new file.

I reopened the original file, and that visibility was restored as well.

I didn't relaunch VW, just closed and opened the file.

Next time it happens I'll do a Save As or just move the whole file to a website so I can submit it as a bug...

Link to comment
michaelk, I think that all of the symbols that I've had trouble with were made from extrudes.

Could THAT be the problem?

My symbols are Extrude Along Path objects in one class and nurbs curves in another class. No 2D. Symbols are inserted in the None class.

Both classes have Use at Creation checked to use class pen and fill colors.

michaelk

Link to comment

I believe it does persist through a reboot. But I can't be sure.

I know that just renaming the file, closing it and reopening it fixes the problem.

As does entering the 3D edit space and exiting right away again. - This will fix the issue for one symbol at a time. In the drawing I'm currently working on there are 9 3D symbols that have had this issue twice in the last couple weeks.

When the problem presents itself, all nine symbols are invisible and don't respond to class visibility changes.

The extrude along path object is created from a path object and profile object that are both in the same class as the EAP.

A TOPIC FOR ANOTHER THREAD:

I have noticed a problem with editing the EAP, but I think this is a separate issue. Double click the EAP > Profile, then deselect everything, right click on empty space, choose Edit Path. VW jumps out of the EAP and back into the drawing. Double click on the EAP again, and you are brought straight to the Path object part, without the dialog box asking what part you'd like to edit. (same issue happens when trying to go the other way..) I've tried this on the problem drawing and on a blank drawing same result.

michaelk

Link to comment

It happened again and I was able to capture it.

I will include it as an attachment. I had to strip everything away to make it fit as an attachment here, so there is little context - but here it is.

This is what I'm seeing:

1. In wireframe render I don't see the symbols

2. In Open GL they appear.

3. Meanwhile, back in wireframe, click on one of the symbols in the Resource Browser>Edit>Edit 3D>Exit symbol will make that symbol appear. (The affected symbols are all in the symbol folder: "Stupid Tension Grid"

Bill, is this the same thing you're experiencing?

michaelk

Link to comment

michaelk, That does sound like the same problem. Objects appear in solid rendering but not wireframe or hidden line. "Editing" 3d component of symbol without making changes fixes the problem (temporarily.)

I haven't tried the Save as Copy "fix" but I'll be a little surprised if that really fixes the problem. My experience has been that all "fixes" are temporary. Eventually, I have the problem again.

My problem symbols are all Hybrid.

Link to comment

Try turning quartz off?

Same for anti aliasing, 2d excelleration, and other visual settings that are available in your verion.

Might also play with the 3d resolution as well.

The intermitent nature sounds like a screen buffer type problem.

You might also stop operations you are running in the background as these could effect the video buffer.

Link to comment

Great suggestion, thanks.

It's happening again right now. Quartz and anti-alias settings have no effect.

I have my doubts about a video buffer. Last time it happened I rebooted the computer and it was still misbehaving. Right now I have almost nothing else running. Activity monitor shows 90% idle.

Here's a couple more clues:

1. Symbols do not appear in wireframe, dashed hidden line, or hidden line render mode.

2. Symbols DO appear in Open GL, Final Quality Renderworks, Artistic Renderworks, and Fast Radiosity. (Those are the only render modes I tried.)

3. In the 3 modes where the symbols do not appear, the curser will snap to them and preselection highlighting will appear as though it were visible.

4. They can be selected, but remain invisible when selected. Only the selection highlight is visible.

5. In views other than Top or Top/Plan the invisible symbols behave like (invisible) 2D screen plane objects. Even though my symbols are 3D only symbols. I can snap to them an select them, but they are stuck in Top/Plan view (and, of course, invisible).

6. Entering and exiting the edit space for any of the symbols will cause that one symbol to immediately behave as expected in wireframe, dashed hidden line, and hidden line.

Bill, are you also seeing 1 - 6?

michaelk

Link to comment

I don't think that it's a screen buffer issue either. When rendering in hidden line, the objects don't obscure objects behind them. So, If my symbol obscures some part of an object beyond in an elevation view, in hidden line rendering, I can see all of the object behind (as if nothing is in front of it.) BUT if I render in a "solid" rendering mode, like RW, the object behind IS obscured. AND, if I render with RW as background, and hidden line as foreground, the "solid" part of the rendering looks fine but the hidden line foreground doesn't show an outline around the symbol and the outlines of objects beyond are visible.

michaelk, I haven't tried wireframe or dashed hidden line but I suspect that my objects would behave as you describe in 1 and 6 above.

I THINK that turning on all classes while in sheet layer might be fixing the problem for me. It didn't seem to fix it when I made the initial change a couple of days ago but now the problem VPs seem to be rendering properly when I make sure that all (or almost all) classes are set to visible when I'm viewing the sheet layer. I assume that it would also work if I only turned on the classes contained in the problem symbols but, right now, it's just easier to turn them all on.

WHY WOULD THAT MAKE ANY DIFFERENCE?

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...