Jump to content
Sign in to follow this  
REB

Light Rendering less intuitive than before

Recommended Posts

I've recently upgraded from 12.5 and I'm trying to get a handle on the changes made in 3D rendering with light. My primary issues follow:

1) I liked being able to use my light symbols to render light by inputting height and focus (and swatchbook color, etc..) I have not seen any option akin to the "light on" checkbox that was in 12.5. Is there some other way that's eluding me? I don't see anything in the object info palette.

2) Grudgingly using the light tool instead, when I click "cast shadows" there are still no shadows cast. Is there a hidden setting somewhere, or is this some kind of bug? Is there some other option for color selection than a color picker - like being able to input a catalog number?

Share this post


Link to post

Have you taken a look at the Visualization Palette? This will let you turn on and off individual lights and if you right click (control-click) on them, you will be able to edit the specifica of a given light.

Share this post


Link to post

Yeah, I saw that - I like it, but the column that says "casting shadows" or "not casting shadows" shows that it's supposed to be, but it definitely isn't.

Share this post


Link to post

1. If you have more than a couple lights to deal with, the Visualization Palette is definitely faster. (The trick is to make sure every instrument has a Channel # and/or Purpose - otherwise you can't tell what's what.)

But in the regular OIP you can still enter the gel color, height, and focus point.

If you want to get straight to the "light on" button, you can right click on an instrument and select "Edit Light..." This will open up a window that controls the light source built into the symbol.

2. There are two parts to casting shadows. The light has to cast a shadow and the object casting the shadow can't have a texture that doesn't cast shadows (like Spotlight Instrument Symbols). That may be what you are seeing.

And I don't think a regular light object will take a Rosco or Lee color number... Pretty sure that's a Spotlight only thing...

hth

michaelk

Share this post


Link to post

2A. Actually 3 parts to casting a shadow: #3. Some geometry for the shadow to fall on.

michaelk

Share this post


Link to post

I figured out one problem - somehow the default shutter settings for my instrument symbol had them all pushed in. It seems someone owes the ME a beer!

Though I still have the shadow problem... I have a people figures and wooden benches that all should be casting shadows on the surface they're standing on. All objects are clearly lit by that source, but no shadows on the ground or other people or objects in the way.

Share this post


Link to post

Ah. I must've been clicking "Fast Renderworks" and not "Fast Renderworks with Shadows" by accident.

Is there a logical way to use the shutters to make cuts that isn't guess-and-check? Does it strike anyone else as backwards that the little diagram that shows the shutters is a black circle on a white field and not the opposite?

Share this post


Link to post
Is there a logical way to use the shutters to make cuts that isn't guess-and-check? Does it strike anyone else as backwards that the little diagram that shows the shutters is a black circle on a white field and not the opposite?

No and yes.

michaelk

Share this post


Link to post

I've asked this question before, but never really got a good answer. Here goes: when rendering (in any mode) my shutters cast shadows. It's a real pain, especially when I'm showing students how to use shutters. Anyone have a fix for this? thanks!

Share this post


Link to post

bjw,

I don't understand why the shadows are a problem. Do you not want shadows? If so, then make sure "cast shadows is turned off for all the lights you are using. Send a screen shot. That may help us see what you have. I would be more inclined to think you could not differentiate the slats of the shutters without shadows, and/or hidden line rendering. That's the problem I constantly encounter. RenderWorks shadows are nowhere near as good as the human eye. Object with the same color, and near each other, do not separate well, if they do at all. Yet our eyes see them perfectly fine in the real world.

Share this post


Link to post

Bruce - Brandon is talking about shutters on ellipsoidal lighting fixtures. Not shutters on windows. It's a Spotlight thing.

Brandon - When I use shutters, they only render with Fast Quality w/ Shadows, Final Quality Renderworks, and Custom Renderworks (with the right settings). But don't you want the shutters to cast shadows?

michaelk

Share this post


Link to post

I've attached a simplified file that contains my latest migraine. The same process I used in 12.5 to render gobos with lighting fixtures does not work in 2008. I've tried using custom and vw provided gobo textures. The light will render without a gobo, but once the gobo is in, it is as if the gobo is opaque, and renders black. I've tried a ton of different setting options, and can't figure it out. The unit has a fill, Ray-traced shadows is selected, there's only 1 layer in the document, etc. etc. I've tried with and without a lot of settings, I've tried it in Final Quality and Custom Render modes. I've even zoomed in on the unit in wireframe, and when the gobo is put in, it looks to be in the right place (even though the beam shows the light going through the body) I have run out of things to try. Anyone have new ideas? I feel like it must be a problem with the gobo texture, but I can't figure out what it would be.

Share this post


Link to post

Hold the presses. Not 2 minutes after posting the last comment, I figured out the problem. I think it might be a bug. It's related to the black background preference. If you wish to experiment for yourself, you can open up that file then:

1. Set VW preferences to black background on.

2. Enter a texture in gobo 1; FQRW

3. Observe lack of light and gobo image.

4. with FQRW still on, switch preferences to white background.

5. Observe unchanged lack of light and gobo image.

6. with FQRW still on, reenter the name of the texture in gobo 1 in the OIP.

7. Presto. gobo.

Now... here it gets even funkier...

8. Keeping FQRW on, change prefs back to black background

9. Now you probably have a gobo image AND a black background!

10. BUT... now try reentering in the texture name in gobo 1 of the OIP (or a different texture)

11. Alas, no more gobo.

I also had a friend try this out and the same results occurred.

So, now that I've figured out my problem, I can work around it by working in white background and using a big black box behind my drawing, but the question is "Is this a known bug with a fix pending?"

Edited by REB

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...