Jump to content

Drawing A Line

Recommended Posts

Hi, so i was wondering if someone could help me with a question. I'm kinda new to Vectorworks, and i am trying to just draw the outline of a parking lot. I am trying to do this with just the simple line tool, but i prefer to use coordinates when i draw. So i activate the line tool, press tab to see the data bar, and go to type in my coordinates, but as soon as i press a number key, Vectorworks selects a new tool, like all the numbers are keyboard shortcuts. I'm working on a laptop, so i am using the number keys on the main section on the keyboard, and when i trying to hold down my 'function' key and enter numbers with the fake keypad, nothing happens at all. Any help? any way to disable the keyboard shortcuts? Thanks for the help.

Link to comment

From what i can tell i'm doing everything correctly. When i try to use the fake keypad on my laptop, i can type symbols into the coordinate text boxes, like negative and asterisk, but as soon as i try to enter a number, it switches tools...

Link to comment

There are some circumstances where VW takes the number input directly, and others where you have to explicitly tab (or in the case of popping up the data bar with a tab, you have to tab twice).

I ran into this when I first started.

Setting the data bar to popup automatically made things smoother, but it still happens occasionally.

But mainly it's just a matter of transitioning to a new way of working.

I would recommend using polygons over lines, or joining rectangular surfaces, that's just my two cents though.

Link to comment

when I reread your original post, I may have seen the issue. When you say activate the tool, do you mean selecting say the line tool, either by clicking the line icon in the tool palette (or the appropriate keyboard shortcut) and then hit tab to start entering the parameters. Or do you select the tool and then click on the drawing to set the start point of the line and then hit tab to bring up the data bar? If it is the latter, then my original answer at the bottom of the post should help. If it is the former, continue reading for what I think will help.

if you want to perform both the placing and the sizing without using the mouse to specify the start point, then either double click with the mouse on the tool icon, or hit the keyboard shortcut twice. That will allow you to specify a start point, and the appropriate dimensions to your object.


Below is my first response, then I reread your first post.

I think it is because you have two settings that are interfering with each other.

In the top right of your window, are two triangles pointing to the right. Click on the lower of these, and you will see the data bar options. I am going to guess that you have your options set this way:

"Use floating data bar only when tab key is pressed"

"Do not allow numeric keypad entry for instant data bar activation"

Even though the second specifies the numeric keypad, it appears it also interferes with normal numeric entry in the manner in which you describe.

To make it work with the settings as you have them, hit the tab key twice, or until you see the first value in the data bar highlight, then start typing.

to fix the problem, set the second option to:

"Allow numeric keypad entry for instant data bar activation"

as of right now, that will do two things for you, one, it will allow data entry after hitting the tab key once. The other, once you have memorized the order of the data bar, you can simply start typing the appropriate value (e.g. Length for lines) and it will start editing it and bring up the data bar.

Link to comment
.... any way to disable the keyboard shortcuts?
Yes: pull down File > Workspaces > Workspace Editor > Edit a copy of the current workspace

But I'd be surprised if that solves your problem. For one thing, the keypad numbers shouldn't be able to select tools. For another, even if you press a letter key while in a data bar cell, you just get that letter in the cell. You don't get the tool associated with that key.

At least that's true with a normal desktop computer. There could be some mix-up caused by the way your laptop's fake keypad works.

You may have to get a real keypad, which in any case will come in very handy for CAD work or anything else that involves a lot of numeric data entry. And the Enter key on a real numeric keypad acts like the Tab key, getting you into the data bar or on to the next cell. So you can enter data quickly, touch-typing on the keypad the way accountants and book-keepers do.

Link to comment

I think your are correct jan15. Sounds like it is dual function keys on the laptop, you should be able to disable it. Jeff, please add a signature to your posts (My Stuff link at the top, My Profile) with VectorWorks version and computer specs including OS version and laptop make and model. I would want to take a look at the laptop specs.

Link to comment

Jan and Ray, if you look at the first post, you notice he is using the normal numeric keys, (above the QWERTY row) and that is switching tools. If he uses the 'fake' numeric keypad nothing is happening, which is what appears to happen when you are drawing entirely in 2D and you use a standard numeric keypad. The view changes, but the 2D elements stay stuck to the screen plane, so it appears like nothing is happening at all.

it is either 2 presses of the tab key, or as I suspect that the tool is not being initiated, and he either needs to click on the drawing to start the tool, and use tab to get to the data bar, or if what he wants to do is entirely by coordinates, to double click the tool icon, or the keyboard shortcut to enter the appropriate values to get an object.

Link to comment

Yes, I missed that, Ion. With that in mind, it does sound like his "press tab to see the data bar" isn't actually getting him into the data cell, and that's why keypresses are still interpreted as tool shortcuts. And keypad numbers don't select tools, so that's why nothing happens with them.

I don't understand your second paragraph, though. Why do you think he's not in the line tool? It sounds like the tool shortcuts are working. And the data bar should work no matter what tool he's in.

Jeff, is the problem solved if you mouse-click in a data bar cell and then enter the numeric data? And what happens when you press the Tab key several times?

Link to comment
...but i prefer to use coordinates when i draw. So i activate the line tool, press tab to see the data bar, and go to type in my coordinates,

This reads to me like someone who is choosing the tool, and then expects to create the object and location entirely by keyboard entry.

Like say in AutoCAD, invoking the line command, typing in start point, length etc...

Link to comment

Yes, that sounds right. He may be trying to use the data bar to set the start point. That should work. Just type the X and Y coordinates in those cells, with an Enter after each one, and VW draws a crosshairs at the start point. But you can do it in any tool, even the Select tool. I don't understand how it indicates he's not in the Line tool.

That sentence continues

but as soon as i press a number key, Vectorworks selects a new tool, like all the numbers are keyboard shortcuts.
That just tells us he's not in the data bar. The top row number keys ARE all shortcuts for tools in the standard workspace. But if he was in the data bar they wouldn't be interpreted as shortcuts, they'd be interpreted as numeric data to put in the cell.
Link to comment

Except that if you aren't hitting tab twice, the data bar will be displayed, but any entry will be interpreted as a shortcut. you have to hit tab twice to enter the data bar.

I wasn't suggesting he wasn't in the line tool. I was saying that he had selected the line tool, but had not clicked to start a point. Because if he had clicked to initiate a line, further key-presses would not have switched to new tools, and only clicking again or the escape tool would have terminated the active line.

In the end one tab press will activate the data bar, and it looks like things should happen, but key entry will activate shortcuts, it takes two tab presses to activate the data bar, and start editing the fields.

Also, you don't even to use the enter key anymore, the tab will move you from field to field and accept the value.

Link to comment

Yes, that must be it. It's what I was trying to say in all three of my previous posts ? that he's not really in the data bar ? but I guess I didn't make it clear.

I thought you were suggesting he's not in the Line tool because of this:

I suspect that the tool is not being initiated, and he either needs to click on the drawing to start the tool, and use tab to get to the data bar
and because I thought you were answering the question I posed in response to it:

Why do you think he's not in the line tool?
Sorry for the confusion.

My data bar shows all the time, and I get into the first cell by hitting the keypad Enter key once. But in my second post I suggested trying multiple Tabs to get into the data bar, because Jeff said he has to press Tab just to see the data bar.

Link to comment

One last time, keeping it simple...

1. Be sure data bar is set to "Use floating data bar" (or "Use floating data bar only when tab key is pressed") - SEE ATTACHED IMAGE

2. Select line tool

3. Either click on start point, the data bar should appear when you begin to drag the cursor away from the click point (OR hit TAB to invoke the data bar).

4. TAB to highlight the first value of the data bar,

5. Type in value, doesn't matter from which keyboard you use.

6. TAB to accpet the value and move highlight to next value on the bar,

7. RETURN when you're done entering values to accept and end.

Link to comment

Actually, you need to click also.

If you use Jeffery's method to set a point, you still need to click (anywhere) to set that point. Then you can use the procedure to enter the coordinates for the next point and click.

I don't think there is a way "out of the box" to enter line (or other object) point coordinates and have them draw without clicking at each point.

It could be scripted though.


Link to comment
  • 10 months later...

Just some thoughts about that topic after having switched from a 12.5 to a 2009:

I understand that you need to either click or tab to get the floating bar to appear, even if "Use floating data bar" is checked. (Although I was expecting the data bar to be ALWAYS on my screen if this option was checked...)

So: No matter which "Use floating data bar" option you've checked, you always need to tab to see the floating data bar.

Although the "Allow numeric keypad entry for instant data bar activation" is checked, you will have to tab A SECOND TIME to get into the first data bar field. If you don't tab a second time, entering numbers will result in changing views or switching to another tool. ? Is this a bug or do I misunderstand anything?

(NB: I'm using VW on a laptop with an external keyboard that also has a numeric keypad.)

I found out that you always need to press TAB twice before entering the start point. Quite annoyed I ended up in using the fixed data bar again. It only needs ONE TAB to enter data.

But what's the use of the floating data bar then?

Link to comment

Maybe what you want is available, but just not in the floating data. In the bottom right corner of the screen is a small black triangle. Click it and you get a pop up menu letting you control what positional information is shown at the bottom of the screen ("message bar").

With it set to show the positional information, you get X, Y, Length and Angle information relative to the current datum point.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...