Jump to content
  • 0
B Cox

Speed Issues w 2D Drawings

Question

Hi I'm wondering how I can make vectorworks run faster.

 

I have run vectorworks for the past 8 years and I'm dealing with a file that is heavy, like 40 megs of almost all 2d linework, few bitmaps, some BIM objects like walls and windows. Nothing is textured.

 

My PC normally runs VW just fine and snappy. I switched to best performance already.

 

My computer is i7 6700k, 16 gigs of ram, SSD, GTX 970. I'm running 1080p screen. 

 

This file just drags everytime i do anything or zoom in or out. I've tried purging it already. I'm checking my activity monitor and it never peaks above 30% load on CPU, GPU, Ram or disk. It just seems like is vectorworks calculating the stacking order of all the vectors or something. Is there something I could do to make this faster?

Share this post


Link to post

9 answers to this question

Recommended Posts

  • 0

One of the things that greatly slows VW is the calculating and redrawing of selection handles. If you can group a lot of the items so the selection handles don't have to be calculated (except for the 8 of the group) you might end up with a snappier drawing.

 

A long time ago (in a galaxy far, far away) I did a test. I tried a file with something like 60,000 lines. To Select All or Deselect All took multiple minutes. I then Grouped everything and the time to Select All went to just a few seconds.  Your mileage may vary.

  • Like 1

Share this post


Link to post
  • 0

@Pat Stanford thanks--I wonder. Unfortunately other users of this file imported a bunch of dwgs from another autocad project. The result is many thousands of ungrouped objects at the design layer level.

Share this post


Link to post
  • 0

Could you possibly use Classes to isolate the imported object and group them? You can always enter the group and Cut/Paste In Place the items that you need to work on while leaving the rest as is.

 

Or even just try a quick test to select everything on each design layer and Group them. At least that way you can relatively quickly see if that help with the speed.

 

Share this post


Link to post
  • 0

I went through and i put everything into groups by geographic location in the file, it still is pretty slow. Because we are dealing with several different users inputs we also have several hundred classes. Harder to untangle that. I wish vectorworks had a visual tool for re-mapping classes. It would make dealing with autocad and rhino users much easier.

Share this post


Link to post
  • 0

In imported data, it is quite possible that you have "curves" that are actually hundreds or thousands of line segments. That will certainly slow down a file.

 

If you are only using the Acadias data as backgrounds, it is usually better to import it into a separate file and then do a referenced viewport into your working file. That way you isolate all of the Acad "Layers" (VW Classes) to the other file instead of contaminating your drawing.

 

I know that best practices are probably too late for this project.

 

About the only other thing I can suggest is check for duplicated objects. Run the Purge command using the "Coincident Duplicate Objects" options. Perhaps things got doubled or tripled and you can get rid of them to speed things up.

  • Like 4

Share this post


Link to post
  • 0

Also check the density of imported hatches.

If you import an acad file and the content isn’t in the correct size, most users will scale the imported objects. The hatches however won’t scale and might be extremely dense. This results in zones with hundreds of thousands of hatch lines that have to be computed by the graphics card. This will dramatically slow down the file.

  • Like 3

Share this post


Link to post
  • 0

@B Cox Hatches aren't necessarily an issue in imports. If you import the file in the correct way, it will be no problem.

The issue is that most ACAD-users never fill out the used units in their file, so chances are the units recognised are wrong.

 

Here's the best way to import a dwg-file:

  • Open a new, empty drawing with your drawing units set. (The issue with wrong sized dwg-imports isn't scale related, it's unit related.)
  • Import the dwg-file without using the automatic unit recognition. Start from the idea that the ACAD user is using your own units, so select your own units.
  • After the import, verify the size of any object of which you know a size. Don't trust those things that look like dimensions, often they are groups of lines and texts.
  • While you see the size of the object, try to determine the units in which it has been thought. I.e. if I see a stair in my drawing in cm that says it is '900' wide, I know that should be mm, not cm. This way I'm sure the ACAD-user has been thinking in mm.
  • DO NOT scale all the imported objects, this will cause the hatches issue. Instead of scaling the contents, just close your vwx-file without saving.
  • Open a new vwx-file with your units set.
  • Import the dwg-file for the second time. Now choose the units you derived from the previous import.

The import will be OK. Hatches will no longer be an issue.

  • Like 1

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...