Jump to content
  • 0
Stéphane

Section cut casting an unwanted shadow

Question

Hello everyone, 

 

I'm pretty new to Vectorworks and still exploring its possibilities. I have discovered this forum which is really great and helped me to solve most of my issues. However, the issue im submitting to you today remains unanswered for me; that's why I created a new thread and really hope you could help me on this. 

 

So, I have a closed box made by walls and slabs that is cut in a section viewport. The box should be completely shadowy but light still cast in it. Why ? 

I explored the "Cast shadows of objects removed by section" found in "Advanced section properties" by ticking it and unticking it and nothing changes. Thinking that it could be a bug based on the objects themselves, I also tried to remove the wall and recreate it. Same for the heliodon. Still nothing changed. 

 

Yes, my trees look like pink marshmallows. 

 

1410998073_Capturedcran2020-09-2511_08_54.thumb.png.9020ca92b3d8cd8ca7e94a700dc9bddb.png48482830_Capturedcran2020-09-2511_38_56.thumb.png.c9e999df071f76cc7becdd3b67d0268d.png

Share this post


Link to post

11 answers to this question

Recommended Posts

  • 0

Hello, 

 

Is my post clear enough ? Would you need additional informations in order to answer ? 

Share this post


Link to post
  • 0
10 hours ago, Stéphane said:

Hello, 

 

Is my post clear enough ? Would you need additional informations in order to answer ? 

 

Can you upload a small file showing the problem?  Maybe make a copy of the file, delete everything out but the walls and slabs involved (and the section viewport), and purge all unused stuff?

Share this post


Link to post
  • 0
18 hours ago, Matt Panzer said:
On 9/30/2020 at 3:07 AM, Stéphane said:

Hello, 

Is my post clear enough ? Would you need additional informations in order to answer ? 

 

Can you upload a small file showing the problem?  Maybe make a copy of the file, delete everything out but the walls and slabs involved (and the section viewport), and purge all unused stuff?

 

If you'd rather, you can send the file as it is to me privately.

Share this post


Link to post
  • 0
4 hours ago, Stéphane said:

Tank you Matt for your answer. Here is a test file. I checked it and the issue still occurs on it. 

TEST FILE.vwx

 

Thank you for the file.  I took a look and see the issue.  I investigated this and found it is a known bug that affects a Renderworks modes.  OpenGL, however, does provide correct shadows (make sure to select Use Shadows on the OpenGL render settings of the viewport).  If you can get by using Open GL, that would be a possible workaround for now.

  • Sad 1

Share this post


Link to post
  • 0

Thank you very much Matt for you investigations. I must say it is not the answer I would have liked to read, because I started to love these cartoon renderings. When will this issue be solved ? Will it be solved in VW2020 ? 

Share this post


Link to post
  • 0

Hello Stephane:

I think this problem is specific to using Artistic RW style.  It doesn't happen with Photorealistic RW style.  Using a Photorealistic style would be a workaround you might consider.

 

  • Like 1

Share this post


Link to post
  • 0
18 minutes ago, Dave Donley said:

Hello Stephane:

I think this problem is specific to using Artistic RW style.  It doesn't happen with Photorealistic RW style.  Using a Photorealistic style would be a workaround you might consider.

 

Thanks for clarifying this, Dave.  So there are more options other than OpenGL.

 

Stephane, You may want to try a non-artistic Renderworks mode and apply Image Effects to the viewport.  This might get the rendering a little more "stylized" than straight Renderworks.  Just a thought.

Share this post


Link to post
  • 0

Speaking of stylizing, if you wanted to make it very stylized you can use Vectorworks Cloud Services.  If you are on a Mac you can copy the viewport rendering, paste as image to Preview on the Mac, save as a file, and then stylize the image with different styles.  Maybe too stylish but that is your option.

 

https://cloud.vectorworks.net/portal/help/pages/stylize-images-machine-learning/?app=WEB

 

  • Like 1

Share this post


Link to post
  • 0

Have done the test in realistic RW style and indeed, the shadows are now cast correctly. 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...