Jump to content
SLFY

Exported / PDF image blank

Recommended Posts

Has anyone had an issue with being able to export an image in VW2020? - up to date with service packs.  

In 2020 the exported image, and the image in a published PDF page were blank - no error messages, or anything out of the ordinary. It generates the rendered image on screen as expected.

 

This may still be some setting or something that I haven't figured out, but I restarted VW, I restarted the computer. I checked for an object in front of the image, layer and class visibility settings. I opened a different file with a model and I can export images of it fine. I couldn't figure it out. 

 

I finally saved the file back to 2019, and was able to open it in 2019 and export the same image / publish the image, with no changes other than a viewport update - no problems. 

 

The file with the issue is different only in that much of the rendered image is actually image props. The model is just a simple sculpture base. the sculpture itself and background are all image props. 

 

I found my work around. I just thought I would see if it is likely just something with my file, or if it is more common. 

Thanks,

Sean

Share this post


Link to post

I've just received a report of this from a user. They haven't specified what content/objects are on the Sheet Layers they're publishing but I'll see if I can shed any light on this. 

Share this post


Link to post

I've found no reason to suspect an issue with the software nor any particular installation of Vectorworks so is most likely a function of settings used. The following two threads likely hold the key for all users getting this result: 

 

 

Share this post


Link to post

Just to clarify...I am not able to EXPORT an image, nor publish a rendered image. The image is rendered correctly in a viewport in a page layout. This has happened to me in two different files now. I am not saying it is a vectorworks issue in general. It may be something in the files or something on my end. It has only cropped up recently. This is why I asked if I was the only one having the issue.

But it is happening on a Windows 10 Desktop with an AMD processor, as well as a Windows 10 laptop with Intel core i7 processor. I have tried color, black and white, different PDF writers, and, again, simply exporting the image.

And. again, I can export the file to a VW 2019 version, open it in that, render the image and export or publish with no issues and no other changes...no scale changes, nothing. 

So if someone else has these issues, maybe it is a vectorworks thing. Until that happens, I have to assume it is me or my setup, and I have the work around. I don't generate images all that often, so it isn't a huge deal - just an annoyance. 

 

But thanks for following up. 

Sean

 

 

Screen capture  of a Published PDF in the PDF program: And note, the image shows blank in Vectorworks as it publishes the pdf, then reappears after the pdf is created. It isn't a viewer issue. 

image.thumb.png.324f0a9bb8ddbe47ecc461f18fd04778.png

Screen capture of the sheet layer with the rendered image. 

image.thumb.png.97b644c88a7d317e747b190dc52fdd77.png

Share this post


Link to post

Thanks for clarifying @SLFY, this sounds familiar. What Service Pack is your Vectorworks 2020 on? The current Service Pack is SP3.1. There was an issue in earlier Service Packs where if JPEG was set as the 'Default Compression' file type in Vectorworks Preferences, Renderworks mode renders would turn out solid white. 

 

See here: 

 

Share this post


Link to post

Thanks for continuing to look into this. I keep updated on service packs generally - on 2020 sp 3.1 build 537701

You had me excited regarding the compression type - but the default compression is still PNG. Not something I have ever changed, but thought maybe I did on accident somehow. I also gave exporting the image as a PNG rather than a JPG a shot, since I wasn't sure I had tried that...but it still comes out as a blank file. 

 

Thanks again, 

Sean

Share this post


Link to post

Sean, I just reexamined your earlier post. It is strange that two seperate computers have the same problem. Have you shared your User Data and Preferences Folder between them? 

Share this post


Link to post

Thanks Jeremy. That helps. I will keep the reset in my back pocket. Right now I am in yet another file with a model that is rendering, publishing and exporting normally. It is very strange. 

Thanks again, 

Sean

Share this post


Link to post

Sorry Missed the second post. I do keep workspaces and plug-ins synced between the two computers. I don't remember what else gets sync'd but I have most of the other settings, etc. set to be ignored by the sync program - but who knows. There could easily be enough there to be why they both have the same issue. I just wish I knew what caused the issue in some files but not all. 

So far it has affected two files but not the most recent. If it becomes more prolific I will do the reset. 

 

Thanks again for following up.

Sean

Share this post


Link to post

I'm sorry to say Sean, I have again overlooked an aspect of your situation: This occurs in some files but not others. Given this I'd say the Resetting Vectorworks Preferences process is much less likely to be helpful. I've just diagnosed a corrupt file for a user where a specific texture was causing a few visual oddities when rendering in Final Quality Renderworks in the Design Layer only.

 

Are there any [applied] textures that are exclusive to all the files that exhibit this issue? It seems a little odd that a corrupt texture would affect the visibility of an entire Viewport, but it's worth checking. 

 

It may be anything else common to these trouble files, or the files themselves, especially if they are all derived from a file that has issues. 

Share this post


Link to post

Grasping at straws. Chased another problem today that was caused by objects in the drawing located very far (170 km) from the drawing origin.

 

Any chance that either your main drawing, or even a small piece is located very far from the origin?

 

From your Design Layer(s) Select All and then do a View:Zoom:Fit to Objects.  If everything disappears, it is possible that VW had to zoom very far out to make everything fit on the screen. Try and drag a marquee near each corner of the drawing and see if anything shows as selected. If so, zoom in and if you don't need it delete it or move it to the drawing origin.

 

Or maybe it has nothing to do with this at all.

 

Good Luck.

Share this post


Link to post

Thanks Guys. I appreciate the continued diagnosis. 

 

Common textures - There are likely a dozen, maybe 2 dozen, in the files that are common, of course, because they are both from the same template. But of those I can only think of one that I use a bunch - a "porcelain" texture I often use for a floor when I am rendering a furniture piece - and is what I applied to floor in the file you checked out for me. But, I don't think I had used that texture for anything in the first file that had issues, and I DID use that texture in the most recent file that is working fine.

 

But you have me thinking...the most recent file that does not have any issue is for a different client, and a new file setup. I can't remember, but I may not have used a common template file to start. Hmmm....

 

Thanks Pat - but as for the objects at a distance...well I won't say there isn't. I often find that I assumed there was a glitch and a tool didn't work, and so reused the tool, only to find out later that it had placed my object way off my screen. But both files have issues with viewports on sheet layers, setup through cameras, which render fine on the screen. Any regeneration issues would not, I DON'T THINK?, affect my image export. I usually export using a marque selection, setting the px/inch number to the resolution I have set for the sheet the viewport lives on, paying attention the the pixel count numbers next to my cursor as I select what I want to export, and entering that number into the corresponding pixel dimension input box of the export window, and save. As long as I put in the correct pixel number or smaller, from my selection box, it always exports immediately without regenerating anything. Done it a thousand times. (I do wish VW would automatically enter the same pixel dimension numbers from my selection box - it always shows a significantly lower number regardless of when I change the px/inch number. But that is a different post.)

 

But I get what you are saying. I just about had a coronary last week, as I am relearning AutoCAD after 15 years of seeing the light with VW. My published AutoCAD drawings were showing up blank...hours of futzing around...until I realized that when I had brought in a block onto the paper space, it came with a bit of text I didn't see, which went a mile away when I scaled the part i was after. AutoCAD, in its infinite wisdom, did not try to just print the sheet I had so painstakingly set up in the paper space, it was trying to print everything in that paper space. The scale of 1:1 I set meant I was getting a paper sized bit of the nothing midway between my sheet and that bit of text.  

 

I will look into this more as I go back into these files, and I may try to purge my template file for the client with the issues, and start the next job from scratch or close to it.

If I learn anything I will post it. 

 

Thanks again, 

Sean

 

 

Share this post


Link to post

Ok - I just went back to the new file, and now it won't export my image either. Not sure why it worked before. But I am back to a reset...maybe over the weekend.

 

Thanks again,

Sean 

Share this post


Link to post

VW2020 SP3.1

 

Having a similar issue. Unable to export image at all. Thumbnail is black... just an empty file.

 

A very basic render, only 3 textures and 11 parts lol

Share this post


Link to post

Hey @Sittingducks, care to post your file for examination? If so, please include definitive steps you used to produce the exported image. Eg: 

  1. In Design Layer 'Cabinet,' in perspective view, render mode, 'OpenGL,' 
  2. Go: File > Export > Image File…

Share this post


Link to post

Just an update, 

I finally got around to resetting vectorworks preferences. This appears to have done the trick. 

 

On note: The reset procedures don't remind you that by deleting the user / appdata folder, you will be deleting any custom plug-ins and workspace you have created that live in that folder.  I did back those up, and once the program was opened and recreated these folders, I was able to move my custom stuff back into its appropriate places with no ill effects. Years ago I had a corrupt workspace file...I'm grateful I didn't need to recreate that this time. 

 

Thanks a ton for the help Jeremy,

Sean

 

Share this post


Link to post

You're welcome @SLFY. Glad to have helped. 

 

The Resetting Vectorworks Preferences page does include at the top, "To maintain a copy of your preferences, follow THESE INSTRUCTIONS" but I do concede, no mention of broader customisations. I'll request it be refined. 

Share this post


Link to post

I am having a similar issue here. I have a large scale drawing, I try to export a section of it using a smaller page size. The export then comes up totally blank. When I export from the sent size, then create a new file, and resize the PDF, the same thing happens. It seems to be in the page size function? This happens still after I Rest Preferences, whether I use Current View, All Pages, etc.

 

Formerly I could take a 36x44 drawing, make my page size say 8.5x11, export or print what part of the sheet I laid it under and go from there.  Somehow that isn't working any more....

Share this post


Link to post

Check for an option that says Current View Only. Then zoom in on the part of the drawing you want to print. Or reduce the size of your drawing window is you want it at a typical scale.

 

I think this is the Print dialog box, the Export PDF options and the Publish options.

Share this post


Link to post

I have the same problem. Image is black when I export Image File as jpg, png, or tiff.  works fine to PDF.   What am I doing wrong here?  worked for years until I updated to VW2021

Share this post


Link to post

FYI, Spoke to someone in Tech Support and solved the problem.  He suggested I enable "Unified View" under the "View" menu.  That fixed the problem.  Now when I export to JPG, I get an actual image instead of all black. 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...