Jump to content
  • 1
Andrew Davies

VWX 2020 - Bug - Saving dimension settings

Question

  • New file
  • Document settings>Units.  Select the units you want (I chose mm, show unit length, comma for thousand separators and square meters for area
  • Save settings as a new set (top left)
  • Settings are saved and units show ok.
  • Open a new file (or even stay in same file)
  • Go back to Document settings>Units and select the previous settings set
  • Units are set back to feet and inches (in my case)

 

I also got this very odd display - see attached. 5 feet and 1mm?

 

Really - what is going on?  Was this software tested before release?

 

 

 

Screenshot 2019-09-10 at 21.09.21.png

Share this post


Link to post

10 answers to this question

Recommended Posts

  • 0

After making the changes you want to set you need to save a Default Template file and then select that as the base for your new files when you create a new file.  

 

The Template file doesn't need to be named Default.  It can be named anything of your choosing.  The important thing is that you set it in the pop-up list when you create a new file so that it is the one that is used.

Share this post


Link to post
  • 0

That’s new for 2020. I am sure that hasn’t been the case before for saving dimension styles. 

 

Any idea on the 5 feet, 1 mm dimension?

Edited by Andrew Davies

Share this post


Link to post
  • 0

Andrew, I've just tested your workflow above and I am able to reproduce it. I will file a bug report immediately.

 

Of course, the workaround described by Mike is to create a template that already has the unit settings you desire, and start your new documents from this file. This is the method I have always used, so I'm afraid this was not caught in my personal testing. But we will get it to the engineers today.

  • Like 2

Share this post


Link to post
  • 0
3 minutes ago, Tamsin Slatter said:

Andrew, I've just tested your workflow above and I am able to reproduce it. I will file a bug report immediately.

 

Of course, the workaround described by Mike is to create a template that already has the unit settings you desire, and start your new documents from this file. This is the method I have always used, so I'm afraid this was not caught in my personal testing. But we will get it to the engineers today.

Thanks Tamsin

Share this post


Link to post
  • 0

It is not a bug.  It is working as designed (WAD).   Dimensions are not a global preference.  They are a file preference.

 

When you set Dimension preferences you are only doing it for the active file.  If you want those preferences to become a default for your work you can only do it by saving those settings as part of a Template file.  To 'recall' them you then need to use that template file as the 'base' for the new file you are creating.

 

Or you can create a unique 'Dimension Style' and then import that.  Easier to incorporate it as part of your 'template file'.

Share this post


Link to post
  • 0
13 minutes ago, mike m oz said:

It is not a bug.  It is working as designed (WAD).   Dimensions are not a global preference.  They are a file preference.

 

When you set Dimension preferences you are only doing it for the active file.  If you want those preferences to become a default for your work you can only do it by saving those settings as part of a Template file.  To 'recall' them you then need to use that template file as the 'base' for the new file you are creating.

 

Or you can create a unique 'Dimension Style' and then import that.  Easier to incorporate it as part of your 'template file'.

Hi Mike

The bug is what happens when you recall a set of saved units (in metric) in a file that was previously imperial. The resulting dimensions, units and rulers are displayed with the feet unit marker. (e.g. 3'4mm instead of 34mm).

Of course, the workaround is simply to save your desired unit settings in a template, so that you don't need to recall saved unit settings. Start each project from your own template and you won't have the problem.

Share this post


Link to post
  • 0

Tamsin, the weird unit expression is definitely a bug.  The non appearance of the set units in a new file is not a bug though.

 

Some users assume that units are a global preference.  ie all they have to do is choose Imperial or metric.  Unfortunately it isn't.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×