Jump to content
A.D.K.

Default 3D Legend View

Recommended Posts

Hello Dear Geniuses,

 

Is there a way to designate a default 3D Legend View, either made active/selected like the default Label Legend, or associated with said active Label Legends?

 

Thanks!

  • Like 1

Share this post


Link to post

First, in the edit label legend menu make sure that you tick the fields that you want active in your 3D label in the use 3D column (red)

 

if you want to set the 3D layout for the fields in relation to the fixture use the drop down menu highlighted in blue, choose none and then use the edit 3D layout option in the label legend manager to set up the layout.

 

Otherwise the legend will use a default layout, depending on which option you choose.

 

label legend 1.JPGlegend 2.JPGlegend 3.JPG

 

After assigning your legend to the fixture make sure that in the object info pane you have selected a 3D Legend view, otherwise it will not be visible (I normally use screen aligned). Lastly you may need to use the 'refresh labels' command in the OIP if you change views.

 

 

 

Share this post


Link to post

3d Legends are applied like Jesse says above, however I cannot see a way to make sure all of your fixtures display a 3d legend view to front or right by default. I have tried editing the light info record defaults through the spotlight preferences menu but it seems to be locked out.

 

I tend to put a default fixture on a position with al of these options pre set, then I duplicate that fixture and replace with symbol as appropriate, this saves having to select multiple instruments and selecting 3d view.

 

Unless anyone can find a way of pre-setting this I will make a feature request via Jira.

 

Thanks

 

Tom

Share this post


Link to post

Thanks Jesse and Tom.

 

I had managed to figure out what you outlined above, Jesse.  Tom has articulated my problem exactly.

 

Tom: I've actually updated our template/reference files to include this.  We've got an insertable symbol with all our fixtures (so our classes survive purges with less clicking), and I've added the 3d Legend View settings for copy/pasting as you suggested.  It would still be nice to be able to associate it with a symbol, so I'm off to feature requests.

 

Thanks again!

  • Like 1

Share this post


Link to post
Posted (edited)

This is possible, but requires you to make a new record format.

 

If you make one with the criteria filled in thus:

 

1719297043_Screenshot2019-06-25at13_31_24.thumb.jpg.6a952b3b0d8466647e02c17bedb367a1.jpg

 

Attach that to your lighting instrument symbol/s. You can edit the criteria for each symbol if you like.

 

Then go to Spotlight preferences and open Additional Default Records

 

Attach your 3D label legend record.

 

1567418364_Screenshot2019-06-25at13_33_40.thumb.jpg.1db2bcb2307fdfcb60e12e9a75915427.jpg

 

Then save and close your file. You may need to restart VWX as well.

Then, when you insert the Instrument with the new record attached you will see the specified label legend and all the other criteria preset and ready to go.

 

 

Edited by markdd

Share this post


Link to post

Thanks Mark, this is great.

 

If I omit the first line, it will default to active, correct?

 

Also what does the "set 3D orientation step do?

 

Thanks.

Share this post


Link to post

Thanks Mark,

 

This is great, I might also try to add it as a feature in the label legend manager dialogue.

Share this post


Link to post

If you omit the first line, then yes, I would expect so.

 

The "Set 3D orientation" step just toggles the check mark in the OIP.

 

The Additional records function of the Spotlight Preferences is much overlooked but is invaluable for just this kind of thing.

 

It's worth saying that you should never edit the Light Info record as it will cause all sorts of annoyance down the line.

 

Share this post


Link to post

Appreciate the help.  This is exactly what I was looking for.  Thank you!

Share this post


Link to post

Cheers Mark

That's an approach I hadn't considered.

Share this post


Link to post

@markdd So this is all working beautifully, except I have the 3D Labels showing up in top/plan view.  They're not present when I go to edit the 2d elements of a fixture; in the 3D layout manager for the Label Legend, all elements are set to 3D plane (not "screen"); it only appears on fixtures that are oriented vertically according to my screen (even if they're exact copies of fixtures that are rotated a little off axis, which don't have the ghost 3D labels visible in 2D plan).  It feels like buggy behaviour to me, but I thought I'd check.  Any insight?  Thanks.

Share this post


Link to post

If you go back to the Label Legend manager, and then Edit Fields. Make sure that there is a check mark beside the correct field in the 2D column. They will probably be right down the bottom.

 

Then you should see the correct text items ready and waiting to be positioned when you click Edit Layout.

 

Hope that works for you

 

Mark

Share this post


Link to post

I do have that.  The 2D Legend is no problem, it's just that the 3D Legend shows up in 2D, so I have double legends.  I think it's a bug, given when/how it appears.  Thanks anyway!

Share this post


Link to post

Yes, there has been some strange behaviour when fooling around with the new 2D/3D label legends. Is it an older drawing from a previous version?

 

If you can bear it, try making the new Label Legend from scratch. Maybe even in a clean file. It should work. I don't think it is in any way related to the extra parts record youve added though. However, I could be wrong.

 

If you fancy posting the Label Legend and extra parts record here, I could take a look.

  • Like 1

Share this post


Link to post

Hi Mark,

 

Of course now I've been fussing with it, it's behaving.  I have a "goodLabel" screenshot waiting, and will add "badLabel" and ping you here with resources attached if/when it acts up again.

 

Thanks again!

Share this post


Link to post

@markdd it did it again, so I have an example.  Attached is a snip of two fixtures that have the same Legend and 3D legend view (screen aligned) applied.  Note only the one oriented vertically shows the 3D label in this 2D Top/Plan view; this is typical.

 

Also attached is the 3D layout for the Label Legend in question, and what I would assume are the relevant bits of the OIP for the highlighted element.

 

For now I've made the class in question invisible on all viewports so at least it won't print, but that's a tedious manual workaround obviously, especially with the number of files we're handling.

 

Any insight would be appreciated.  It's feeling more and more like gremlins.

 

Thanks!

badLegendgoodLegend.JPG

badLegend1.JPG

badLegend2.JPG

Share this post


Link to post

Can you atttach the label legend in a clean file and I'll take a look

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...