Jump to content
Sign in to follow this  
mjm

Shadows on backlit objects - big problem (or - it's just me)

Recommended Posts

So, in earlier versions of VW, I could create a cyclorama texture, backlight it just as I do in my day job and then throw a gobo or image onto it from behind. It seems to me this is actually no longer quite possible. The "backlit" shader allows a projector (aka spotlight fixture) to cast a beam of light onto the Cyc from behind, but, when the fixture has a gobo in it, only the full beam of light is projected, no gobo.

Problem.

I prefer verisimilitude, and that's why I create renderings in the first place, so as to show clients something tangible, something I can say -"This I can do for you".

If I've missed something, I'd be grateful for the pointer/s.

I've attached links to two renders showing the difference between front projecting onto cyc and the same fixture, same gobo, etc from the rear and one img showing the shader settings...

[img:left]https://secure.flickr.com/photos/mazzm/6762147335/in/photostream[/img]

https://secure.flickr.com/photos/mazzm/6762147087/in/photostream/

https://secure.flickr.com/photos/mazzm/6762180265/in/photostream

Edited by mjm

Share this post


Link to post
Have you tried turning off Cast Shadows on your texture?

Tamsin - thank you for getting back to me, and yes, I did try that with no joy.

Share this post


Link to post

I wonder if anyone else is seeing this type of problem. If it's just me or symptomatic of a greater issue.

michael

Share this post


Link to post

HERE'S a test file to quickly and clearly demonstrate the problem: two fixtures, one on either side of a "cyc".Both are on in the drawing, turn one off to see the problem in detail.

michael

Share this post


Link to post

Hi mjm:

I am seeing the same thing now, it looks like the gobo texture is working on the backside but that the backlit shader is not using the masked shadow on the front side. I will ask Maxon about it, there might be some adjustment we need to do or the backlit shader may be limited here.

Share this post


Link to post

Thanks for continuing to look into this Dave. Of course, what's somewhat ironic about this is my need for verisimilitude in creating a fake shadow. I hope there's an adjustment which can be made. This (patterns on a cyc from the rear) is a standard tool in the LD's arsenal and I use it regularly.

Edited by mjm

Share this post


Link to post

Hallo,

I explored your File with C4D, and the good news are:

Yes they can!

But it has to be done by Nemetschek, there is a Option in the Backlight Shader

called Shadow Intensity that on default is on 60%.

If we get this Option also inside of VW, we can set it 100% and the result

is as extpected. In the current Version this Option is not available.

See C4D Screenshots attached. (Sorry for the German :-))

Besides That:

I like the Way Goboes are Exported from VW to C4D.

Nice little Gobo-Plate in Front of the Lightsource. Like in life. wunderbar simple!

Horst M.

Share this post


Link to post

Aha, thank you so much for the tech support Horst. We will change it so that the backlit shader uses 100% shadow intensity. I don't know yet which version will have this fix.

Share this post


Link to post

Hallo Dave,

Coming to monadnoc's question:

If you change the Shadow intensity (or make it available ;-), it would eventually be good to give us Control over the intensity of the Backlight effect by setting the brightness to control the brightness inside the shader. The one on top seems to have no effect.

This makes sense, if we use the Backlight-shader to illuminate the Scene by using Global Illumination aka VW Indirect Lighting.

The Value seems to be kind of multiplied with the brightness of the Light source.

Attached on image from a Test-file for a texture of satianted Plexi backlit from

a Circle Fluorescent Light.

Horst M.

Edited by Horst M.

Share this post


Link to post

Horst - thanks for the C4D research to confirm and isolate the problem, and Dave for the promised fix - can't wait.

Monadnoc - yes, and it did not make matters better, just less contrast overall.

Share this post


Link to post
This is fixed for the next service pack of 2012, thanks again for the info and the solution!

Great news Dave, thank you and Horst & the VW / Maxon team.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...