Jump to content
  • 0

Printing Error- "pictwpstops"



We just added a new computer to our small network, and are having problems printing.

Mac 1.25 ghz duel processor, 1GB ram, OS 10.2.5

Xante Acelawriter 3N laser printer

HP 488 CA plotter

When trying to print to the Xante laser printer from Vectorworks 10.1.0, we get the following error message visible in the Print Center Application:

?pictwpstops got an error disposing of document ?43?

This problem only occurs in Vectorworks, other programs have no problems printing to this printer. I can save Vectorworks documents as PDFs either through the built in Mac quartz features or Adobe Acrobat and then print them, but I can not print to the laser printer directly from Vectorworks.

The same problem occurred with OS 10.2.4; I upgraded in the hope of solving the problem.

The other 2 computers on our Ethernet network running Vectorworks 10.1.0 and Mac OS 10.2.5 have no problems printing to this laser printer from Vectorworks.

Any suggestions to solve the problem?

Thanks for any help.

Link to comment

23 answers to this question

Recommended Posts

  • 0


What driver are you using? How did you install it? Have you tried (in the print center) to remove the offending printer from the printer list and then add it back? When you add(ed) your printer to the printer list, did you make sure that you were selecting the printer from the correct pull-down list (eg: AppleTalk, IP Printing, etc.)? After adding your printer to the list did you restart your machine (I know you're supposed to have to do this, but it sometimes cures mysterious little things!)

That's all I can think of. Hope it helps!


Link to comment
  • 0

This is a known HP/OS compatibility problem when files were worked on in versions of the OS prior to OS 10.2.4 with this printer enabled.

Please see this link on HP's website:


If this solution doesn't work for you, please email me and I can send you a printer settings scrubber which will clear print settings in a VW file.


[ 04-28-2003, 10:55 AM: Message edited by: Katie ]

Link to comment
  • 0

see my earlier post on this issue:http://techboard.nemetschek.net/ubb/ultimatebb.php?ubb=get_topic;f=22;t=000103

i am still having this issue, with no resolution at this point other that a time consuming workaround (the print settins scrubber that katie mentions) the corrupted font issues have not shown up in our files and we dont use the custom presets that the hp page talks about.


do you know if this is this going to somewhere along the line by NNA, HP or Apple? I am about to toss my plotter over this!

Link to comment
  • 0

I didn't know that people were having this problem. I should check the boards more frequently. This problem-- exact same error message-- popped up for us when Jaguar came out. Some of our machines had it and some didn't. We had the problem from most Carbon applications we tried (I can't recall if it was every)-- but no Cocoa applications. We primarily use VW and AppleWorks-- so it was very frustrating. From AW we were able to "Preview" the document and then print. Since Preview.app is a Cocoa application this worked fine. We could do the same from VW but the output was not quite as good as printing directly.

We tried just about everything as far as troubleshooting goes (including complete wipes and reinstalls and gimp-print) to try to get things to work. After posting on Apple's discussion boards, these boards, and the linuxprinting boards, as well as calling Apple, we finally figured it out on our own.

One some machines one of our postscript fonts was corrupted. It didn't show up as such in any diagnostic tool. In our case it was AGaramond. Unfortunately we had been keeping our purchased fonts in a single compressed file on our server to make deployment easier when we rebuilt a machine or set up a new one. Turns out that the AGaramond in that Archive was corrupted.

So, we would wipe a machine, reinstall everything, and then reinstall the fonts and we would still have the problem-- yet the adjacent CAD station would be happily printing/plotting with apparently the same exact setup. Since the font was in (but not embedded in) an eps with our logo it was doubly difficult to diagnose. Many of our machines had not gotten AGaramond from that archive but had had it back from OS9 days.

Once we figured it out the fix was easy. We removed the font family from each affected machine and reinstalled it from the original compressed file we had received from Adobe. That fixed the problem and it has never come up again.

Part of the problem that Apple faces is that they license the CUPS system-- it is not their product. In our case the same computers had worked fine under 10.1.x. The same font could be printed in 10.2 without problem from a Cocoa application. It seems that CUPS is just less forgiving that the previous printing architecture of certain anomalies or ways that the data is sent to it.

I can see that there has been a great deal of discussion and troubleshooting on this issue. It may be possible, or even likely, that this error code results from several different problems and we were lucky that it was just a font in our case. But we are absolutely certain that in our case it was a bad font. It could not have been HP drivers (since none were installed). It could not have been saved printer settings (since a wiped computer does not retain those). It also could not have been a VW file that had been worked on it a previous version. BTW, we never install any of the HP, Canon, or Epson printer drivers when we install Jaguar. It wastes space and we only have postscript devices in the office.

We print/plot to an HP 1055CM, an Apple LW 8500, an Apple LW 12/640 PS, and a Tektronix Phaser 850DX. It made no difference which printer we printed to if it was from an affected machine.

As far as troubleshooting goes I would recommend methodically replacing fonts. I would start by completely removing any and all postscript or OpenType fonts. Keep in mind that OSX has several places where fonts are normally stored.

I hope this helps.

Link to comment
  • 0


THe problem was with certain printers having problematic drivers (built into the OS) under OS 10.2.3.

If these files were accessed or created wtih template files worked on under OS 10.2.3 - you'll have this printing problem.

Cleaning the printing history - with the cleaner thingy - will fix that file.

If stored settings are used period, on any OS X version, you'll run into this problem sooner or later.

Once the file is cleaned, it should be clean. Unless of course, stored settings are used and then file then saved.

There was alot of advertisement on MacFixit and Apple's website stating issues with certain printer manuf. and the OS 10.2.3 and was recommened to revert to OS 10.2.2 until a new version was released. Those that never saw that tidbit have several files affected.

THe problem isn't exclusive to VW, however most applications being used probably won't create files large enough to run into this problem.

If you email me, I will send the fix to you.


Link to comment
  • 0


At this point, about 4 months in, we have tried everything to no avail. I am going to reinstall in the OS on one machine and see if that fixes the problem. I have noticed that if we print from a machine that has been restarted, the problem goes away for a while. I am not sure why, and not sure what causes it to return, but will post what i find.

Link to comment
  • 0

I finally found time to implement ?asrsloat?s? suggestion.

It turned out a font I had loaded on our new machine was indeed corrupted. I deleted and reinstalled the font and everything works perfectly!

Many thanks to ?asrsloat? in particular and everyone else for your tremendously helpful contributions to this message board! You have saved me a great deal of time.

Link to comment
  • 0

Well you guys seem to have gotten it quicker than HP and NNA combined - there seems to have been one font that was corrupted and so far so good, no more errors. i am going to do some test runs on another machine this weekend and see if it fixes it there als0 - kudos to all!!

Link to comment
  • 0


We discussed corrupted fonts at one point with you. You said it wasn't a corrupted font problem. I believe I mentioned it on the other printing posts as well.

On a side note, there is a program called Font Doctor.

I strongly reccommend this application, it's well worth the money to troubleshoot font related problems.

Even though you may only have a font issue in one application, it can still be a font issue, not an application issue.

Most font problems are caused by duplicate fonts in a variety of folders, being placed in "illegal" folders, font suitcase not having the matching PS or bitmap font, or the font file is simply corrupted.

ALl of the above can cause a variety of problems when printing - especially when using a snon-standard OS font which requires the printer to download teh font -- frm your computer. If the font is bad or corrupted or not complete, the printer can't download the valid information to print.

THe reason you may have a font problem in VW and not other applications, can be one of many. The most common reason is due to the way certain applications send files to the printer. Often times, applications will send an image of the file to the printer- bypassing the need for the printer to download a font for printing purposes - since the text is actually part of the image.

You'd see the same thing if you exported to an image file and then printed from VW. Fonts that might not have printed correctly before are printing like magic when using the image file.

Font Doctor

YOu can download this at versiontracker.com. It's free for a trial period. It can scan all the fonts on the computer then give you a report of the bad fonts and what's wrong with them.

I usually have users send in a suitcase of fonts that are having display and/or printingp roblems. I run it thru that utility and find the suitcase is missing a matching bitmap or PS font or the font is corrupted.

Font suitcase fonts are a whole other beast when it comes to fonts. Most font suitcaes are only fully supported by cocoa applications. VW and many others remain carbonized to keep the users who wish to remain with OS 9. Font Suitcases have to be perfect to work with carbonized applictions. Even then, it's not guaranteed these fonts will work. Generally they include post script fonts and or bitmap fonts. If you are missing one or the other component of the font, prints can appear with bunched text, dropped text, scrabbled text with odd characters and probably more that I haven't run into yet.

On the screen, you may not be able to set these fonts as a default font, they may create a text block twice as big as the font size on the screen with the text writing higher than it actually gets placed when the text block is closed.

Anther thing I've seen happen more than I can count. People move their OS 9 fonts to OS 10 font folders thinking they will work. They usually do not work under OS 10. This can lead to many of the above mentioned printing and display issues.

There's a reason why more and more carbonized applications are issueing statements about fonts and only True Type fonts are supported with those applications.

So there's my 3 cents on fonts. Sooner or later I am going ot get around to writing a white paper about fonts and OS 10 and how to get over the problems caused by unstable fonts and font suitcases.

[ 05-16-2003, 10:32 AM: Message edited by: Katie ]

Link to comment
  • 0


Originally posted by Katie:

We discussed corrupted fonts at one point with you. You said it wasn't a corrupted font problem. I believe I mentioned it on the other printing posts as well.

Now, now Katie... no point in trying to defend yourself...

Seriously though, the Nemetschek NA folks do a great job on these boards and they certainly work hard to address problems (like this one) that are really unrelated to VW itself. Other applications, notably AppleWorks, generate the same error when trying to print a specific corrupt font. This is really something that our friends at The Cupertino Fruit Co. should be addressing.

BTW, Font Doctor may be able to help some people-- but when we were having this problem back in September it was unable to find the corrupt font. It is possible that they have improved the product somewhat.

Link to comment
  • 0

FYI: It was Katie who originally suggested a corrupted font issue to me way back when I switched to OSX and was having problems printing a particular file. Lets all pat ourselves on the back that we can figure this stuff out. There are two things I have found out that create printing errors. the corrupted font issue and using fill patterns other than the first row in the pallet. They were real frustrating at first. Either not printing at all or cryptic error messages. And most people are really frustrated when it works on a cheap desktop printer but not on the plotter. OSX and plotters appear to be more sensitive to these kind of issues. Now I know what to look for.

The first thing I do is try to print/ plot the file one layer at a time to see if some layers plot and others don't. Once you isolated the problem layer or layers then you can look more closely at what is in that layer. Then you must ungroup the objects in that layer (best to make a copy of the problem file first). The reason for this is custom selection will not pick up individual objects if they are in a group with others. First do a select all then look at the font menu and under fonts it will put a dash next to all the fonts it finds. Any non basic fonts are suspect. Switch one or all to geneva and then try to print. If it works then you found it or them. Isolate and reinstall from the originals. Do not just try to drag them over from another machine. Or if you do not have the originals (pirated copies), drag them onto your desktop first, over the network, from machine that have no problems, then put them in the font folder in your system folder. I put all non true type fonts in the OS9 font folder not OSX. If this doesn't find any thing, then I look for patterns. I custom select patterns rows at a time until it finds one or more patterns. You know when you got one when the fill box shows a pattern. Also it helps when you do a select all to click the show all button at the bottom of the window. This is important because objects can be beyond the limits of the screen and cause problems. This is especially true when new draftspeople leave all sorts of stuff out there in the file. A little 1/2" x 1/2" filled box, way out in space, or one letter in a text block, can cause the file not to print. Good hunting!

Link to comment
  • 0

I'm contemplating buying a used HP488CA for my mac (Power mac G4 867 Mhz with Mac 0S 10.2.6 and a NVDA , GeForce4MX card). The asking price is $800. This seemed quite reasonable until I saw some of the problems posted in the discussions. it looks like some of this is related to font issues. Right now I'm printing to PDFs files and sending out to a plotting service. This works fine but I'd like to be able to print in house. My question is simple:

Is this a plotter that is complatible with Vectorworks 9.5.3b1?

I don't think its going to be used for more than a couple plots a day with occasional sets of 10-20 pages printed monthly.

Any advice is greatly appreciated.

Link to comment
  • 0

The 488 is a good machine but you will be using gimprint or xrip from microspot to drive it. HP does not support this machine in OSX. Gimprint is really not that bad to set up and it is free, with plenty of users on this tech board to help with the setup. You will need the jetdirect printserver too which comes with the mac version (post script) of the plotter but not the pc version. Alternately HP just came out with the designjet 10 plotter for just under $1,000 dollars for the base model, so do not pay too much for the 488. It will handle up to a d size sheet. Looks pretty interesting and since it is new, HP has OSX drivers for it. Although HP's drivers are traditionally problematic on Macs. I have not talked to anybody with the new plotter.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...