Jump to content
  • 0
brianconneally

Importing DWG to Vectorworks - Dimensions Issue

Question

I'm trying to preserve the graphical qualities of the original drawing. When I import the DWG into Vectorworks, the dimensions seem to be drawn in the sheet layer.

So as the sheet layer can only be set to 1:1, the dimensions are changed to the space they measure on the sheet layer. Please see below image for example.

 

I have selected the import dimension as group option - which does import the correct dimension into Vectorworks. However the graphic changes dramatically, dimension lines become massive, and text is out of place.

 

Any and all help is appreciated, thanks!

 

Sorry this has probably been answered a million times already. 

Screen Shot 2020-02-14 at 13.30.44.png

Screen Shot 2020-02-14 at 13.17.57.png

Share this post


Link to post

4 answers to this question

Recommended Posts

  • 0

If you import with different units than the original drawing uses you will end up with a drawing that is off by some scale.

 

You can either import again and set the units to what the original using uses or you can use the Scale command to adjust the already imported drawing.

 

Usual scale differences are 10 (drawing in mm imported as cm or vice versa). 1000 (drawing in mm imported at meters or vice versa) or 25.4 (drawing in mm imported as inches or vice versa).

 

Try drawing a dimension on something that you know the dimension of (maybe a door or window). Or you can use the Modify:Scale Objects:Scale by Distance mode to draw the dimension on the imported drawing and then enter the dimension that it should be.

 

It is always a good idea to import into a blank document and them copy/paste or reference into your drawing so you can get the dimensions correct rathe than contaminate your whole drawing.

Share this post


Link to post
  • 0

Our main tip to users when importing a dwg-file in Vectorworks: DON'T SCALE THE RESULT!!! 🙂 Hatch definitions won't scale and might become ridiculously dense. That will make your graphics card run extra hours.

 

During training sessions we very often have to explain the best way to import a dwg-file.

If there's an issue with a dwg-file, this is not a scale. It is a unit issue.

 

1. Open a blank document with your units.

2. Import the dwg-file as if it was drawn in you units. Do not use the detected units, they will be wrong. AutoCAD users never indicate the unit they use to work.

image.thumb.png.481237ef6eb6c0b589435ccb8fc2ee3c.png

3. In the result, check a dimension or size you know. I.e. if you see a staircase, the stair width will be something like 80cm to 100cm, sometimes 120cm. If it reads '900' units, that means the dwg-user has been thinking in mm. If it reads '0,9', his units were meters. DO NOT TRUST DIMENSION OBJECTS IN A DWG. They may be 'exploded', what makes them just lines an text.

4. If the units in your imported file don't match your settings, THROW AWAY YOUR CURRENT FILE AND OPEN A NEW ONE. Don't just throw away the imported objects sibce the hatch definitions will stay in the file and they are already too dense...

5. Restart the import in a new, empty file. But now use the units as you found them in step 3.

 

Succes!

Share this post


Link to post
  • 0

Thanks for the responses guys, I don't think I properly conveyed my issue in the original post. 

 

There's no issue with the scale or the units in the actual design layers themselves. The drawings themselves are fine.

The situation is that we're trying to make a very small change to an annotation, basically just editing a dimension that is incorrect on a dwg file created by others.

 

The problem is that the dimensions are annotated in the equivalent to the Vectorworks sheet layer. Now Vectorworks sheet layers are always 1:1 (Unless some genius can tell me how to change this). When the file is imported to Vectorworks the dimensions now measure the space at 1:1. 

 

So for example, I import a drawing which is drawn at 1:10. There's a dimension which is 380mm, when I go into the design layer, this is correct.

The actual dimension annotation however is drawn in the screen layer, and measures a space which is now at 1:1. So the annotation displays 38mm in Vectorworks instead of 380mm.

(Which is what is shown in the first screenshot above)

 

Hopefully this clarifies my query.

Share this post


Link to post
  • 0

It sounds like the original DWG is drawn "incorrectly". Normally Dimensions in paperspace would come in as part of the annotation group of a viewport rather than directly to the sheet layer.

 

Maybe try and Cut the dimensions from the sheet layer, Edit the Annotations for the viewport and Paste in Place and see if that "solves" the problem.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...