Jump to content
  • 1

Not all uplights show drapery pleats





I have some drapery in my scene, with lighting devices just above the floor, facing up towards focus points that are just behind the drape. I have 8 lights and 8 focus points, but only 6 of the lights show the pleats on the drapery. I have no idea why lights 3 & 4 (counting from the left) don't show pleats. Perhaps it's a bug, but I'm thinking it's probably some setting I don't know about that got changed by accident. Has anyone have any ideas about what might be causing it? See attached photo.


Thank you,






Link to comment

11 answers to this question

Recommended Posts

  • 0

Hi Tamsin,


the option on all lights are the same. I tried toggling the cast shadows option on one of the bad lights, just for fun, but none was to be had. I've included another view of the two bad lights. The light on the right, for some reason, shows just a tiny bit of pleat detail in the top right corner.


Screen Shot 2020-02-09 at 5.10.05 PM.png

Link to comment
  • 0

This has been rendering in custom renderworks.  OpenGL seems to be the same, but the lights are so faint that they are almost impossible to see in this rendering mode. If I set it to final quality renderworks and output an image file, those two lights look proper in the rendered file, but not in render you see in the editor. 


Edit ** - I just rendered again with final quality renderworks and I am seeing detail in the drape now. Which would be great if I had done something to fix it. Custom quality renderworks still renders those 2 lights incorrectly, but at least I can get my rendering done with final quality renderworks, however, the floor renders as white now instead of showing the layer below that contains an image of the rigging points for the room.... in the rendered image file that is... in the editor it shows as it should. Also it shows in the output file if I choose OpenGL for rendering type.

Edited by Sean@UVS
new info
Link to comment
  • 0
  • Vectorworks, Inc Employee

May seem a random suggestion but...

Is your file's geometry close to the internal origin? Tools > Origin > Locate Internal Origin.

If there is a huge distance between the geometry (5KM) and the internal origin, then this can cause strange problems like this.

Try Tools > Origin > Center Drawing on Internal Origin (you may need to clean up scattered geometry, which can occur if you started with a DWG import).

Nothing in the file, or any referenced files, should be more than 5KM from the internal origin.


Link to comment
  • 0

Yes, the geometry is close to the origin... the furthest away point would probably be a wall and it's about 180' from the origin.


I am starting to wonder if my problems go beyond this version of Vectorworks simply being buggy. Perhaps my install has become corrupted somehow. I say this because of the tremendous amount of problems I've been facing. I am sure that many of them are simply user error, but at the same time this is the 4th or 5th version of Vectorworks I've used and comparative to previous versions, this one seems just riddled with bugs. A few random examples... 


1. Objects disappear from view as I zoom in and out of the drawing. (see attached video)

2. Seemingly random objects change to a partially transparent fill when some adjustment is made to the drawing (move an object, turn a light on, change a symbols setting (ie: truss length), change view angle). (See attached before and after picture) To get them to show normally, I have to save or switch to another open Vectorworks file, then back again.

3. Parts of the image just randomly render wrong. ie: instead of rendering an object with it's proper color, it renders it flat green (like the default floor color in a Vectorworks scene) or parts of objects get moved. (see attached picture of drape rendering green and parts of truss getting moved out of position. These errors occurred when changing the brightness of my misbehaving lights. At one point, the light would only turn on at 650%...  a brightness setting 649% for example, caused it to render as if the light was off... and it messed up the truss)


So basically I spend far more time trying to work around bugs than actually get any work done. Aside from the fact that it was quite a bit slower, my 2015 copy of Vectorworks functioned much, much better. I would just revert, but stepping back to a version that is 5 years old seems wrong and we just paid thousands of dollars for VW2020.


I am going to be diligent today about screen capturing any errors and making notes about what I was doing when they occurred. Is there a particular forum thread I should post my findings in?


Thank you,




2 - vectorworksError_beforeAndAfter.png

3 - vectorworksError_brightnessAdjutment.png

Link to comment
  • 0

@Sean@UVS One quick thought, in your Custom Renderworks settings, what is the "Curved Geometry" setting set to? If it is low, try changing it to high. I suggest this as it was working with final quality renderworks and not custom. The other thing I do when this happens, is open a brand new file, copy your drape line to it and paste it in place. Then delete the drape line from your original file, then copy and paste it in place from the new file back into the original file. I've had that fix weird bugs where it wasn't updating all of the geometry when rendering.

Link to comment
  • 0

@Tanner Shelton My curved geometry setting was on low and changing it to high made the detail show up on the drape. Awesome! Thank you. I tried your copy and pasting trick, but it didn't seem to help in my case. 


@Rob Books I took a look at the settings, but didn't see anything that seem out of whack to me... I'm running a 2019 MacBook Pro with a 2.4 GHz Intel Core i9, 32 GB 2400 MHz DDR4, Radeon Pro Vega 20 4 GB, Intel UHD Graphics 630 1536 MB. Any settings that I particularly need to worry about on this machine?



Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...