Jump to content
  • 0
MTRobin

Greyed out layers don't display in viewports

Question

Hi Everyone,

 

After speaking with VWX tech support we determined that it is intentional to have 3D objects disappear when their class or layer is greyed out in a viewport and rendered in OpenGL or Hidden Line. I would like to request that this not be the case and instead they become grey.

 

Let's say I have truss on a "truss" layer and lighting on a "lighting" layer. I have a viewport rendered in hidden line and in a front view. The lights are hung below the truss and I would like to grey out the truss on this page. On the next page I would like to grey out the fixtures. These are separate details for the person hanging the lights vs someone hanging the truss.

 

I know I can make 2 instances of everything and have one using a black line and the other using a grey line, but that will mess up my counting worksheets and will make the file much larger, not to mention it is annoying.

 

I have attached an image of what I am referring to.

 

Thank you

 

Maxwell

 

Greyed classes.pdf

Edited by MTRobin

Share this post


Link to post

7 answers to this question

Recommended Posts

  • 0

I don't believe you got the right information from Tech Support. I just created a drawing with objects in greyed classes and layers. Both on a design layer and in a viewport the object still show in OpenGL.

 

What does not show is the edges of the objects. Coupled with the very light grey that is used it can make it hard to see the objects.

 

An additional option to show edges on Greyed layers and classes would be a very good addition.

Share this post


Link to post
  • 0

Hi Pat,

 

Attached is a VWX file with 2 cubes. Each is on their own class. You'll see when you update the viewport that the greyed out one disappears. These are renedered in hidden line. When in wireframe they seem to work, but I need it to work in hidden line.

 

Thanks

 

Maxwell

Grey Class.vwx

Share this post


Link to post
  • 0

Hi @MTRobin,

 

If you're using sheet layer viewports, have you tried using class overrides to set the trusses gray in one viewport and the fixtures gray in another? This would be a far more flexible approach since you can set the exact color you want for each class.

Share this post


Link to post
  • 0

So, I think that this wish should be clarified to read Support for Gray class and layer visibility option in Hidden Line and OpenGL rendering.

Share this post


Link to post
  • 0

I am able to use the class attribute overrides, but what I am looking to do is have certain classes print greyed out on certain pages and then normal on others. It seems silly to me that there is an option to have the class visible, grey, or off and 2 of those options just turns it off. I have found that the grey option works in wireframe, but when you publish it to PDF it still prints as black.

Share this post


Link to post
  • 0
2 hours ago, MTRobin said:

I have found that the grey option works in wireframe, but when you publish it to PDF it still prints as black.

Have you tried adjusting the setting to adjust the level of "grayness" when you publish?:

 

image.thumb.png.f2010f3a5dee3e258a33214fe6e6c4a6.png

 

Share this post


Link to post
  • 0

Yes that was the issue for Wireframe, but I am still seeing the issue where they disappear in Hidden Line and OpenGL.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×