Jump to content
Cris with no H

Planar objects showing in RW modes

Recommended Posts

I have a file that I've rendered side by side in 2018 and 2019.  In 2018, the planar objects disappear as I expect them too.  In 2019 - directly opened from the 2018 file, the planar objects pop back into existence at the end of the render.  

 

Is 2019 supposed to do this?

Share this post


Link to post

Yes! Beginning with version 2019, Renderworks modes show all planar objects and point clouds, with the exception of Artistic RW and RW styles with edges.

  • Love 1

Share this post


Link to post

Cris - do you already have the "Display Planar Objects" button unchecked in the Viewport's OIP? I'm assuming you're rendering in viewports....

 

If this is unchecked and planar objects are still rendering (which has happened to me once in 2019), then it sounds like a bug.

Share this post


Link to post

This is not a viewport.  This does not make me very happy, @Selin.  This should at least be a preference.

Edited by Cris Dopher

Share this post


Link to post

The planar objects always disappearing in renders was indeed a bug. If your workflow had included this as a part of it, your easiest option is to render in a viewport so that you can control it's visibility. Rendering in a viewport is better for a number of reasons, this included.

Share this post


Link to post
Just now, Jim Wilson said:

The planar objects always disappearing in renders was indeed a bug. 

Yep, it was a limitation of the CineRender engine. Sorry to hear that it was part of your workflow.

Share this post


Link to post

I don't need (or want) that either.

And now I know I have to better care about it.

Should work as I have my few 2D Elements on separate Classes.

 

But I am very happy for all the Students on the german VW Forum,

as they always tried to render their 2D PDFs under their 3D geometry.

 

I see 2D is not effected by Shadows and GI (?)

Share this post


Link to post
Just now, zoomer said:

I see 2D is not effected by Shadows and GI (?)

Nope. 2D geometry is rendered with OpenGL and won't affect the RW renderings in any way.

Share this post


Link to post

However this is quite a nice Effect to add some fancy details by adding a bunch of Lines here and there ...

 

Screenshot-98.thumb.jpg.041b11169bb360ec1f95be2e725a79de.jpg

Edited by zoomer

Share this post


Link to post

If only VW could accept that "open" Polylines could never have Fills ....

 

Screenshot-99.thumb.jpg.094386e5d499ec35e02d0962c47c97ab.jpg

Share this post


Link to post

rendering in a viewport might be better, but it doesn't contribute to efficiency.  On the design layer, I can continue to make changes as Renderworks plugs away and it will restart the render when a resource is changed.  It is just quicker on DLs.

 

However, I've found a workaround, thanks to Selin's first comment:  I set up a RW Style that this time includes edges, just set to 0 pixels.  Voila.

Share this post


Link to post
34 minutes ago, Cris Dopher said:

However, I've found a workaround, thanks to Selin's first comment:  I set up a RW Style that this time includes edges, just set to 0 pixels.  Voila.

Hahah I like this workaround 😄 much quicker than setting classes.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×