Jump to content
  • 0




Here's a screen shot of a viewport set to foreground hidden line render.

Can someone please inform me as to how I can get rid of the thicker lines or otherwise reduce their thickness?

Or is this just the way it is?


Share this post

Link to post

4 answers to this question

Recommended Posts

  • 0

The line thickness in Hidden Line render mode is pulled from the actual 3D objects on the Design Layers. If there are any hybrid symbols, the lineweight is pulled from the 3D side of the symbol. I've run into very similar issues as you where all the different lineweights make a Hidden Line elevation look not great. (And you often don't want to change all of the objects' lineweights because they're important for the Plan representation).


Unfortunately I don't know of any way of dealing with this outside of manually changing the 3D objects' lineweights, or using a complicated system of viewport Class Overrides.


I think it'd be a GREAT wishlist item to have the functionality with Hidden Line to suppress ALL lines to a chosen lineweight, easily solving issues like the one you posted. You could always then add back in some thicker outlines where desired by tracing in the viewport's Annotations.

Share this post

Link to post
  • 0


Thanks Andy. 

I thought the fat lines were probably related to my wall line weights and that probably is the issue but why would they be so scattered and inconsistent?

I think I will post a wish but sheesh!

VectorWorksAround.  Good old convert to lines....all one trillion of them.

Share this post

Link to post
  • 0
6 minutes ago, bc said:

but why would they be so scattered and inconsistent?


The thing that's a bit mystifying is whenever two solids intersect - which lineweight does Vectorworks choose to use for the resulting line? That of object A or object B?


For example if you look at your dormer window, it looks like some of the lines took on the lineweight of the dormer's walls, while some took on the lineweight of the window or of the roof object. This is what leads to the scattered, unintentional look.


8 minutes ago, bc said:

Good old convert to lines....all one trillion of them.


I coincidentally just employed this workaround minutes ago for a project. It's very manual, but at least reliable :) 


(Also, if you're getting way too many lines, check that the 3D conversion resolution under VW preferences isn't set to Very High. This particularly affects curved objects).

Share this post

Link to post
  • 0

Thanks I'll give it a go.

I do get multiple lines instances and several lines end-to-end where there should only be one.

I just now overrode my wall,roof,door and window classes in the viewport and that averaged the line weights. 

It's just a bit dispiriting.

Share this post

Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • 7150 Riverwood Drive
  • Columbia, Maryland 21046, USA
  • Contact Us | 410.290.5114


  • © 2018 Vectorworks, Inc. All rights reserved.
  • Vectorworks, Inc. is part of the Nemetschek Group.
  • ×