Jump to content
Stephan Moenninghoff

Info Palette not playing well with Marionette 2018

Recommended Posts

I have been chasing a nasty bug that will stop the OIP from updating after a short time working with Marionettes in VWX 2018. Unfortunately, I cannot pin it down to any specific action which is ever so slightly annoying because it stops me from filing a usable bug...

If anyone is able to reproduce this, any help is appreciated. What is happening is that the OIP will continue to show the info of the previous selected object or node until I go to Top/Plan view. Then, even when I continue to work in Top/Plan view, it will require me to press cmd-5 frequently to refresh the OIP. I don't know when or by what action this starts to happen but it always does (macOS). Is anyone else seeing this?

Share this post

Link to post

Confirmed, I had the same Issue here. Which Build do you use?


At the moment I can't reproduce. I used 387649 and I had this issue after every change of Marionette PIO Option in the Palette. After Rescale Info-Palette it was OK until the next object active and changing something, I ignored it and got to bed... iMac 27" Sierra at Home.


Now I tried again with Build 390873 Mac Sierra in the office it looks fine now :-)


Share this post

Link to post

Just downloaded and installed 395475. Still the same issue. What drives me crazy is that I cannot reproduce this. It just starts to happen after about 5 minutes working with my current file. That's a different file than when I first reported this. It's even a different computer. Oh, the mysteries of software....

Share this post

Link to post

It might not be directly a Marionette issue, but just out of curiosity, which nodes exist in both files? (that are being run)


Also, are you using Undo at all?


I've run into this a couple of times, but like you haven't been able to find the exact reproducible case so I can't report it yet.

Share this post

Link to post

I have it at the moment (Got to work on a presentation and that really stops me now :/) I am working with marionette nodes. Now I have the following symptom:


1. Objekt-Info of every PIO in every File do not work correctly anymore

2. After restarting Vectorworks it works again for a while

3. I have it reproducible if I create a menu command of  a Wrapper. 

4. After that, the Info-Palette is completely numb I have to restart Vectorworks -on a Mac :-)


Maybe it's because I work in a Beta-Build of German Version based on SP1 ...

I reported this as a bug with a vwx and a movie file ...


Share this post

Link to post

Maybe I am sick on Monday :-))



Seems to be related to Preferences.

Edited by DomC

Share this post

Link to post

Hi there,


I have the same problem. I found out when ever you select a Node and press cmd+s it refreshes and works for one click. It is just a work around that forces you to save your project after every change in Marionette. 


I also have discovered that when you press undo that it jumps way back and I can't undo the undo. Has anyone the same issue? (only in Marionette)

Share this post

Link to post

Hey Guys, I still have this issue in the latest release. Does anyone know what the problem is and when it will be fixed?


Best regards,



Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114


© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

  • Create New...