Jump to content
Sign in to follow this  
cad@sggsa

VW12 Crashing with FWS Rendering??

Recommended Posts

Good day All

I seriously had enough, but the boss wont upgrade.

This project I'm busy with keeps crashing VW when I do the "final" render.

I say "Final" cause it is Fast with Shadows, but with a whole bunch of lights with Lit Fog on, hanging from trussing and some tables and it being the most my PC can handle. Looking at like almost a 2hr rendertime.

Now, I have recently upgraded the look of my 10 and 12-seater tables to have more than just the table and chairs and I think this is the culprit, but do not understand why it would Crash the program and leave you with that Windows msg (Send/Don't Send Report). I can understand if VW stops Rendering and pops up the Out of Memory Box.

It runs Geometry and Shadows, but when Rendering stage starts it closes the program.

Any Advice will be appreciated

Thank You.

Share this post


Link to post

Hello Carl:

From memory (12 is awhile ago, it is also becoming confusing with people calling version 2011 "11") it sounds like Lightworks may be crashing since you are in the Render stage rather than Geometry. FQRW mode uses NURBS, you may try using Custom RW with NURBS turned off so that the geometry is generated all on the VW side. Look for any opportunity to reduce the geometry detail in your symbols, etc.

On Windows, a 32-bit application like VW is limited to about 1.5 GB of free RAM, no matter what your physical RAM limit is. You may try enabling the "\3GB switch" to give VW another 1 GB of free RAM to work with. This may help.

Here is the link to the \3GB switch info:

http://kbase.vectorworks.net/questions/663/Windows+3GB+Switch

Also, some RAM is being used for the shadows, you may try using ray-traced shadows to save more RAM, although they won't have soft edges.

Edited by Dave Donley

Share this post


Link to post

Hi Dave

Thanks for the quick responce

I know all about the 3GB swith and ray-tracing etc.

BUT

I'm not even doing that level of rendering, my system won't cope with a Custom Renderworks Render if it can't even do a Fast with Shadows Render, which I trying to do when it crashes.

Maybe if I mention what I added to the tables it will lead us in the right direction.

I created 3 sizes of plates. a dinner, side and Centre Table plate. Thus there is one of the big one and 12 of the other each.

I created a circle, extruded it, then subtracted the top/centre and bottem outer parts to resemble a plate. I also trimmed the edges.

I created a Napkin from Nurbes Curves, extruded it and trimmed the edges. this lays across the dinner plate and has an oval extrution as a band around it. There are 12 of them and 14 tables.

Here is a pic of it:

http://i168.photobucket.com/albums/u171/CAPTIANZ/table-settingsqA.jpg

Edited by cad@sggsa

Share this post


Link to post

If you did not already, rely heavily on symbols. Change every repeating object into a symbol.

Each type of plate, a napkin, a napkin ring, a place mat, a chair, a table leg, a table cloth, etc. When convenient, convert a few symbols into nested symbols:

4 legs +table top + table cloth + ctr plate = table symbol

Dinner plate + side plate + napkin + napkin band + place mat = place setting

Arrange 12 instances of the place settings, 12 chair symbol instances and a table symbol, and nest them into a new symbol. Then place as many instances as needed of these units in your dining area.

This kind of strategy will reduce geometry and render requirements.

-B

Share this post


Link to post

Thanks Ben

I do have everything in symbols, but not as deeply nested as you speak of. Also I do not have a table as such, the drape of the table is the table. every other object is a symbol though.

Still No one can tell me why VW crashes instead off just to stop the rendering.

Do I have a corrupt file or symbol maybe?

Share this post


Link to post

Did you try a render with 3/4 of the lights off? then half? etc

Does Open GL render without crash?

Another troubleshoot is to save & close your file then dupe it, and do the following with the dupe:

Open the dupe, and open a new blank file.

Cut half (or a big portion of) the objects from Dupe and Paste them into New.

Render New. If OK, Render Dupe.

If New crashes, Make New2 & Cut/Paste half from New to New2, then render.

Even if Dupe Renders OK, Cut/Paste another half & re-render.

Repeat until render fails or all objects & resources transferred . . .

This could identify a corrupt object or texture or other resource (often from old VW or import from some other software) or a system problem ( maybe RAM if the halves render OK? Defrag? Restart?).

Are those chairs complex with nubby textures or PIO intelligence? It might be worth converting one to group, making a nest symbol of the components, then replacing all the smart chairs with instances of the new dumb one.

Best of luck!

-B

Share this post


Link to post

Hi Ben

As mentioned before I am only rendering 14 tables, which is half of what is actually in the drawing and normally do not have this problem with dubble the amount.

The chair is not complex and have never had a problem with them in years.

What is Dupe?

All the components are new except for the chairs and Source4 bodies out of my libraries. They render in other drawings.

I am busy re-rendering a copy in a new file containing only what is in the plan making the dwg file half the size. So should see if it works in like 2hrs.

Open GL does work.

I have attached the one camera view that did render

Also the view I want next without the tables.

Thanks for the advice so far.

Share this post


Link to post

As I suggested before, try Custom RW with NURBS turned off, and use raytraced shadows. Task Manager can help you see whether the app is running out of memory (likely).

Edited by Dave Donley

Share this post


Link to post

OK, so I think I figured out what the cause of this is, but do not understand why it would do so.

See attached: Wire frame renders

The 1st plate is what I had. 12 dinner and 12 side plate plus 1 large centre plate per table.

The plate has 4 edges filleted and my guess is, that is where the problem lies.

The 2nd plate is what I recreated as you can not edit a filleted object the same way as you can with extrudes.

It has no fillet, just the solid subtraction.

When it renders it is much more smoother and when viewing the table in a 3d view it loads almost instantly, unlike the 1st plate where it took awhile to generate each table.

Is this a problem for VW to render all these filleted areas?

If so Why?

Will do Render later and see how it copes... ;)

Share this post


Link to post

Oh, sorry about the abbreviation:

Dupe = Duplicate

Plates - just a thought:

Might be help converting to NURBS. Make a master plate with fillets, solid subtractions etc, then convert a copy of it to NURBS, then symbol, then place symbol instances.

-B

Share this post


Link to post

OK

So I did the CRW renders...

Interresting to note they go much quicker than FWS.

I used the plate setting with the plates not filleted and did it in 10min. :grin:

But now I took the Napkin and did as Ben told me. Convert to NURBS and make a Symbol of that. Placed that in the plate setting symbol which is in the table symbol.

It does not want to render. well it tried, but stops the command with no after msg and gives you a white saved image. :tired:

Seems I will have to recreate that nurbs curve...pfft :sigh:

Settings for Render is medium detail, med sampling, no nurbs, ray traced+transparent shadows set at 64 recursion and anti-aliasing.

Edit:

Just did a render with Nurbs selected. It worked and took 16min. See Pres2d

Edited by cad@sggsa

Share this post


Link to post

Hi I'm using Vectorwoks 2011 Educational student version and the program is running very slow.I cannot work properly.I have enought spce on my computer i don't know how to solve the problem?I have windows 7

Thank you

Share this post


Link to post

Hi Diana

Can you tell me your exact machine specification?

You can get this from Control Panel>System. I need to know how much RAM it has and how fast is the processor. I also need to know if Windows is 32 bit or 64 bit.

Also, is it running slow performing any specific task? i.e. Rendering?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...