Jump to content
  • 0

Top/Plan view staying when switching to 3D



I'm having an issue in VW 2024 when I'm in Top/Plan view and switch to any 3D view, the Top/Plan does not go away. I recently switched from 2023 to 2024 and wasn't having issues the other day with this, even on 2024. I've tried restarting VW and I've also restarted my machine. I've attached some pictures of what it looks like when trying to switch to Top/Plan to either Walkthrough, Flyover, or any perspective views. Any help is appreciated.


Thank you.

Screenshot 2023-12-06 095936.png

Screenshot 2023-12-06 095954.png

Screenshot 2023-12-06 100020.png

Screenshot 2023-12-06 100258.png

Link to comment

8 answers to this question

Recommended Posts

  • 0
3 hours ago, Pat Stanford said:

Check the Document Preferences:Legacy 2D pane. and make sure that Turn Off Unified View is not checked. If it is, then each Design Layer has its own view settings. With Unified View turned on, when you change the view of one layer then all the active layers (at least ones with the same scale) change views at the same time.




That did it! Thank you so much Pat. Not sure how that setting got changed but thank you!

Link to comment
  • 0

Try and create a new file (from your template is you have one). Check and make sure it is not turned off in the new file. If it is you need to create a new template file. You can just change the Unified View in a new file opened from your template and resave it as a template.  Or if it is old (several versions or more) you might want to recreate it from scratch.

Link to comment
  • 0
  • Vectorworks, Inc Employee
On 12/6/2023 at 6:44 PM, michaelk said:

I'm seeing this issue as well.


It gets triggered when using a script to navigate from a sheet layer to a design layer or when editing a viewport and choosing to edit the design layer.


Sometimes that causes Unified View to get turned off.

@michaelk thanks for pointing this out and bringing this up!  We've been trying to find a reproducible case that causes this, would it be possible for you to DM me a file and the steps required to get Unified View to automatically turn off? Thanks and any help is very much appreciated!

Link to comment
  • 0

I have attached a really simple file to show how this works.  In the file, there are two design layers, one with a rectangle and one with a cube, and a sheet layer.  There is a simple, one line script that sets one of the design layers as your active layer.  If you run this script from a sheet layer, Unified View is now disengaged but won't show up in the Legacy 2D tab of the Document Settings.  To re-enable Unified View, you have to Enable legacy 2D features and then disable them.  Poof, Unified View is back on.


Or you can add SetPref(94,TRUE) to any script that activates a layer and hope that your user isn't deliberately disengaging Unified View.

Unified View Bug.vwx

  • Like 1
Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...