Jump to content
  • Vectorworks 2022 crashing in DirectX 11 on some Windows systems


    Some Vectorworks 2022 Windows users have reported crashing with basic document window operations such as resizing the application window, tearing off palettes, or switching workspaces.
    We have tracked these issues to utility apps being installed which modify the functionality of DirectX 11. These apps sometimes show overlaid graphics on top of normal graphics, or otherwise inject code into the basic graphics handling routines of DirectX 11. Graphics-intensive applications like Vectorworks and others can be negatively impacted by these apps, when normal graphics operations behave incorrectly. We recommend not using such apps at the same time as Vectorworks.
    Sometimes these apps automatically start up with the system. Clearing them requires changing the Startup Apps settings as follows:
    Type “Startup Apps” in the search field of your Windows Taskbar.
    Disable items a few at a time, and restart Vectorworks to see if Vectorworks is operating normally or still crashing.
    If Vectorworks is still crashing, re-enable the items you disabled and move further down the list.
    When Vectorworks operates normally you have found the problematic startup item(s).
    Apps known to cause problems:
    Dell Command Center
    Dell Support Assist
    Alienware Command Center

    Sonic Studio Suite
    Clearing these items from Startup Apps should restore normal Vectorworks operation.
    Some DLLs used by these apps are known to be problematic. Apps that use the following DLLs should not be run at the same time as Vectorworks. The file path shown when searching for these DLLs can denote which program files should be avoided, for example “C:\Program Files\NZXT CAM\...\ graphics-hook64.dll”.

      Report Article

    User Feedback

    Disabling suspect Startup apps did not prevent Vectorworks 2022 SP0 from crashing, but…


    Uninstalling Alienware Control Center Suite resolved my crashes. Disabling it in the 'Startup' column in Task Manager didn't stop it from launching on startup and it would restart even after using 'End Task' in Task Manager, so I uninstalled it. 


    I can confirm the streaming and screen recording app, 'OBS' also includes the .dll, 'graphics-hook64.dll,' but I've not had any issues with Vectorworks 2022 SP0 while this app is running and recording. 

    • Like 3
    Link to comment

    I have had many issues with the undo command as well and I think it may have been related to MSI Afterburner and RivaTuner.  I have uninstalled them and my undo issues appear to have gone away. 

    • Like 1
    Link to comment

    Uninstalling the Alienware Control Center Suite did in fact work to end the crashes when trying to resize windows within VW2022. Anyone got an idea as to why?

    Link to comment

    Is there an update to this with any other known apps or DLLs that cause 2022 crashes?  I found one of them in the OBS Studio (uninstalled) as well as in EGVA Precision X1 (also uninstalled). I have searched my entire system for all of the listed DLLs again, finding none now, but it is as crashing.  Any update would be greatly appreciated.

    • Like 1
    Link to comment
    Guest Benno Wendt


    We found that behavior with ASUS Sonic Studio 3 - no more Problems without that.

    Link to comment
    On 12/3/2021 at 3:09 PM, BelieveLDT said:

    Is there an update to this with any other known apps or DLLs that cause 2022 crashes?  I found one of them in the OBS Studio (uninstalled) as well as in EGVA Precision X1 (also uninstalled). I have searched my entire system for all of the listed DLLs again, finding none now, but it is as crashing.  Any update would be greatly appreciated.

    I'm encountering the same thing. I found PXSHW10_x64.dll in EVGA PrecisionX 16 and uninstalled it. I ran another search for all the .dll files on the list and couldn't find any. Unfortunately, it did not stop the crashes. Switching between two documents more than once will cause a crash 100% of the time. 


    If anyone else found any culpable files or has any other input, it'd be greatly appreciated if you shared them. This error is incredibly annoying.

    • Like 1
    Link to comment
    2 hours ago, Daniel M71 said:

    Vectorworks Worst software I've ever had,all icons are gone!!!

    Vectorworks 2022 crashing non stop!


    Hi @Daniel M71


    Given the severity of your symptoms I'm not surprised you say that! Conversely, the fact that they are unique and severe suggests they will be caused by conditions specific to your computer. Conditions which can be usually be improved. 


    Because you haven't included any information about your operating system, hardware or circumstances the following is based on a few assumptions, so they may not apply to your situation. Please add your current hardware, operating system and pertinent software to your profile signature or include it in your comments and posts. 


    Shooting from the hip; That your Attributes palette is at the top of the tool palettes suggests you may have migrated from a very old version of Vectorworks. In which case probably also migrated a Workspace or Settings file that is corrupt or incompatible and causing these issues. The solution for this would be to retire your current User Folder. But… Here are some serious suggestions, in order of likelihood and necessity.


    Seeing as the issues include graphics-related symptoms: 

    • Ensure your graphics card driver is up-to-date. - However; If the newest driver available for your graphics card is older than six months you may need to upgrade to a modern graphics card. (Old drivers don't support modern graphics conventions). 
    • If updating the graphics card driver doesn't resolve the matter; Perform a clean reinstallation of your graphics card driver, using the latest release.
    • If you have both an internal and an external graphics card; Ensure your dedicated graphics card is 'assigned' for Vectorworks to use


    Because Vectorworks 2022 is crashing so much: 

    • Ensure your operating system is supported. Looks like you're using Windows 10 or Windows 11. Both should be fine, so: 
    • Ensure your operating system is up-to-date. 
    • Have you ruled out the software conflicts listed in this thread? 
    • If you migrated data from a previous version of Vectorworks, rule out potentially corrupt files in your User Folder by putting it aside and allowing Vectorworks 2022 to generate a new, default one. (For more info on the User Folder and its location read section Vectorworks preferences: User Folders pane, in Vectorworks Help. 


    Because the tool icons are missing: 

    • If you didn't disable antivirus during installation, there is some chance it may have prevented certain software components being installed. The most sound remedy is to uninstall Vectorworks (using the dedicated 'Uninstall' app in the Vectorworks Program Files folder), then reinstall with antivirus turned off. 
    Link to comment

    Hi Jeremy

    This is my Computer specification:

    ·       CPU AMD Ryzen 9 3950X

    ·       GPU NVIDIA RTX A5000

    ·       Motherboard ASUSTeK PRO. X570-ACE

    ·       RAM Corsair CMW 128GX4M4E3200C16 DDR4 

    ·       Storaqe Corsair Force Series MP600

    ·       Edition  Windows 10 Pro

    ·       NZXTcam blocked permission


    I have NOT had any problems with:

    ·       Vectorworks with Interiorcad 2021

    ·       Polyboard Software

    ·       Inventor and  Woodwork for Inventor

    ·       Revit

    ·       Fusion 360

    ·       Sketchup 2020/21


    However, I am having trouble with:

    ·       Vectorworks with Interiorcad 2022

    The graphic card +  the processor have nothing to do - they are relaxing. The program is not able to exploit the potential In contrast to Twinmotion UE4 and D5 Render.


    Link to comment
    On 2/4/2022 at 11:57 PM, Daniel M71 said:

    I have NOT had any problems with:

    Not having issues with other software or prior versions of Vectorworks does not preclude the possible causes I mentioned above. My Windows laptop had no issue with Vectorworks 2021 + Interiorcad, but suffered the issues in this thread with Vectorworks 2022 (without Interiorcad installed). So I suggest you start with (in order of least-imposition to most: 

    1. Remove your 2022 User Folder with Vectorworks closed, then reopen and test. (Location: %AppData%\Nemetschek\Vectorworks). 
    2. Try a clean installation of your graphics card driver. 
    3. Rule out possible software conflicts by:
      1. Making sure no other programs are open at the same time (just while verifying). 
      2. Investigate Services marked as "Running" (in Task Manager) and see if uninstalling them makes a difference. ⚠️ Only stop or remove services you believe to be aftermarket software. Most services are functions of your operating system so be mindful as you do this. You can right-click on any and choose 'Search Online' to help you identify what is what. 
    4. I've not encountered that card being used with Vectorworks before, so perhaps there is an exclusive issue with its drivers and Vectorworks 2022, - but I've never encountered such a thing before so I doubt it. If you get this far down the list you should be consulting the Vectorworks Tech Support provider for your region. They'll escalate to Vectorworks engineers if warranted. 
    Link to comment
    • Vectorworks, Inc Employee
    On 2/8/2022 at 10:16 PM, Jeremy Best said:

    Try a clean installation of your graphics card driver. 

    @Daniel M71 Have Vectorworks Tech Support been able to help you resolve this issue?  Do make sure you get the driver directly from NVIDIA, in the past we have seen problems with vender versions of graphic drivers like Microsoft, Dell, PNY, etc. it's better to get them straight from the manufacturer if possible.


    • Like 1
    Link to comment

    Vectorworks 2022 crashing issue solved today after uninstall Alienware Command Centre Suite.

    Thanks Jeremy, haha, you are the best.

    • Like 1
    Link to comment

    My biggest issue was Graphics card driver update and settings and an apparently corrupted file.  I'm not sure we solved the actual problem but it was with a site model and once it was recreated from site date and new site modifiers were applied it worked fine.  But second thanks Jeremy....and too many others to list.

    Link to comment

    Getting a DirectX 11 crash a lot with 2022 and it tells me the suspect DLL is related to NahimicOSD (which is on the bad list, but when I search for my start up apps - there is nothing like this on the list, so where to find this and clear it out?

    Link to comment

    Well this is just ridiculous.  No previous version of Vectorworks has had an issue with Dell and Alienware support services, and frankly I am not going to uninstall core features of a laptop I've purchased to be able to run a piece of software that should operate perfectly fine alongside them.


    Just installed 2022 finally, and frankly it's unusable.  At this point I may as well uninstall 2022, reinstall 2021, cancel my VSS license, and just stick with 2021.


    I'd like to think a fix was coming, but considering that we are apparently already on SP3 it seems pretty bloody unlikely.

    • Like 2
    Link to comment

    Alienware users - the information at this link:


    has so far worked for me on an alienware M15 R5 Ryzen edition.  I can now change workspaces and resize my windows and I am not getting the DLL crash.  Remains to be seen if I run in to issues elsewhere, but so far so good.


    Essentially you need to add the VW executable to a blacklist of programs for the Nihimic audio tools.

    • Like 1
    • Love 1
    Link to comment

    Thank you for that valuable insight @Anthony Neary. A modified version of the instructions you have linked to worked for me. I've been able to reinstall Alienware Command Center and Vectorworks 2022 now allows me to adjust docked palettes without crashing or the applicable warning coming up (added in Service Pack 3). 


    I'll post verbose instructions below for those who require more specific guidance. 

    • Like 1
    Link to comment

    The following information will probably resolve this problem on any Dell or Alienware branded computers, or any others that employ NahimicOSD: 


    In Summary: Add 'vectorworks2022.exe' to one or more 'exception list' files titled, 'BlackApps.dat.' This will prevent NahimicOSD or similar apps from being used with Vectorworks. This solution works only because the makers of the conflicting software included this 'exception list' facility in their software.


    Important Advice: Other programs that use these or other DLLs will not be helped by this process. In such cases uninstalling those programs may be the only solution for now, but it is possible they have their own, different way to add programs like Vectorworks to an 'exception list.' Search the software name and the terms, 'exception list,' 'whitelist,' etc to look into this. 



    1. Users of Vectorworks 2022 SP3 or later will likely have been presented a warning that cites the exact location of the DLL causing problems. The address will help you locate the 'BlackApps.dat' file you are looking for. Copy the address in that warning minus the file at the end OR Copy the following address to your clipboard: C:\ProgramData\A-Volute
    2. Click on (⊞) / Open the Start Menu and type 'Notepad' into the search bar. 
    3. Right-click on the Notepad app now showing in the Start Menu and choose, 'Run as administrator.'
    4. When asked by the User Account Control window if you want to allow Notepad to make changes to your device, choose 'Yes.' 
    5. When Notepad opens, within the Notepad window, choose 'Open' from the File menu. 
    6. In the bottom right corner there is a dropdown menu. Change the file type from 'Text Documents ('*.txt)' to 'All Files.' 
    7. Paste the address on your clipboard into the address bar at the top of this 'Open' window and hit enter on your keyboard. 
    8. From here things may look different depending on the make and model of your computer, but the idea is to look (or search) within the folders inside until you find the 'BlackApps.dat' file, then open it. 
      • The article linked by @Anthony Neary in his previous comment says it is here: C:\ProgramData\A-Volute\A-Volute.Nahimic\Modules\Scheduled\Configurator\BlackApps.dat

      • Whereas on my computer, a Dell / Alienware m17 R4 laptop, it was in a similar location: C:\ProgramData\A-Volute\DellInc.AlienwareSoundCenter\Modules\ScheduledModules\Configurator\BlackApps.dat

      • Another user's Vectorworks has cited the following DLL in this location: C:\ProgramData\A-Volute\DellInc.AlienwareSoundCenter\Modules\ScheduledModules\x64\NahimicOSD.dll

      • Other makes or models may have other software installed that includes the NahimicOSD frameworks which apparently relate to audio processing on certain computers. Knowing this may help you identify pertinent folders to look inside. 

    9. When the file opens in Notepad, make a new line, then add 'vectorworks2022.exe' (without the quote marks). 

    10. Save and close the file. That's it. 

    • Like 4
    Link to comment
    On 10/28/2021 at 10:00 PM, Jeremy Best said:

    Disabling suspect Startup apps did not prevent Vectorworks 2022 SP0 from crashing, but…


    Uninstalling Alienware Control Center Suite resolved my crashes. Disabling it in the 'Startup' column in Task Manager didn't stop it from launching on startup and it would restart even after using 'End Task' in Task Manager, so I uninstalled it. 


    I can confirm the streaming and screen recording app, 'OBS' also includes the .dll, 'graphics-hook64.dll,' but I've not had any issues with Vectorworks 2022 SP0 while this app is running and recording. 

    How do you uninstall Alienware Control Center Suite and does this affect the alienware computer poorly?

    Link to comment
    8 hours ago, Victoriagoss said:

    How do you uninstall Alienware Control Center Suite and does this affect the alienware computer poorly?


    Users that have this software installed no longer have to uninstall it to stop it interfering with Vectorworks. See my more recent comment (immediately above your comment) which instructs how to add Vectorworks to an 'exception list' so the software concerned stops trying to 'help' Vectorworks graphics or audio processing. 


    If you still want to uninstall Alienware Command Center, this is achieved the same way you uninstall any other program on Windows. Search for then select 'Add or Remove Programs,' click on the software concerned and click, 'Uninstall.' (Just so you know, Vectorworks has its own dedicated 'Uninstall' app inside the Vectorworks program folder). Removing Alienware Command Center will only affect performance if you already use it to adjust the performance of your programs (typically games). If you don't use it for this purpose performance will not be affected but you may loose control of 'Alienware' style features like the keyboard lights etc. I prefer to keep this software intact. 

    Link to comment

    Hello, my VW also keeps closing after just opening it. Sometimes it helps to restart the laptop and I also have most of the apps startups deactivated. But most often this little window pops up that sends me to this website to resolve the crashing. From the above comments I also checked whether I have the Alienware Control Suite which I do not have installed. My laptop is a dell inspiron 7506. 

    I think it has to do with the graphic card(s) on my laptop but I really do not know what to do about it.


    I would appreciate any kind of help!


    Link to comment

    Hi LCK, 


    As they provide crucial context, can you please include in your comment or add to your signature: 

    • The version and service pack of your Vectorworks. E.g. 'Vectorworks 2023 SP0'
    • The spec's and operating system of your computer. (See my signature for example). 


    1. Ensure you're using the latest release of Vectorworks 2023. From the Help menu choose About Vectorworks and click 'Check for Updates.' 
    2. If you're on a laptop with two graphics cards, make sure the dedicated graphics card is assigned for use with Vectorworks
    3. Make sure your graphics card drivers are up to date. 
    Link to comment

    Hi Jeremy,


    the VW version is 2023 64-bit? If that is helpful? The laptop is dell inspiron 7506, 11th Gen Intel(R) Core(TM) i7-1165G7 @ 2.80GHz, 16,0 GB, 64-Bit with Windows 11 Pro. 

    Vectorworks should be up to date and for the graphics cards I tried everything. I tried assigning one card to VW then the other and also letting windows choose but that does not seem to work. I updated the latest intel drivers for the graphics cards but I think that only made my laptop crash. So I reset that update again. A few days ago I even rebooted windows because it got to a point where I could not open VW for even a few minutes. The rebooting helped but now it seems to be acting up again.


    Thank you!

    Link to comment

    Hi @LCK


    Sorry for the delayed reply. Thanks for the info. Because this discussion is such a long read what you've said in your last comment made me wonder if you've got as far down as the solution I posted six comments above here. Have you used those instructions to see if they apply to your situation? If you have, I suggest you contact the technical support provider for your region to get hands-on and tailored assistance. 

    Link to comment

    Hi @Jeremy Best,


    Thanks for your reply! I had tried before what you had suggested in the previous comment, but that did not seem to apply to my situation. But good news is that at the moment everything seems to be working fine. So, I can use vectorworks again without it crashing every five minutes. Fingers crossed it stays like that!


    Thank you for your help!

    Link to comment

    Join the conversation

    You can post now and register later. If you have an account, sign in now to post with your account.
    Note: Your post will require moderator approval before it will be visible.

    Add a comment...

    ×   Pasted as rich text.   Restore formatting

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...