Jump to content
  • 0
fuberator

bug: worksheet editor sticks to screen

Question

Mac os 10.15.4 | VW 2020 sp3.1

 

Sometimes when I am working with worksheets in my documents I can not close the worksheet editor.

 

This image is from having worked in and closed 2 separate documents, each of them having got stuck once. I can still move the windows out of the way, and after a restart of VW they are gone. But there is no closing them.

 

850382158_Screenshot2020-05-11at16_45_36.thumb.png.9d16b087e2974ecca5590e90bf413af1.png

Share this post


Link to post

12 answers to this question

Recommended Posts

  • 0

This is not at all usual behavior. If a restart does not fix the problem, you should consider delving deeper before the problem gets worse.

 

If you are using a custom workspace, try one of the stock workspaces.

 

If this is only in a single file, send that file to VW Tech Support for them to review and possibly fix.

 

If it is in multiple files you will want to do more troubleshooting. I would do the following testing in between to see if it solves the problem.

1.  Create a new User on your Mac and test there. If the problem exists it is a VW installation problem. If not, it is probably your user folder.

2.  Drag your VW User folder (or rename) out of Application Support and Restart VW. A new folder will be created. If the problem still exists it is a VW installation problem. If not, it is a problem in the user folder.

3.  If it is a problem in the user folder and you don't need any of the stuff from the previous folder, just proceed. If you need the stufff (templates, workspaces, etc.) then drag them back one folder at a time and test (restart) between.

Share this post


Link to post
  • 0

Add on to my answer above.  Another possibility is that some kind of dialog box has gotten opened and then sent the the background and hidden. Until the dialog box is closed you can't close the worksheet window.

Share this post


Link to post
  • 0

Hi

 

I will try to figure out the sequence of events, in the meantime I work around it

 

thank you

Share this post


Link to post
  • 0

Hi

 

I have tried extensively to track this down. I suspect it happens if I "edit report" in a worksheet that was initially "placed on drawing". When I close the editing of the report I see the pointer turning into a crosshair briefly, which is the behaviour for the initial placing on the drawing,

 

It's a really a bummer. I use a lot of worksheets and when I edit them I am left with the dead windows taking up screen space and forcing me to regularly restart VW.

 

 

Share this post


Link to post
  • 0

Try Resetting your Always Do options.

 

Vectorworks Preferences:Session Tab: Saved Settings Button: "Always do the selected action" choices.

 

Perhaps there is a dialog that has been hidden that you need to see. You will have to see all of the dialogs again until you check the Always Do options for them, but this can be good as it will remind you that there are options.

 

 

image.thumb.png.4ac6cf17517b37c41d900815edf82993.png

image.png

Share this post


Link to post
  • 0

Very strange. I have confirmed it does it here on my machine also. Please click the Bug Submit link at the bottom of the screen and file a bug on this.

 

I am actually very surprised that no one caught this much earlier. What Service Pack are you running? Just trying to figure out if this just crept in with the latest update.

Share this post


Link to post
  • 0

HI I am running sp3, I had my hopes up when sp3 came, but it's something deeper. 

 

If you experience this too, maybe you are more qualified to report the bug in a constructive way?

 

ps. to close the about box I clicked ok exactly 6 times before it "took"

396400349_Screenshot2020-06-16at18_30_24.thumb.png.b2b8aa6705f9362a68982090001e67c5.png

 

 

Edited by fuberator

Share this post


Link to post
  • 0

Based on trying to work out a bug report, it appears that this is directly related to the Place Worksheet on Drawing option. If you don't check that but rather go to the Resource Manager and place the worksheet on the drawing manually, you can Edit Report without a problem.

 

At least a reasonable work around until they implement a fix.

Share this post


Link to post
  • 0

Or actually when the worksheet editor opens after you close the Report Builder, you can just choose the "Worksheet on Drawing" option from the Worksheet File menu. No need to go to the Resource Manager unless you close the editor before you put it on the drawing.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...