Jump to content
  • 0
rexwexford

help please. Not snapping regardless of settings

Question

Hello all

 

We are encountering an issue in the office whereby some files do not snap to 90/180 degrees etc regardless of the snap settings. 

I have uploaded a video to explain the problem. 


-If I open a blank file, it shows that the cursor will snap to the 90 degree intervals as you would expect 
-If I open a second file (the problematic one) and don't change any settings, it now wont snap

-If i then return to the original file, It wont snap until I close vectorworks and start again

 

Its very difficult to work with . Has anyone else experienced it? Its happened on several files, not just the one in the video

 

any help is appreciated 

 

Using vectorworks 2018 

 

regards

 

Share this post


Link to post

16 answers to this question

Recommended Posts

  • 0

Go down to your snap buttons, and double click on one. This will bring up the SmartCursor Settings.

Go down to Angle, and then tick "Angles from Axes" and make sure you have the 45° 30° etc. in that box... should be fine then, Let us know how you get along

 

image.thumb.png.1a54d7134558984f8070378b316431a7.png

  • Like 1

Share this post


Link to post
  • 0

Hi Russ, 
1939279475_Screenshot2019-03-12at15_12_51.thumb.png.d3ea70d0c8583fde86ffd317ae936205.png
Thanks for your reply. Yes my settings as as per your suggestion. Unless I am mistaken, this allows it to snap how it is in the start of the video before changing files? 

Share this post


Link to post
  • 0

Sometimes, disabling ALL snapping options in the snapping palette, restarting Vectorworks, and then re-enabling the options will reset this. If this does not work, please let me know.

Share this post


Link to post
  • 0

Is it a file you can share? I'd be interested in seeing that.

Bit odd!!!

 

Share this post


Link to post
  • 0
2 minutes ago, RussU said:

Is it a file you can share? I'd be interested in seeing that.

Bit odd!!!

 

Hi Russ, 

 

Not a file I can share unfortunately. If the issue persists, I may have a go tonight at stripping any private data from it and then sharing 

Share this post


Link to post
  • 0
7 minutes ago, Jim Wilson said:

Sometimes, disabling ALL snapping options in the snapping palette, restarting Vectorworks, and then re-enabling the options will reset this. If this does not work, please let me know.

Hi Jim

 

This didnt fix it unfortunately 

 

Thanks

Share this post


Link to post
  • 0
6 minutes ago, rexwexford said:

Not a file I can share unfortunately. If the issue persists, I may have a go tonight at stripping any private data from it and then sharing 


That is very strange, if you can, send the stripped file to tech@vectorworks.net and they can take a closer look. Files are kept confidential however through tech support, and they will destroy their copy right away after troubleshooting if needed.

Share this post


Link to post
  • 0

 

2 minutes ago, Jim Wilson said:


That is very strange, if you can, send the stripped file to tech@vectorworks.net and they can take a closer look. Files are kept confidential however through tech support, and they will destroy their copy right away after troubleshooting if needed.

 

thanks

 

Interestingly, that file is working ok on another machine.

 

Other then resetting the resetting the smart cursor settings, is there anything else that could be directly related to my machine? 
 

Thanks 

 

 

Share this post


Link to post
  • 0

If it is isolated to one machine, (barring any other applications that deal with screen UI that might interfere, but i would expect that to then cause the problem on all files on that machine)  then this is the more invasive procedure that may help, follow the instructions included to back things up first, but dont restore the backups until youve tested to see if the issue still occurs:
 

 

Share this post


Link to post
  • 0

Can I suggest one thing. It might not work, but worth while trying.
in your workspace editor, under the "keys" tab, is a "Suspend Snapping" key, usually mapped to an apostrophe.

Clear that or change it to something else and see if that helps the issue.

I know that my graphics tablet on occasion sends odd keystrokes, which can be problematic.

Share this post


Link to post
  • 0

Behaves as normal here,  but I'm on PC and I note that it's from an older version of VW, which version and service pack are you on, I'll back save and re-post

 

Share this post


Link to post
  • 0

 

19 minutes ago, RussU said:

Can I suggest one thing. It might not work, but worth while trying.
in your workspace editor, under the "keys" tab, is a "Suspend Snapping" key, usually mapped to an apostrophe.

Clear that or change it to something else and see if that helps the issue.

I know that my graphics tablet on occasion sends odd keystrokes, which can be problematic.

 

tried this with no luck. 

 

increasingly confusingly the file that i removed the info from is now working for me too! original one still not working. 

 

wonder it is reference related? I removed these before sharing 

Share this post


Link to post
  • 0
2 minutes ago, rexwexford said:

 

 

tried this with no luck. 

 

increasingly confusingly the file that i removed the info from is now working for me too! original one still not working. 

 

wonder it is reference related? I removed these before sharing 

Scratch that, it isnt working afterall 

Share this post


Link to post
  • 0

Ok so an update, 

 

weirdly I have noticed that this issue seems to happen when I have a document open, as well as an unsaved new document. 

 

For example. If i open vectorworks and it has a default blank file, and then I open my file and leave the blank file in a closed window it wont snap. If i then close that window ,the file works. Must be some kind of bug?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...