Jump to content

Dual Monitors - Palettes Won't Stay Put


Recommended Posts

I have a 15" Macbook Pro linked to a larger monitor/TV display. I've successfully used this dual-monitor setup for Vectorworks in the past, with the main drawing on my laptop display and the palettes shuffled over and arranged on the external display. The palette positions were saved and they more or less always stayed there, unless of course I disconnected the monitor.

I've rearranged things and want to use the larger monitor as my main drafting window, so today I set up the document and moved all my palettes over to the MacBook display. They won't stay there. If I click out of Vectorworks to another program, the palettes move themselves over to the other display when I come back. The only way I can keep my palettes on the Macbook display is if my drawing window is there too.

This behavior occurs regardless of whether or not I have "Displays have separate spaces" checked. I upgraded to VW 2015 SP4 today, but it was happening in SP3 as well. Running OS 10.9.5.

Am I missing something? Am I trying to do something that won't work?

Link to comment
  • Vectorworks, Inc Employee

I have seen this most often when using multiple spaces, Vectorworks often resets and regathers the palettes back into the main screen or to one of the screens on the main space.

Most likely this isnt anything you've done wrong, I've submitted a bug report on this behavior. I will add this thread to it.

Link to comment

I don't know how it works on Apple machines, but in Windows you can specify the main and secondary screen. Depending on the driver it sometimes gets changed for whatever reason after connecting/disconnecting some monitors/projectors then your windows will end up on the wrong screen or may not be visible at all when you are back on a single screen/monitor.

You may want to check your display settings for which screen is defined as main and which as secondary and whether this has changed when you run into this problem. Attaching a secondary monitor may be necessary to put things back to normal when changing the settings.

Link to comment
  • 1 year later...

I had a similar issue. For me it was the Windows Monitor change size from 100 % to 125 % which made it buggy for me. One monitor had 125%, the other had 100%. Then it automatically sent pallets to strange places when trying to adjust them. 
FIXED when I put both monitors to 125 %.

Link to comment
  • 4 years later...

6 Years later, and this appears to still be an issue. I am now using VW2021 on Mac OS 10.14.6 (Mohave). I just started using two monitors for the first time in a several years. We will be replacing our computers with new Macs and using VW2022 by the end of the year. Hopefully that will resolve the problem.

 

Thanks for all your comments above.

 

Ed

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...