Jump to content


Recommended Posts

When using Spotlight’s “Modify Lighting Instrument Color,” set by “lighting Instrument” is it possible to set it so it ONLY will modify the pen color?

I tour with a small company and I do a lot of work where I’m modifying an existing lighting hang, so whenever I add/move/change a unit from it's rep, I give the changed unit a thicker, red outline. This works just fine, but I run into problems when using 750w source 4s. When I turn on the Spotlight "Modify Lighting Instrument Color" toggle, it paints the whole unit with a single fill, thus nullifying the 750 Black Cap and making all of the lights look the same. This makes is very difficult to:

A) Distinguish 750w units from the standard 575w units.

B) It makes the units on the drawing not match the units drawn in the Key.

I'm including two images that should help explain what I mean:

The first is with the Modify Lighting Instrument Color toggle turned OFF. The units are normal and it's easy to distinguish which units are 750w vs standard 575w.

The second is with the Modify Lighting Instrument Color toggle turned ON. It is now clear which units have been added, but their fills are all the same, so it is visually impossible to discern which are the higher powered units.

I'm aware that I can only modify the Pen if I chose to use the unit's gel color, but that is not what I want to do.

If anyone has any thoughts on this, they would be much appreciated.


Link to comment
  • Vectorworks, Inc Employee

Once you select the "Lighting Instrument" option all attributes follow the attribute palette.

The only other option you have is to place the black caps in a separate class and set the "Modify only geometry in the class" to "None", assuming the other geometry is in the "None" class.

Draw the cap with a solid fill but no pen so the pen color from the main body will show through.

Link to comment

I had a similar issue,

imported dwg, converted Fixture symbols using the convert to instrument command. Everything worked as expected but the modify Lighting instrument

color option did not.

you need to attach the light info record to the symbol in the RB first and replace all

imported/converted symbols in the drawing with this symbol. this worked for me.

I don't know if it's a bug.

best Jim

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...