Jump to content
Developer Wiki and Function Reference Links ×


Recommended Posts

  • 2 weeks later...
  • Vectorworks, Inc Employee

For 2012 the DebugModule in the download contains the compiled version of dialog builder that will work to generate either SDK or VS dialogs. There is no source code that needs to be compiled in order to run dialog builder.

I think the reference to '\AppSource\Source\Plug-Ins\Debug\Debug Projects.sin' applies to older versions.

Link to comment
There are also some VectorScript plug-ins that get created when VectorWorks starts from the Dialog Builder Library. These plug-ins are placed under your user folder: \Application Data\Nemetschek\VectorWorks\13\Plug-ins

What does it mean that 'VectorWorks starts from the Dialog Builder Library'

When should these Plugins get created?. I can't find any in my plug in library.

It would be simple to provide a .zip with the plugins which need to be copied to the plugin library.

Edited by Assembly
Link to comment
  • Vectorworks, Inc Employee

I tested the files for Windows and since there is only one workspace you may need to make one for the Mac. Try adding the commands to the workspace manually.

The files in the zip are the files that are needed, just supplying the VS files will not be enough.

The VS files will automatically be created in your user folder by the Dialog Builder Library.vwlibrary when Vectorworks is launched after adding the files from the zip to the plug-ins folder, for 201 it should be HD > Users > (User's Home Folder) > Library > Application Support > Vectorworks > 2011

Link to comment

Thanks Kevin-

I had put the files in a secondary user folder.

The packet has expanded, all the PIO's are now in the user folder.

The workgroup loads fine.

The menu commands are there and work.

However I have trouble with three of the plugins.

Dialog Builder Test Run & Dialog Builder Tools

return an error that says they are not in the plug in folder.

The Plug Ins are in the Plug In folder.

Using the VectorScript Editor- they do not appear in the editor list. Nor can I see them in the workspace editor.

This is repeated on two of my laptops.

A 'Fresh' user folder has been created, and the process repeated. I assume that the Programe Folder does not have edited files- thus this would be similar to a reinstall of the software?.

Can you please check on the fresh install you did on your mac that these PIO's are working?.

Thanks for your help

Link to comment
  • Vectorworks, Inc Employee

I put the plug-ins from the zip directly in the application plug-ins folder and they all work fine.

I'm not sure that placing the plug-ins in the user folder will work correctly. The extra level of directory structure may not let the plug-in access the necessary files.

Vectorworks is designed to look for plug-ins in sub-folders but plug-ins do not automatically look for sub-folders or attempt to find the application automatically.

So try deleting the existing plug-ins and placing them directly in the applications plug-ins folder.

Link to comment

I've tried everything I can think of except reinstalling VW itself.

VW does not think the two plugins are in the folder- but they are.

I note that there is a strange naming thing going on.

The PIO that I'm clicking on in the Dialog Builder Workspace is named 'Dialog Builder Tools'. In the workspace editor there is a 'Menu' object called Dialog Builder Tools. When this is added to the work space it includes all the 9 but no 'Tools'

I notice that every time that VW starts the plugins get regenerated.

I tried creating a new plug in with the same name so that the PIO gets registered. This allows me to click on the PIO with out getting the error message, but on restart the PIO is regenerated and I get the same errors again?

Josh, what is the permissions checking that you mention?.

I will try a reinstall of VW when I get a free chance.


Edited by Assembly
Link to comment

I have now tried this on 3 of my computers + 1 reinstall.

I get the exact same problem as above.

So there is ether some thing a miss with

1) OSX permissions as Josh suggested.

2) VW package on the website.

3) Something else that I have no idea about.

Any help would be appreciated.

Can someone using VW2011 on mac please try install the DB6 Tools with the build currently at:



Download the tools: Copy them to your user folder.

Link to the Mac Tools


Download the Workspace and copy to your user workspace folder.

Link To the Workspace


Restart VW, the plugins will get generated in your user plugins folder.

Select the works space: Dialog Builder.

Click on the third & fourth icons in the 'Sample Pallet' if you don't get the error message then I can rule out any problems with the installer of the DB packets.

Link to comment

I have finally got this working- to an extent.

I created a new user folder. Then added each plug-in individually adding it to the work space. I have most things working. The Run Test Tool and Build tool do not work.

I created my own menu command to create the Dialog Builder Test Run tool.

I think I have recreated all functions that did not install correctly.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...