Jump to content
Sign in to follow this  

Combine Into Surface - Polyline disappearing

Recommended Posts

Hello All,

I am running 11.5 on an XP machine. I have a PIO in which I am doing a few Combine Into Surface ops to finally get the required object shape. When run, the resulting polyline is invisible. The only way to display it is to manually hatch/fill it. I have tried to SetFPat within the code, but it does not matter.

I am doing tons of other similar stuff within my system, and this does not happen at all. It seems to be directly related to the CIS operation.

Any hints on what is going on would be appreciated.



Share this post

Link to post

Has the PIO script ever worked properly? Or did it break recently.

It is likely that you are not getting a handle to the correct object after the CIS. I am not certain, but it is likely that the CIS is not considered an object created by the Vscript, so the LNewObj command will not get you a handle.

Could you reset the default attributes before you do the CIS and then set them back?

Or place another object (locus), get a handle to that and then to the Previous Object and then delete the locus?

Share this post

Link to post

I've never used CIS, but this might be related to clip surface where the result of the operation is not LNewObj as Pat suggests.

You might be able to use LNew just before the combine command, and then use NextObj after the combine to get a handle to the resulting polyline. That's one way around the clip surface situation.

Share this post

Link to post

It's a weird call. I'd use another one if I was you.

I dislike that it needs a selection and doesn't allow for a handler.

Run first a AlrtDialog(Concat(temp_h <> NIL)); where temp_h is the resulting handler from CombineIntoSurface.

I see this failing if

* sel objects are not overlapping the point

* objects overlap but are not selected

Ugly routine.

I am sorry but I cannot test any longer under VW11. I guess if the handler is not NIL is the first thing you checked. ResetObject fails to regen?

If you can manually fill it, it must be a regen problem, and the handle cannot be NIL. I can fill it no problem in VW 2009.


Edited by orso b. schmid

Share this post

Link to post

Pat, Charles and Orso,

Thanks for the feedback. It was definitely a handle issue. I worked around it by doing some clipping rather than all the CIS calls. It's ok for now.


Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  


7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114


© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

  • Create New...