Jump to content

Shell Tool

Recommended Posts

John, I'm surprised to see you say that because I've found the shelling in VW 2009 to be much more robust and reliable. Objects that just wouldn't shell in VW 2008 shell fine in VW 2009. Are you able to post a file containing sample objects that you want to be shelled (with clear instructions of course)?

Link to comment

I am working on a very complex shape at the moment and I have two issues. I need to infill the space within the 'horseshoe' with a solid that will be a cushion once complete. I have yet to find a way to create this shape though I had assumed I could loosely draw a nurbs surface by snapping to points and then shell it about 4" thick.

I'd be happy to upload an image though the slightly new format here has be uncertain how to do that to.

Link to comment

Try this:

- Use the Extract Curve tool to get the horseshoe nurbs boundry.

- After extracting the curves ungroup the resulting group.

- Complete the nurbs curve boundary using the Draw Nurbs tool (use 1 degree and by interpolation points).

- Select all of the bounding nurbs curves and compose them into a single object.

- Create a nurbs surface from this nurbs curve. (3D Power Pack sub-menu).

- Use the Shell tool on this surface to give it the required thickness.

I know its long winded and not very intuitive but it works.

Link to comment

I am unable to extract any nurbs lines or surfaces from this object? I already tried what you are asking. How do you upload here Mike. I'll show it to you?

I tried to draw the nurbs surface by hand but that's a nightmare especially given the horseshoe shape is not flat.

I'm baffled and nearly out of time for an online submittal...


Link to comment
Guest Wes Gardner

To upload, you have to use the "New Reply" option, not the Quick Reply at the bottom...

Once you click on New reply, go to File Manager (mine shows up in blue near the bottom) - you'll see a Browse and Add File function, etc.

Link to comment

Thanks for the guidance on adding files. Would not have easily found that! Given the intensely graphical nature of VW I figure that ADD FILE would be a bit more prominent...but that's just me.

Ahhh, I just found the ADD IMAGE icon in the tool bar above the text window....Excellent.

IMAGES: The first image is a prototype concept image for a very interesting piece of furniture I am developing. The 'horseshoe is the door which when folded down becomes a leg rest like a lounge chair. This shape is an 'Extrude along a path' that was created by extracting a path from the missing slice of he egg (shaped like a tongue) and creating a frame which will surround the cushion. I am unable to create the cushion and it's very challenging to create a working plan accurately for this object.

PROBLEM: The SHELL TOOL does not work at all and none of off the ADD / SUBTRACT or INTERSECT solids is appropriate for this solution.

What must I do to repair the shell tool? Is there a preference file that needs to be trashed?

QUESTION: Does version 2009 allow for the snapping of nurbs or 3D polys to en existing 3D object? AS many of you know, you find that you snapped to some point in the distance quite often once you rotate your view.

Link to comment

By the way and with all due modesty. I am not an Apprentice with Vectorworks as my LOGIN Data suggests. I have been using this application for a long time. Repeatedly in the past I have had my account data not be recognized by the online system so this is my 4th or 5th account with the VW Tech Board over the years. It's almost two years old!

Link to comment

Blink the Parasolid modelling kernell is more robust and capable than the VW 12.5 kernell, making it possibe to model things that simply couldn't be done before. The type of modelling you are doing would benefit from using VW 2009.

A query on your egg object - how did you form the hole in the original egg shape? Perhaps there is an opportunity to replicate the process to that point and diverge so that you create the door object instead.

Link to comment

Going back to your original post, I would not expect the Shell command to work on an extrude. It is already a solid, not a shell that you can add thickness to.

On your horseshoe, I can't tell from the picture, is the horseshoe hollow? How did you make it? If you did an extrude along path, then it is going to be a solid and will not shell. If you do a loft so you can get just the surfaces, then you should be able to shell them.

Remember, Vectorworks implements both solids modeling and surface modeling. It is pretty good about going back and forth, but there are some things that just don't make sense, like trying to shell a solid.

If you want the shell on the outside, perhaps you could duplicate the object and scale it up to the outside dimension and then do a subtract solids. Or scale it down to the inside and subtract solids.

Or duplicate the object you extruded, resize it and extrude again and subtract solids.

Link to comment

Thanks guys for the input.

I made the opening in the egg by slicing it in plan view after rotating the egg's thin skin profile using SWEEP. The result was a 3D tongue if you will from which I extracted a curve on three side to make the horseshoe.

I had to delete about 5 million handles on the path to make it work. Isn't there a simplify poly tool for nurbs? Geeez, that took 1.5 hours of deleting handles.

From the path I created the horseshoe shape so it is not filled in the middle. That is what I need is a fill in the middle in order to create a cushion like the one you see in the egg. The orange line on the horseshoe was my attempt to hand draw a nurbs surface by snapping to points. It did not work too well!

SHELL TOOL: I tested it on the most simple object, an extruded rectangle, and it did not work either so I feel it is corrupted somehow.

"there are some things that just don't make sense, like trying to shell a solid" I have done this many times before like with lampshades and flower pots etc..

"perhaps you could duplicate the object and scale it up to the outside dimension and then do a subtract solids." That is precisely how I created the inner and outer layers of the egg because that too would not shell.

I am unable to create an object that can be ADDED, SUBTRACTED, INTERSECTED, SHELLED or PROTRUDED to give me the infill I need inside the horseshoe. If I could shell, I would use the original 3d tongue to slice it flush with the top of the horseshoe.

"Hopefully someone with more nous can provide some advice to you on how to proceed. " Where can I get some of that nous? LOL

Link to comment

Shell works fine in VW2009. The shelled egg parts in the image below took me about 3 minutes (including thinking time).


- Draw an oval in front elevation view.

- Split the oval in half with the Split tool and discard the left half.

- Sweep the remaining half to create a solid egg.

- Switch to Top/Plan View and draw a guide line where the solid egg is to be split.

- Split the solid egg with the Split tool, and then delete the guide line.

- Open the view up by rotating the two parts so they are at right angles (so you can see the shelling result).

- Use the Shell tool to shell each of the solid egg parts.

- Change the fill colour of the two parts and render in Final Quality Renderworks.

PS - its taken me longer to type out this post!

Link to comment

Blink, complaining about what a two version old program can't do won't achieve much. You can either:

- Stay with VW 12.5, battle with its modelling kernel limitations, and possibly not get done what you need to get done.


- You can upgrade to VW 2009 and take advantage of its superior modelling kernel, and probably get done what you need to get done.

Its your decision at the end of the day.

Link to comment

Mike, do you work for Nemetscheck and are you independently wealthy? I am certain a few years ago Vectorworks users were resolving this problem without the new kernal as well the shell tool in their version 12.5 was functional.

For the record I am not complaining. I have inquired HOW DO I RESOLVE an ERROR with the shell tool as well requested a work around given a deadline that has passed.

Are you kidding me about questioning my effectiveness? Is this how you joined the 2000 club? You have already stated you do not have an answer. "Blink, complaining about what a two version old program can't do won't achieve much." What is the effect of that hollow statement? What's your point? Buy a solution? So how do you solve problems once you have the latest release? Gimme a break!

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...