Jump to content
Sign in to follow this  
BandA

vw2008 & Leopard - Memory Sinkhole?

Recommended Posts

I am on os 10.5 and vw2008 sp1 and i am finding that while rendering a relatively simple viewport in hidden line rendering (one which rendered in 12.5.2 and vw2008 on os 10.4.10 ok) the active memory usage shoots through the roof (up toward 2 gig) and then vw punts me out of the application saying 'insufficient memory to complete task' or something similar.

i am also finding that the longer i use vw2008 sp1 during a given session, the amount of active memory usage inches up toward 2 gig which never happened in os 10.4.10.

i am on a macbook pro, 2.33 c2d, 3g ram, osx 10.5

anyone else had similar experiences?

Share this post


Link to post

it appears that the only rendering mode i could find this in is 'hidden line'.

this is a fairly crucial part of my work flow and i am dead in the water without hidden line viewports.

has anyone had the same problems? has nna found these problems as well?

Share this post


Link to post

though, to keep adding to my rambling thoughts, i've also noticed that vw2008 takes up a LOT of memory in leopard. anyone else found the same?

Share this post


Link to post
Guest

Can you please send all this info to bugsubmit@nemetschek.net?

If you have a sample file you would like to provide, that would be extremely helpful.

Share this post


Link to post
Guest

PS - you may want to update your signature and change VW !2 to VW 2008

Share this post


Link to post

i'll send the info in a sec. what if my sample file is large (~150 mg)? do you have a server i can upload to? i can't really attach that to a email.

Share this post


Link to post
Guest

Stuff it to see if you can get it down to 100 mb. If you can, send the file using yousendit.com

If you can't, send me an email and I'll reply with FTP information.

Share this post


Link to post

Before sending a huge possibly sensitive client file...

why not first try send off a simple Console Log report or

use one of the Developer tools to punch-out the memory issues and report them ?

Tech can tell which procedure to use to best meet their needs .

~/Developer/Applications/Performance Tools/

Share this post


Link to post
Guest

Go ahead and send the file. We want to look at the actual file.

Share this post


Link to post

There is an active bug for this issue, so we have several files we're already looking into. The odds are good the cause of problems with those files is the same as with your file. So if you haven't sent it in already and would find it difficult, you may want to hold off.

Share this post


Link to post

Thanks Andrew. I did send the file already, so hopefully it will help. For what it's worth, most rendering modes seems to have trouble to a certain extent, but the one that had the most problem was Hidden Line.

This is especially the case when cutting Section Viewports.

Share this post


Link to post

I am having the same problem doing an animation in hidden line rendering. Has this memory problem been solved yet?

Share this post


Link to post

This problem has been driving me crazy for some time. With the amount of memory that I have (10 GB) it is very frustrating when an application says it is out of memory.

The memory leaks in VW2008 are very serious. Memory grows every time you render something and is not fully released. After a while VW either crashes or you get messages that indicate that you have run out of memory, or you see nothing until you look at your console log and VW is trying to fill up your disk with messages like this:

6/21/08 3:29:07 AM VectorWorks[541] VectorWorks(541,0xf42ce000) malloc: *** mmap(size=27840512) failed (error code=12)

*** error: can't allocate region

*** set a breakpoint in malloc_error_break to debug

6/21/08 3:29:07 AM VectorWorks[541] VectorWorks(541,0xf4350000) malloc: *** mmap(size=27840512) failed (error code=12)

*** error: can't allocate region

*** set a breakpoint in malloc_error_break to debug

6/21/08 3:29:07 AM VectorWorks[541] VectorWorks(541,0xf43d2000) malloc: *** mmap(size=27840512) failed (error code=12)

*** error: can't allocate region

*** set a breakpoint in malloc_error_break to debug

6/21/08 3:29:07 AM [0x0-0x5f05f].net.nemetschek.vectorworks[541] VectorWorks(541,0xf42ce000) malloc: *** mmap(size=27840512) failed (error code=12)

6/21/08 3:29:07 AM [0x0-0x5f05f].net.nemetschek.vectorworks[541] *** error: can't allocate region

6/21/08 3:29:07 AM [0x0-0x5f05f].net.nemetschek.vectorworks[541] *** set a breakpoint in malloc_error_break to debug

6/21/08 3:29:07 AM [0x0-0x5f05f].net.nemetschek.vectorworks[541] VectorWorks(541,0xf4350000) malloc: *** mmap(size=27840512) failed (error code=12)

6/21/08 3:29:07 AM [0x0-0x5f05f].net.nemetschek.vectorworks[541] *** error: can't allocate region

6/21/08 3:29:07 AM [0x0-0x5f05f].net.nemetschek.vectorworks[541] *** set a breakpoint in malloc_error_break to debug

6/21/08 3:29:07 AM [0x0-0x5f05f].net.nemetschek.vectorworks[541] VectorWorks(541,0xf43d2000) malloc: *** mmap(size=27840512) failed (error code=12)

6/21/08 3:29:07 AM [0x0-0x5f05f].net.nemetschek.vectorworks[541] *** error: can't allocate region

6/21/08 3:29:07 AM [0x0-0x5f05f].net.nemetschek.vectorworks[541] *** set a breakpoint in malloc_error_break to debug

6/21/08 3:32:01 AM com.apple.launchd[138] ([0x0-0x5f05f].net.nemetschek.vectorworks[541]) Exited: Terminated

I had to kill it (the last line).

My workflow is totally messed up. I have to monitor memory whenever I am updating viewports and quit and restart as soon as memory usage gets to about 1.5 GB (sometimes lower).

I have submitted a bug report, and except for the comment above, I have never heard anything about this from NNA.

Love the program, hate this problem.

RonMan

Share this post


Link to post

I upgraded to SP3 but that didn't help. So I guess this problem has not been solved yet? *sigh*

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

 

7150 Riverwood Drive, Columbia, Maryland 21046, USA   |   Contact Us:   410-290-5114

 

© 2018 Vectorworks, Inc. All Rights Reserved. Vectorworks, Inc. is part of the Nemetschek Group.

×
×
  • Create New...