Jump to content

Stair PIO Settings will not display!

Recommended Posts

The settings dialog box for the Stair PIO no longer displays. I have a building with multiple stairs and now cannot configure them beyond what you can control in the Object Info palette.

I hope there is a quick fix and this is not a file corruption issue.

Please help.

Link to comment

I have just experienced exactly the same problem. The problem occured when inserting a second set of stairs on the next floor. Both sets of stairs could not be edited in the settings dialog. I deleted the second stair and started again. This time when I clicked the stair tool and then the settings button the dialog also failed to appear. I also am experiencing another problem with the second floor stairs. When setting the floor to floor heights based on Mod-floor-1 (lower) and Mod Floor 2 (upper) the data below gives a negative floor to floor height and a negative number of risers! When the apply button is clicked the stair diagram disapears and a note comes up saying "Flr to Flr height does not allow any risers" (the layers are stacked in the right order)I then tried to reset the height manually and diagram failed to return. I then clicked cancel and the PIO closed and a Script error dialog poped up. Unfortunately this dialog did not allow me to copy the text so I cant post it. This means I only have the option of manually setting the flr-flr height which then does not allow me to control the appearance of the stair on the mod floor 2 layer. This is very frustrating as this did not occur on the mod-floor-0 to mod-floor-1 stair. The another anoying feature with this PIO is that if your second stair is a different basic shape from the first one, you can't change it in the setting dialog, but have to find the new shape in the rescource browser. Why???

Edited by seanSF&A
Link to comment

I have just retried the insertion of the second floor stair and the same problem of negative flr to flr heights re-occured. Again, when resetting back to manually setting height, the diagrame does not reappear and the note remains. When clicking either ok or cancel the PIO closes with the following script error message pops up:

Error: _300 _3 - index outside array limits

Error: _7190 - END GROUP Statement missing

Error: _7190 - END SYM Statement missing

Error: _7190 - END GROUP Statement missing

then an s with a v above it and a letter looking like an A and E stuck together

In trying to affect the elevation setting by changing design layer stacking orders I get seemingly random total heights and numbers of risers both positive and negative regardless of which layer elevations selected. and this has now affected the first stair which was seemingly ok. The stair PIO is now unusable if I set the overall height using layer elevations becase the stair disapears and I'm left with the note "Flr to Flr height does not allow any risers"


Edited by seanSF&A
Link to comment

I have found the same problem when using a negative floor height value in the design layers. I now use only positive values and the stairs work fine. One note with the stair PIO...once you have an issue with the stairs than you will not be able to edit the stairs again until you re-start VW. I have also run into the stair PIO adding risers to the when you use the show risers function for upper and lower floors. The function added the total number of risers in the entire stair. I asked for 10 to show on the first floor and all 17 to show on the second. The PIO built the stairs with 27 risers....! I deleted and built a new set. Wierd!

I think the stair PIO need more work to get it right.

Link to comment
  • 4 weeks later...


i've got the same problem...

on an 8 storey building, with every floor/floor height being different it isn't a joke....

once one stair goes "rotten" they are all buggered.

sometimes exiting VW will sort it out, sometimes not...

i set up the first flight as i want it, using height by layer elevations, <layers set up via 'model setup'>

and then either duplicate in place + set the upper + lower for the next floor up or copy the original +

paste in place on the next floor up + reset the upper + lower for the new floor. either way it bombs out eventually...

i'm going to try doing each staircase from scratch but am not hopeful...

basically the stair pio aint fit for use...

Link to comment

I was about to post about a stair problem when I saw this post. My stairs (5 sets) have been in place for about three weeks, but when I tried to edit one this morning, another one disappeared. The edit dialog box comes up each time, but when I edit and close it, the same set of basement to first floor stairs is gone. The edit dialog also shows "no flr to flr height, so no risers". The set that disappears is the only one set to get its hgt from layer hgts. One other short set also shows a "0" in the OI for floor hgt.


Link to comment
  • 2 weeks later...

Robert, sorry for the delay, version 12.0.1, Win XP Pro, AMD X2 +4400, 2GB RAM, GT6600

It just happened again in a new file, tried to create a third stair and it refuses to show the stair in the preview pane - and this one did not have a negative value - clicked apply and got the following bug report:

Error: _300 _3 - Index outside array limits.

Error: _7190 - ENDGROUP statement missing.

Error: _7190 - ENDSYM statement missing.

Error: _7190 - ENDGROUP statement missing.


Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...