Jump to content

VW2013 won't export DWG


Recommended Posts

VectorWorks2013 on Windows10

 

I posted the problem below on the Technical Forum, but nobody had a solution to the "Teigha LIbrary" problem. So, here I'll just focus on the more immediate difficulty. I just emailed a complete set of final PDFs to the Architect client. Now he's requesting DWG files, so he can make future changes without me. In the past, this was not a problem, other than the usual minor translation issues. But now, I'm stuck on top of the Tower of Babel.

 

I'm guessing the "Teigha" issue is due to the obsolescence of VW2013. I recently bought a set of European hatches, but they wouldn't import. And I was told the app would only work for five years back from current version. I downloaded the ODA file converter to update the Teigha library, but it had no Readme, or instructions, so I was lost.

 

I've tried every way I know to get VW to produce a DWG file. I even did a test of the Zamzar online file conversion app. But the downloaded DWG didn't show proper line weights, when opened in the DWG viewer NanoCAD. Since I'm a penniless retired Architect, offering drafting services for a fee, this situation is embarrassing. So, I would appreciate any practical suggestions. Thanks

 

 

ORIGINAL POST

"Exporting from VW2013 to AutoCad DWG2013. Got "Teigha Library Error" message. Tried 2011-2013 ; 2007-2008-2009, 2000 - 2002 ; and got same error. Filenames have no forbidden characters. Associated files were copied to the folder, but no DWG file. I don't know what the Teigha Library is. But I haven't had that error before. How could Teigha be "open in another application? I assume it's part of VW2013.

 

Yeah, I know 2013 is old, but I am too. Long retired, only do a couple of projects a year. Got 17 drawings to export. So any suggestions will be appreciated."

Teigha Error.JPG

Link to comment

Try reinstalling VW. Perhaps there is corruption in the library that is causing the issue. 

Try exporting to DWG2012 instead of 2013.

 

I doubt that updating the library to a different version than what shipped with VW2013 will help. It will probably make matters worse.

 

Link to comment
17 hours ago, Pat Stanford said:

Try reinstalling VW. Perhaps there is corruption in the library that is causing the issue. 

Try exporting to DWG2012 instead of 2013.

Pat

Thanks for the suggestion. I'm leery of replacing an installation that has been working well (with a few exceptions) for over a decade. To avoid burning my bridges, I'll probably start by renaming the VW folder, with Preferences & Workspaces, that I can go back to if necessary. But if I don't uninstall the old program, it might leave some separate items that could become an issue with the new install. Do you know of any other precautions to take before making such a drastic leap into the unknown?

Link to comment
Posted (edited)
On 6/24/2022 at 5:48 PM, Pat Stanford said:

Try reinstalling VW. Perhaps there is corruption in the library that is causing the issue. 

Try exporting to DWG2012 instead of 2013.

I have reinstalled VW from the original disks. And the new install works correctly, except it won't export a DWG file. I even did a Batch Export, and got the same error. I'm exporting to DWG2000 -- 2002.

 

The error message says "make sure the file is not already open in another application". The only app running is VW.

 

I've tried all the Google search suggestions up to 2021. I even downloaded a "TEIGHA viewer" as suggested for a SketchUp user (below). But it seems to be intended for an IT pro, and with no instructions, I couldn't make sense of it. I can't find any files in the VW2013 folder related to TEIGHA, so I don't know where the error message originates. I tried to post on the OpenDesign Alliance support website (TEIGHA), but it wouldn't let me log-in.

"SketchUp3D_de

you can always use the free ‘Teigha Viewer 187’ for evaluating the readability and content of a DWG/DXF as well as down-saving to an older version (e.g. r2000 compatbile w/ allmost everything)."

 

I've been spinning my wheels for several days. And VW TechSupport is not available for VW2013. So the User Forum is my only source of traction. Again, any useful suggestions will be appreciated.

 

PS__ One temporary fix is to upload the 17 drawing files to DropBox, and have someone else export them to DWG. My client may not like for others to see his drawings. But I'm running out of options. So, If someone volunteers, I'll ask his permission.

 

Edited by JHEarcht3
Link to comment
6 hours ago, Pat Stanford said:

VW2013 is listed as compatible with Mac OS 10.7 to 10.11 (Snow Leopard to El Capitan).  If you are running one of those OS's I don't know why it is not exporting.

 

If you can get permission, I will make you DWGs and PDFs.

Pat

 Thanks for the offer, but my VW is running on Windows 10 (I know, I know), so you may not be able to open the file.

 

I just reinstalled VW2013 from original disks. And it is hogging memory & CPU, so VW runs very slow, with lots of spinning blue wheels. Since the reinstall didn't help the DWG problem, I may have to go back to the old install. I just made a lot of revisions despite the spinning wheels, so my head is spinning. I'll check in again tomorrow.

 

PS___It's possible that the 38MB VWX file I'm working on is corrupted after all the DWG problems. So I'll work on that manyana.

Link to comment

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...